cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

LMS 3.1 - CW-Backup takes very long

lo.mueller
Beginner
Beginner

Hi there,

we discovered a very long dbbackup of LMS-DBs (longer than a day).

Troubleshooting the source of the problem aims to validation of HUM-Database with command dbvalid (the upm.db database has a size of over 8GB).

Is there a problem with backup.pl script handling this "huge" amount of database size?

Is it recommended to comment out the dbvalidation in backup-script to speed up the backup-process?

Thanks for you ideas.

Lothar

5 REPLIES 5

Joe Clarke
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

It's not a problem with the Perl script, but an issue with the database engine. We found this same kind of time lag with LMS 3.1 data migration when it came to large databases. No, it is not recommended to disable database validation as that is the way to determine if a database is consistent when backed up. Turning that off may make the backup complete faster, but you would not know if the data backed up could be properly restored.

Hi Joe,

it seems that after restarting LMS-Application dbvalidation in backup is much faster.

Is that explainable?

Maybe filled up cache, ...?

Thanks for your update

Lothar

Joe Clarke
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

No, that doesn't make sense since the verification is done on the BACKED UP database (i.e. a new engine is always started). What would make sense is if some other LMS process was taking a lot of CPU and further slowing down the verification process. A restart may have corrected that.

Hello guys,

We have problem with scheduled LMS 3.1 backup. It takes more than 12hours to finish. You can see in log that backup is scheduled for 18:00h and it waits untill 22:07 to start doing anything. We can't figure out why is there such a delay. It started to happen after system reported lack of free space on disk. And we feed up the space, but then faced this problem with long duration. Before this problem occured backup used to last for 45 min od 1 hour.

Backup to 'C:/BACKUP' started at: [Mon Apr 11 18:01:26 2011]

Apps file : D:\\PROGRA~1\\CSCOpx\\backup\\manifest\\campus\\properties\\datafiles.txt
[Mon Apr 11 22:07:07 2011] Archiving the contents of the following directories into C:\BACKUP\2\campus\filebackup.tar
[Mon Apr 11 22:07:07 2011] D:\PROGRA~1\CSCOpx\campus\etc\cwsi\DeviceDiscovery.properties
D:\PROGRA~1\CSCOpx\campus\etc\cwsi\ANIServer.properties
D:\PROGRA~1\CSCOpx\campus\etc\cwsi\ut.properties
D:\PROGRA~1\CSCOpx\campus\etc\cwsi\discoverysnmp.conf
D:\PROGRA~1\CSCOpx\campus\etc\cwsi\datacollectionsnmp.conf

Do you have any ideas what went wrong and how to fix it?

Thanks,

Marija

Joe Clarke
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Please start a new thread for your question.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: