cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
563
Views
0
Helpful
5
Replies
thongams2000
Beginner

LMS 3.2 netconfig telnet password configuration customization

I am trying to configure telnet vty password using netconfig. I want to make the configuration only for line vty 0-4 however I am not able to find a way to define the line numbers. Moreover it also has the login command added by itself.

The default configuration it shows is as follows -

line vty 0 %MAXLINENUMBER%
password *******
login %authentication default%
exit

 

And how I want to configure is as follows - 

 

line vty 0 4
password *******
exit

 

Please suggest if there is any way.

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Soniya

Your're quite correct, in thinking that this might not work. But lucky for you - it does work.

Simply paste the whole config you need in the ad-hoc tasks and deply it.

Like this:

 

line vty 0 4

password cisco12345

login

 

That's it, - no need to add "exit" either.

 

hope it helps. cheers.

Pierre

View solution in original post

5 REPLIES 5
Vinod Arya
Cisco Employee

Try to select the Adhoc task under General where you dont have to configure as per a predefined template, instead you can configure your own CLI command lines to be deployed on device.

-Thanks

Vinod

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Thanks Vinod for the suggestion. However, I had checked the adhoc option as well. In adhoc I have options to configure commands in enable mode or config mode but for vty I need to enter the line mode before i give the password command. Or may be I miss something here.

 

Regards,

Soniya

Hi Soniya

Your're quite correct, in thinking that this might not work. But lucky for you - it does work.

Simply paste the whole config you need in the ad-hoc tasks and deply it.

Like this:

 

line vty 0 4

password cisco12345

login

 

That's it, - no need to add "exit" either.

 

hope it helps. cheers.

Pierre

View solution in original post

 

Thanks Pierre. It worked :)

Soniya

Great to know it worked. I was sure you can simply configure it without thinking of submode.

-Thanks

Vinod

 

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Content for Community-Ad