cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
784
Views
0
Helpful
5
Replies
Mason Tu
Beginner

Message content of Automated Action in Prime LMS 4.2

Hi,

I am using Prime LMS 4.2 automated action to run a script sending out messages to SMS.

But the content of message is IP address not hostname.

Is there any option that I can change the IP address to hostname?

I have check the "hosts" file, there is a IP/hostname mapping.

But seems it's not enough.

Thanks!!!

5 REPLIES 5
AFROJ AHMAD
Cisco Employee

Hi ,

I am sure you are getting syslogs from your device with the IP Address ONLY.

check the syslog.log first.

 

To achieve your goal , you can follow the below steps:

- To configure that: * CiscoWorks side (windows Server ):

1.Go to Registry  (regedit)

2.Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\crmlog\Parameters

3.Change CrmDnsResolution=1(default is 0).

4.Restart crmlog service.     

net stop crmlog     

net start crmlog

* Device side:   

 logging origin-id hostname That will specifies that the hostname will be used as the message origin identifier

 

Hope it will help

 

Thanks-

Afroz

***Ratings Encourages Contributors ****

 

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Hi,

Thanks for your reply. I have followed your instructions.

But after I done that, the syslog stops unexpectedly.

The crmlog service is running but the syslog report is empty.

Did I do anything wrong?

Hi ,

 

-Share the screen shot of the registry showing the changes you have done .

-share the screen shot of ::Admin > Collection Settings > Syslog > Syslog Collector Status,

-follow the below steps:

pdterm SyslogCollector

pdterm SyslogAnalyzer

 

pdexec SyslogCollector

pdexec SyslogAnalyzer

 

then check the syslog.log

 

Thanks-

Afroz

 

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Hi,

I found the option in LMS finally, please check the attached file.

After I enable that option, I check the register value you mentioned.

That value is changed to 1 as you said. And the syslog report is normally now.

Thanks!!!

GREAT :)

Kindly resolve the thread

 

Thanks-

Afroz

**Ratings Encourages Contributors ****

 

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Content for Community-Ad