cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1968
Views
0
Helpful
5
Replies
parakiteiz
Beginner

NTP not working on Nexus 5548

Issue: I have bad NTP on my Nexus 5548 no matter what device I point it at. I pointed it at my GPS device to which it should see because I see the mac address of the GPS device when I do a sh mac add | in 254. I then pointed the Nexus 5548 at two other switches and still did not get it to change it's time.

I also have ntp logging turned on and no logs are hitting my logs.

IOS: n5000-uk.9-kickstart.5.2.1N1.5.bin

Model: Cisco Nexus 5548

Config for NTP:

ntp server server *.*254.80 use-vrf management

ntp logging

5 REPLIES 5
Mark Malone
Mentor

hi

are you using the oob mgmt. interface , if not remove the use-vrf section just have ntp sever x.x.x.x prefer , its only required for oob and it could be isolating the ntp address from normal route table

I have a oob mgmt interface configured but I do not want ntp to use it. I want ntp to use what it finds in it's mac cache since it see the ntp device there.  I changed the command to ntp server *.*.254.80 prefer but when I use the command sh ntp status I get:

Distribution:Disabled

Lost operational state: No session

Still wondering what the issue could be.

did you try set the source to be a loopback or something else in case ntp by default is coming off the mgmt. int when enabled , theres a few bugs In ntp in nexus aswell that were fixed in newer releases for 5ks , 1 I found for your release could expliain it

https://quickview.cloudapps.cisco.com/quickview/bug/CSCui34757

try add in clock protocol ntp aswell into config

Changing the default interface fixed my issues. 


Thanks!

Marvin Rhoads
VIP Community Legend

On nx-os you need to "commit" ntp changes after making them.

Try

ntp commit

...from configuration mode.

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5500/sw/system_management/6x/b_5500_System_Mgmt_Config_6x/b_5500_System_Mgmt_Config_6x_chapter_010010.html