cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1153
Views
0
Helpful
2
Replies
daniel4579329
Beginner

ospf neighbor not working

hi 

 

im learning for the ccna and im working on ospf and i cant make R2 to learn routes via ospf on port fa1/0 no i tried to do this via the network command and also via the command under the port can someone look at the packet tracer file and tell me what i dont see 

 

thanks for the help (:

2 REPLIES 2
Farhan64
Beginner

Hi,

 

YOUR FA1/0 IP ADDRESS IS NOT PROPER

 

Router#sh ip ospf neighbor

THIS IS WHAT FA1/0 IS SHOWING BEFORE CORRECTING THE IP ADDRESS

 

Router#sh ip interface f1/0

FastEthernet1/0 is up, line protocol is up (connected)

Internet address is 200.20.0.1/8

Broadcast address is 255.255.255.255

 

AND YOUR NEIGHBOUR TABLE

 

Router#sh ip ospf neighbor

 

 

Neighbor ID Pri State Dead Time Address Interface

10.12.0.1 1 FULL/BDR 00:00:36 100.0.0.1 FastEthernet0/0

 

 

 

Router#sh ip protocols

 

Routing Protocol is "ospf 1"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 200.20.0.1

Number of areas in this router is 1. 1 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

100.0.0.0 0.255.255.255 area 0

200.20.0.0 0.0.0.255 area 0

11.0.0.0 0.255.255.255 area 0

Routing Information Sources:

Gateway Distance Last Update

10.12.0.1 110 00:01:16

200.20.0.1 110 00:01:16

Distance: (default is 110)

 

 

 

Neighbor ID Pri State Dead Time Address Interface

10.12.0.1 1 FULL/BDR 00:00:36 100.0.0.1

 

 

YOUR IP WAS 200.20.0.1/8 and  

AND YOUR NEIGHBOR MASK IS  /24

 

OSPF routers cannot form neighbor relationship due to a mismatch in Hello or Dead parameters. Following parameters in Hello packets should match between neighboring routers:

  • Hello and Dead intervals

  • Area ID

  • Authentication type and password

  • Stub Area flag

  • Subnet ID and Subnet mask

 

SUBNET MASK WAS WRONG.. CORRECT IT

Router(config-if)#ip address 200.20.0.1 255.255.255.0

 

Router#sh ip interface f1/0

FastEthernet1/0 is up, line protocol is up (connected)

Internet address is 200.20.0.1/24

Broadcast address is 255.255.255.255

 

 

 

here is your neighbour table

 

Router#sh ip ospf neighbor

 

 

Neighbor ID Pri State Dead Time Address Interface

200.20.0.3 1 FULL/BDR 00:00:35 200.20.0.3 FastEthernet1/0

200.20.0.2 1 2WAY/DROTHER 00:00:35 200.20.0.2 FastEthernet1/0

200.20.0.4 1 FULL/DR 00:00:35 200.20.0.4 FastEthernet1/0

10.12.0.1 1 FULL/BDR 00:00:35 100.0.0.1 FastEthernet0/0

 

Martin L
VIP Advocate

 

as mentioned above, you have wrong /8 mask but others have /24.  To exchange routes, OSPF and other protocols must be on the same network/link.

change mask to 255.255.255.0 on R2's interface FastEthernet1/0 with ip address 200.20.0.1 

 

Regards, ML
**Please Rate All Helpful Responses **