Showing results for 
Search instead for 
Did you mean: 

PI 3.0.x and Catalyst 3850


Hi there,

Just wondering if people have come across any issues when trying to manage 3850's I have some that are really well behaved and others that constantly fail to synchronise and inventory collection and SNMP time out. I have tried a few things but just wondered if anyone else had been having issues.

Cisco Prime Infrastructure
Version : 3.0.0
Build :
Critical Fixes:
        PI 3.0.2 Update 02 ( 2.0.0 )
        PI 3.0.3 ( 3.0.0 )
        PI 3.0.3 Update 01 ( 1.0.0 )
Device Support:
        Prime Infrastructure 3.0 Device Pack 2 ( 2.0 )
        Prime Infrastructure 3.0 Device Pack 3 ( 3.0 )
        Prime Infrastructure 3.0 Device Pack 5 ( 5.0 )
Prime Add-Ons:
        Prime Insight Agent ( 1.0.0 )
        PI 3.0 TECH PACK ( 1.0.3 )

I have shelled onto the prime box and can seem to use SNMP ok from the CLI.

ade # snmpwalk -v 2c -c testrwrw <ip> system.sysName.0
Cannot find module (ENTITY-MIB): At line 0 in (none)
ade #

However I sometimes get this

ade # snmpwalk -v 2c -c testrwrw <ip> system.sysName.0
Cannot find module (ENTITY-MIB): At line 0 in (none)
Timeout: No Response from <ip>

So I am wondering if its a bug with the 3850 SNMP implementation but I have other 3850's working fine though so there seems to be no common thread.

4 Replies 4

Mark Malone


Are the ones that work and don't work on the same ios-xe version and same platform model

I have a lot of 3850s all running snmpv3 was Prime 3.0 just upgraded to 3.1 though have not had any issues with them on that version of snmp but I have had problems with both prime and ios-xe with bugs to say the least

one thing il say if you do go to 3.1 be careful as we hit an inline upgrade bug that wiped the DB all devices all credentials that were configured even all the compliance reports we had set up , lucky enough we had a snapshot backup of the VM taken just before we started ,unfortunately TAC never provided the bug ID as they weren't aware of it yet. 

Maybe try snmpv3 when I checked the release notes for each prime release there seems to be a lot less snmp bugs for that version and we have not had an issue with snmp connectivity yet

We are running same version as you above for IOS-XE the safe harbour 3.6.4E

Hi Mark,

I they are on two different versions 03.03.05 and 03.06.04. We upgraded two to 06.04 to see if that would make any difference unfortunately it did.

I did try SNMP v3 before the upgrade and that seem'd to have the same issue but maybe I will give that another shot since I have upgraded it.

My SNMP v3 Config was pretty basic but hopefully it should work with prime, according to this doc

snmp-server user snmpv3 TESTV3 v3 auth sha <pwd> priv aes 128<pwd>

snmp-server group TESTV3 v3 auth read V3Read write V3Write
snmp-server view V3Read iso included
snmp-server view V3Write iso included
snmp-server host <ip> version 3 auth snmpv3

I will let you know how I go.

yes let us know how it goes , this is the way we have it set currently and its working ok on 3.6.4

snmp-server group xxxxx v3 priv access 5
snmp-server group xxxxx v3 priv write v3write access 6

snmp-server user xxxx xxxxx v3 auth SHA xxxxx priv aes 128 xxxxx

Out of interest when you add the devices does Prime verify the snmp as ok when it goes through the checks before adding it , and have you tried adding by ip and dns , we had issues with dns when adding them once we started using the device ip seemed to work better

Hi Mark,

The devices did verify ok with SNMP just took ages for it to do it, Chrome started complaining about the page timing out. We only add them by IP and that has always worked well for us.

And looks like my two test switches have decided to become more stable with them just using SNMPv3. So looks like we might have a solution. I am thinking maybe its to do with the Next Generation Wireless Controller in them as we have plenty of 3650's which use the same code that are fine with SNMPv2 

Anyway thanks for your advice! 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers