Showing results for 
Search instead for 
Did you mean: 

PI2: Error #2032 in Monitoring Deployment



Always and with all PI installations I know I get an Error #2032 with "Message (RSL Error 2 of 7)" in Deploy => Monitoring Deployment, if I try to assign a monitoring template to a device or port group. Is there a workarround or bugfix out?

thx for hints in advance,


6 Replies 6

Cisco Employee
Cisco Employee

Hi Steffen,

these are the BUG's :

CSCuj39571    PI 2.0 - Monitor template deploy generates RSL #2032 error

CSCuj41410    PI 2.0 FCS shows RSL error #2032 in multiple pages

I don't see any workaround for them , you can check with TAC.



[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Hi Afroj,

Thx for your answer. Snip from Bugtool:

Workaround:Place the 'framework_4.5.0.21746.swz','mx_4.5.0.21746.swz' and 'spark_4.5.0.21746.swz' at VM Folder: /applications/common/flex/treetable (eg: /opt/CSCOlumos/apache-tomcat-7.0.40/webapps/webacs/applications/common/flex/treetable)

Last Modified:Oct 24,2013


At PI2.0 the folder looks like this according affected files:

ade # ls mx_4.* framework_4.* spark_4.*

framework_4.5.0.17689.swf  mx_4.5.0.17689.swf  spark_4.5.0.17689.swf

framework_4.5.0.20967.swf  mx_4.5.0.20967.swf  spark_4.5.0.20967.swf

framework_4.5.0.20967.swz  mx_4.5.0.20967.swz  spark_4.5.0.20967.swz

framework_4.5.1.21328.swf  mx_4.5.1.21328.swf  spark_4.5.1.21328.swf

framework_4.5.1.21328.swz  mx_4.5.1.21328.swz  spark_4.5.1.21328.swz

framework_4.6.0.23201.swz  mx_4.6.0.23201.swz  spark_4.6.0.23201.swz ade

The mentioned version of this files are noot there: Where do we get this files? Is there a bundled downloadable bugfix out?


Hi Steffen,

I also did not find these files. you can get in touch with TAC so that they can conatct the development team. They may have some patch for this..



Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

How can I use the Open TAC request tool for Prime Infrastructure with this large Serial-Nrs of PI that doesnt fit into the SN# field of TAC service request tool even I delete all '-'?

Please post if someone got a solution for this. I dont understand how to implement the workaround provided for this Bug.





I have experience the same problem under different tools in PI. I did notice it first under “Deploy>Monitoring deployment>Interface Health template>deploy and I get the 2032 error.

I have learn that this occurs when you use a client with no internet connection and you try to start above deployment tools.

What happens is that when you try to open such page in PI web interface, the flash player starts and try to get some files on the PI but the URL it get from the PI application points to a library that do not contains the file (Bug in PI?). The files the flash player looks for is called something like framework_4.5.1.21328.swz and spark_4.5.1.21328.swz and so on. The url from PI looks like https://PI_Server/webacs/applications/SAMDeployTemplate/js/framework_4.5.1.21328.swz but the file is missing.

The flash player have a backup way to get the xxxxxx.swz files it needs. If it can’t find the files in the application, it try to get it from Adobe . But in my case my client can’t access internet so I get the error 2032.

I have another installation at another site that allows internet access everything works fine. The flash player can load the files it needs and store them locally on the client PC. Then I can take that PC back to the another site with no internet access where I did get the 2032 error and now It works fine because the flash player have the files it needs to handle the PI application.

I have a case open but it has not been solved yet.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers