Showing results for 
Search instead for 
Did you mean: 

Prime Infrastructure 2.1.1 cannot add more than two interfaces in Dynamic Interface > Controller Templates

Steve Ballantyne

Cisco Prime Infrastructure is a damned nightmare of browser bugs (some features work in IE8, some in IE9, and some only in Firefox).  And I am not sure if what I am experiencing is a browser bug - or a real bug - or something that I was able to do before and can't any more?  I would love for someone to either explain why this is happening to me, or reproduce the bug!

I'm running Prime 2.1.1.  I am doing this ...

Configure > Controller Template Launchpad

System > Dynamic Interface

Select a command > Add interface (GO)

Enter all the properties - roll to the bottom of the page, and click Apply to Controllers

I have four controllers.  And normally I would add an interface for each controller.  But I can only create two out of the four.  It doesn't matter which two I choose.  When I click Add under Manage Interfaces for the third controller, I cannot click the Done button to apply it (see screenshot, attached).  I have found that if I change the VLAN to something else, it will let me save it.  But ... why?  I went back and reviewed all of my existing interface templates and I am not doing anything different.  Although, they were all created a long while ago using WCS 7.x.

Any help, guidance, or confirmation of insanity would be appreciated.

-Steve Ballantyne

3 Replies 3

Steve Ballantyne

I doubt I will get any hits on this here but I always try.  I opened a TAC case.  I will come back and comment on whatever they find.

Did you get a response from TAC in the end? I have the same issue and I'm at tethers end with 14 controllers.

Prime is making it hard on itself to justify its existence...

I ended up figuring it out myself. I had upgraded from NCS up to Prime, and aparently my support was not upgraded along with it. So I received NO help from Cisco. And it took a few weeks to upgrade my support so that they would even talk to me about it. Typical!!

I just went back and read my own notes, and it looks like I ended up applying the templates to the two controllers that it would let me. Then I created the interfaces *manually* on the other two. 

Here are my ramblings from back in July ...

7/19 - With a clear head, and a bit of free time at my disposal, I went back into this to try and find some work arounds.  The templates feature of this product is definitely broken.  But the job of the template is to take one change and apply it to four controllers.  I tried making the change to the first two controllers using a template and then MANUALLY created interfaces on the other two controllers.  This seems to have worked.  Because the creation of the WLAN and the AP Groups (in a template) only refer to the interface by name --- and the name is the same amongst the four --- this should not be an issue.

And I can attest that this worked, because it's been running that way ever since.

Hope that helps you!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers