cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
410
Views
0
Helpful
2
Replies
Highlighted
Beginner

RV180W Wireless DHCP Relay Strangeness

We have used the RV180W across many of our customers and are very happy with it.

About a month ago we purchased one for a local Drug Task Force. We have managed their network for several years. The 180 was replacing a Cisco WRVS4400N (if I remember correctly).

 

Setup went fine. I manually setup the few features that were being used on their old router. Everything worked well and everyone was able to connect on all devices. They received a DHCP Lease from the Customer's Windows Server.

We all figured everything was operating correctly and went on about our day.

 

About a week, maybe 10 days later they call because one of their computers wont connect via wireless (that had been connected before the router replacement, and after).

I arrived on site and checked the machine and the settings (that hadn't been changed) looked fine.

Upon further investigation; I noticed that the Windows Laptop wasn't receiving DHCP (including DNS Settings, Default Gateway or any of the DHCP lease options)

I then examined the machine to see if TCP/IP Services were working and everything seemed to be correct. Rebooted the Laptop and tried to connect to the Router's SSID, no luck. Got an APIPA address.

Then to satisfy my own curiosity I created a WiFi hotspot from my phone and the Laptop saw it and after providing authentication was able to connect and received all the settings.

I then tried to connect to the Router's SSID, no luck.

I then turned my hotspot off on my phone and tried to connect to the Customer's WiFi and received a DHCP lease complete with all the DHCP Server's options. I figured this was just a left over lease so I deleted the network on my iPhone 5s and had my server operator (John) remove my device's lease in the Server's Leases. I then reconnected to the network and after providing Authentication was able to connect and got a different IP from the server (but a valid one). I then confirmed with John that he was seeing my phone in the lease under the new IP.

I then pulled out my Windows 8.1 Tablet and tried to connect. I was able to, I then removed the Network from my Tablet and removed the lease from DHCP and tried to reconnect. No luck.

 

I then tried this with multiple devices (iPhones (various generations) and Windows 7 & Windows 8). All iOS devices received a DHCP lease. All of the Windows Devices were destined for APIPA land. I also plugged the laptop in with Ethernet and it received a lease on it LAN connection, but not with Wireless.

 

As a short term solution: I am able to manually configure the Windows Device's Wireless card with a static internal IP and set all the options manually and got them going.

 

Any thoughts? Suggestions? I have never seen a DHCP relay be selective about the OS like this before.

Please let me know what you need me to do the get

 

The network is as follows

External is a Static IP from their ISP

Internal is 192.168.0.x

SM: 255.255.255.0

dtf5th.local internal domain name

 

The Router is 192.168.0.1

The Server is 192.168.0.2

The router is relaying DHCP from the server to wireless clients.

2 REPLIES 2
Highlighted
Beginner

So I call the Support Number and they tell me to post on the Forums.

Apparently to let it die.

Highlighted
Beginner

Hello Cody,

       Sorry the device is not working properly.  I see this post is a bit old and not sure if you still have the device.  If you do, the RV180 can do a packet capture but it has to be under 1 meg in size, otherwise it will get deleted and overwritten.  I would activate the packet capture on the RV180, capturing the LAN port.  Connect a Iphone and let it get an IP address.  You may want to pull this capture off first and name it Iphone_Connect or something like that.  Then restart the capture and try connecting with a PC that fails, pull that capture off and name it PC-Fails.  If possible, at the times of these captures, if you can get a capture at the DHCP server port, that would verify the packets leave the RV in the RV capture and would see them reach the DHCP server, and the response from the server on the server capture, and then the capture at the RV will show the return traffic from the DHCP.  With these captures then you can compare to the DORA process and the good capture of the Iphone connecting and hopefully, identify where the issue is occurring in the failed captures.  Hope this helps.

Content for Community-Ad