Showing results for 
Search instead for 
Did you mean: 

Trunking/Native VLAN


Dear CISCO Team'

I hope you're doing well. I would like to bring into your kind knowledge that I am observing an issue related to Trunking/Native VLAN. I have MikroTik Router attached with CISCO 3750-G Switch and connected switch port with Mikrotik is set to trunking and allowed vlans are 50,60. If I set native vlan to 50 then all the PPOE users in VLAN 50 get authenticated wheres VLAN60 user didn't authenticated and vice versa. Further If I set VLAN 1 as native then no user get authenticated.

Pls support to resolve the above mentioned issue. Your quick response in this regard is highly appericiated.


Thanks & Regards' 

4 Replies 4

Richard Burts
VIP Community Legend VIP Community Legend
VIP Community Legend

We do not have much detail to work with and that makes it difficult to understand the issue or to give much good advice. Perhaps if you post the config of the Cisco switch it would be a starting point in understanding what is going on.

Based on the limited information what we have it sounds like the MikroTik is successfully processing Ethernet frames that are not tagged (in the native vlan) but is not processing Ethernet frames that have 803.1q tags. Can you check the configuration of the MikroTik and see if there are any options about 802.1q?



Hi @Richard Burts '

Thanks for the reply, can you please confirm that configuration required for complete switch or for specific interface.


Thanks & Regards'


Georg Pauwen
VIP Master VIP Master
VIP Master



not sure what your configs look like, but make sure it looks something like below (Vlan 50 is the native Vlan in this example):




interface GigabitEthernet0/1
description Trunk to Mikrotik
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 50,60
switchport trunk native vlan 50




/interface bridge
add name=bridge1 vlan-filtering=no


/interface bridge port
add bridge=bridge1 interface=ether1 pvid=50


/interface bridge vlan
add bridge=bridge1 untagged=ether1 vlan-ids=50
add bridge=bridge1 tagged=ether1 vlan-ids=60


/interface bridge
set bridge1 vlan-filtering=yes

Hi @Georg Pauwen '

I have same exact configuration on CISCO switch whereas I applied your shared configuration on MikroTik issue remain the same.


Thanks & Regards'


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers