cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
922
Views
0
Helpful
2
Replies

Two problems with EEM script

jdevane
Level 1
Level 1

I have an EEM script (below) and I have two problems.

1) Line action 4.5 gets a "%Error opening bootdisk:blackhole (File or Directory already in use)"

2) Line 5.0 - 5.5 get "Line has invalid autocommand "sh mls cef hardware module 4 | append sup-bootdisk:blackhole"

Any ideas to get me on my way?

thanks!

jim

2 Replies 2

Joe Clarke
Cisco Employee
Cisco Employee

I'm guessing you'd get the same errors if you ran these commands manually in this order one after other (i.e., you pasted them into the CLI).  This might just be a limitation of the file system.  What you might do is conver this to Tcl so you don't need to use the CLI to store the output (or at least open the file once).

You can use the tool at http://www.marcuscom.com/convert_applet/ to convert your applet to Tcl.  A simple modification would then be to remove the append bits, and store the $_cli_result into an accumulator buffer.  At the end, do the email of that buffer.

Thank you for responding. Yes, I am not sure why they fail. I tried to run remote command and run them on the module themselves but that same result.

I am not very familiar with Tcl so I wound up mailing the $_cli_result immediately after and getting a bunch of emails instead of one. Not elegant but it worked and I got what I needed.

thank you for the conversion link. I will check it out!

jim