cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15678
Views
130
Helpful
26
Replies
Highlighted
Beginner

Unable to install packettracer on Ubuntu 20.04

Hi all,

Since the dependencies of libdouble-conversionn1 and qt-st-api aren't available in Ubuntu 20.04, It seems impossible to install PacketTracer on Ubuntu 20.04. Is there any fix for this? Or an ETA for when a fix will be available?

I found a PacketTracer snap, but this one isn't maintained by Cisco (So less trustworthy). I don't know if this snap works on Ubuntu 20.04

I couldn't find a PacketTracer sub-forum. That's why I posted in this sub-forum. If this is the wrong location, could somebody move it to the right one?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hello!

With some help, today, I successfully install PacketTracer on Ubuntu 20.04

 

cd ~/Downloads

wget http://ftp.br.debian.org/debian/pool/main/d/double-conversion/libdouble-conversion1_3.1.0-3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/libj/libjpeg-turbo/libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb
wget  http://archive.ubuntu.com/ubuntu/pool/main/libj/libjpeg8-empty/libjpeg8_8c-2ubuntu8_amd64.deb


sudo chmod +x libdouble-conversion1_3.1.0-3_amd64.deb libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb libjpeg8_8c-2ubuntu8_amd64.deb PacketTracer_730_amd64.deb
sudo dpkg -i libdouble-conversion1_3.1.0-3_amd64.deb libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb libjpeg8_8c-2ubuntu8_amd64.deb PacketTracer_730_amd64.deb

sudo gedit /var/lib/dpkg/status
! delete this string --> Depends: libdouble-conversion1, qt-at-spi

sudo apt --fix-broken install

 

View solution in original post

Установка Packet Tracer 7.3 https://askubuntu.com/questions/1206794/cant-install-libdouble-conversion1-on-ubuntu-19-10 # 1. libdouble-conversion1 (http://ftp...
26 REPLIES 26
Highlighted
Beginner

I have the same problem, installing packet tracer on ubuntu 20.04 getting the below error message

 

 

[$] <> sudo dpkg -i PacketTracer_730_amd64.deb
Selecting previously unselected package packettracer.
(Reading database ... 179344 files and directories currently installed.)
Preparing to unpack PacketTracer_730_amd64.deb ...
Unpacking packettracer (7.3.0) ...
dpkg: dependency problems prevent configuration of packettracer:
packettracer depends on libdouble-conversion1; however:
Package libdouble-conversion1 is not installed.
packettracer depends on qt-at-spi; however:
Package qt-at-spi is not installed.

dpkg: error processing package packettracer (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for gnome-icon-theme (3.12.0-3) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:
packettracer

Highlighted

I just ended up building a vm to run it in.

Highlighted

I am having the same problem where you able to fix this?
Highlighted

No after removing the dependencies and running apt --fix-broken install, it removes the packettracer again.. so for me it doesn't work.
Highlighted

Hello everyone,

I had the same problem. By installing the first dependency you are able to open the application and do your stuff. For the second one, the process is more time-consuming. because qt-at-spi package also needs some more dependency that you are able to manually download and install them on your system.

This was the way I did. If anyone else knows a better way, I will be appreciated to let me know.

Highlighted

Can you link to the files you installed?
Highlighted

deb source of ackettracer from netacad , ver 730-amd64

 

https://drive.google.com/open?id=1ZBqg7yKWrv_wqUh-sE08KccO5qKesTbl

 

Highlighted

Hello!

With some help, today, I successfully install PacketTracer on Ubuntu 20.04

 

cd ~/Downloads

wget http://ftp.br.debian.org/debian/pool/main/d/double-conversion/libdouble-conversion1_3.1.0-3_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/libj/libjpeg-turbo/libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb
wget  http://archive.ubuntu.com/ubuntu/pool/main/libj/libjpeg8-empty/libjpeg8_8c-2ubuntu8_amd64.deb


sudo chmod +x libdouble-conversion1_3.1.0-3_amd64.deb libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb libjpeg8_8c-2ubuntu8_amd64.deb PacketTracer_730_amd64.deb
sudo dpkg -i libdouble-conversion1_3.1.0-3_amd64.deb libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb libjpeg8_8c-2ubuntu8_amd64.deb PacketTracer_730_amd64.deb

sudo gedit /var/lib/dpkg/status
! delete this string --> Depends: libdouble-conversion1, qt-at-spi

sudo apt --fix-broken install

 

View solution in original post

Установка Packet Tracer 7.3 https://askubuntu.com/questions/1206794/cant-install-libdouble-conversion1-on-ubuntu-19-10 # 1. libdouble-conversion1 (http://ftp...
Highlighted

after installing pt 

it returns the bellow message, what is wrong in that string line

after installing pt all dpkg commands has been failed

 

dpkg --list
dpkg-query: error: parsing file '/var/lib/dpkg/status' near line 44978 package 'packettracer':
duplicate value for 'Package' field

I totally want to remove packettracer , 

sudo dpkg --remove libdouble-conversion1_3.1.0-3_amd64.deb libjpeg-turbo8_2.0.3-0ubuntu1_amd64.deb libjpeg8_8c-2ubuntu8_amd64.deb PacketTracer_730_amd64.deb
dpkg: error: parsing file '/var/lib/dpkg/status' near line 44978 package 'packettracer':
duplicate value for 'Package' field

 

Package: packettracer
Status: install ok unpacked
Priority: optional
Section: base
Maintainer: Packet Tracer Support <packettracersupport@external.cisco.com>
Architecture: amd64
Version: 7.3.0
Description: Cisco PacketTracer 7.3.0 installation package
Package: Parted
Status: install ok installed
Priority: optional
Section: admin
Installed-Size: 167
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: foreign
Version: 3.3-4
Replaces: fsresize, parted1.6
Depends: libc6 (>= 2.11), libparted2 (= 3.3-4), libreadline8 (>= 6.0), libtinfo6 (>= 6)
Suggests: parted-doc
Conflicts: fsresize, parted1.6
Description: disk partition manipulator
GNU Parted is a program that allows you to create, destroy, resize,
move, and copy disk partitions. This is useful for creating space
for new operating systems, reorganizing disk usage, and copying data
to new hard disks.
.
This package contains the binary and manual page. Further
documentation is available in parted-doc.
.
Parted currently supports DOS, Mac, Sun, BSD, GPT, MIPS, and PC98
partitioning formats, as well as a "loop" (raw disk) type which
allows use on RAID/LVM. It can detect and remove ASFS/AFFS/APFS,
Btrfs, ext2/3/4, FAT16/32, HFS, JFS, linux-swap, UFS, XFS, and ZFS
file systems. Parted also has the ability to create and modify file
systems of some of these types, but using it to perform file system
operations is now deprecated.
.
The nature of this software means that any bugs could cause massive
data loss. While there are no such bugs known at the moment, they
could exist, so please back up all important files before running
it, and do so at your own risk.
Original-Maintainer: Parted Maintainer Team <parted-maintainers@alioth-lists.debian.net>
Homepage: http://www.gnu.org/software/parted

 

Highlighted

It works, thanks!
Highlighted

Thank you so, so, sooooo much!

Worked well for me on Kubuntu 20.04

Highlighted

Thanks, It is really helpful. I have already waisted 6 hours before reaching out to your POST :).

Thanks Again. I really appreciate your work.

Highlighted

Hero! Thank you very much!

Highlighted

Thank you so much its really helpful, but I have a question, "is there any performance effect on PacketTracer after deleting this dependencies?"

Content for Community-Ad