04-19-2021 07:30 AM
For some reason, I am able to transfer all my hosts and services from an old Cisco 3560G switch to our new L3 Cisco 3650 series switch. I decided to make this a separate post as it is more specific to VMware. There are 4 ports on our Cat 3650, basically identical to the old switch. Below are the new ones
interface GigabitEthernet1/0/19
description VMWARE6
switchport access vlan 100
switchport trunk native vlan 3
switchport trunk allowed vlan 1-3,100
switchport mode trunk
end
interface GigabitEthernet1/0/20
description VMWARE6
switchport access vlan 100
switchport trunk native vlan 3
switchport trunk allowed vlan 1-3,100
switchport mode trunk
end
and the 'old' equivalent ports are (same port numbers)
interface GigabitEthernet0/19
description VMWARE6
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
spanning-tree guard root
end
CTSC-CORE-02#show running-config interface GigabitEthernet 0/20
Building configuration...
Current configuration : 197 bytes
!
interface GigabitEthernet0/20
description VMWARE6
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
spanning-tree guard root
end
I am like literally just moving Ethernet ports from old to the new switch and suddenly our VM applications stop responding, etc. Are there VMware timeouts that need to be adjusted, etc? For what it's worth, we are using ESXi 6.5 I believe with 8 blades and have port channel groups. Ports 20 and Ports 21 are similarly configured. Thoughts ideas on why they would suddenly not work on the new switch? Again, all other hosts and services are working on the new switch and the VLAN 100 is being trunked fine. We also have non-VM VLAN 100 hosts that are working fine.
Thanks,
04-19-2021 07:55 AM
- Ref : https://kb.vmware.com/s/article/2049667
I am not sure if this could be due to residual effects of the old network environment , hence the mentioned article. Another option might be to clear a blade from all VM's reboot it and move one host to it again, and check if it can get network connectivity on the new network environment.
M.
04-19-2021 09:47 AM
Try to remove below bold and test it.
interface GigabitEthernet1/0/19
description VMWARE6
no switchport access vlan 100
switchport trunk native vlan 3
switchport trunk allowed vlan 1-3,100
switchport mode trunk
end
interface GigabitEthernet1/0/20
description VMWARE6
no switchport access vlan 100
switchport trunk native vlan 3
switchport trunk allowed vlan 1-3,100
switchport mode trunk
end
04-19-2021 01:17 PM
I agree that it looks odd to have a switchport access vlan 100 on a port that is configured as a trunk. But it is not a problem. I have seen this in configurations many times and have never found it to be a problem.
What I do notice is that the new config is not quite like the old config. The old config just made the ports trunks, which allows all vlans while the new config restricts the trunk to 4 vlans. Try removing switchport trunk allowed vlan 1-3,100 and let us know if the behavior changes.
04-19-2021 08:26 PM
What Rick said. The configs aren't the same.
Anyway, see if the trunks are up and trunking the vlans you want. show int trunk
04-20-2021 12:14 AM
I agree that show interface trunk from both the old switch and the new switch might be helpful.
I do not know how I missed it before but in reading through the discussion again I notice that there is another difference between the old switch config and the new switch config
switchport trunk native vlan 3
The new switch changes the native vlan (which would have been the default vlan 1 in the old switch config).
04-21-2021 11:25 AM
Rick,
Thanks, that might be one of the keys, I didn't notice that myself about the native vlan. We use 3 on most of our switches but maybe not for the VMs. below is from the old switch, proving your point about vlan 1. What about putting portfast on a trunk port? Is that a no-no?
switch-old#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gi0/7 on 802.1q trunking 3
Gi0/19 on 802.1q trunking 1
Gi0/20 on 802.1q trunking 1
Gi0/21 on 802.1q trunking 1
Gi0/22 on 802.1q trunking 1
Port Vlans allowed on trunk
Gi0/7 1-3,100,110,120
Gi0/19 1-4094
Gi0/20 1-4094
Gi0/21 1-4094
Gi0/22 1-4094
Port Vlans allowed and active in management domain
Gi0/7 1-3,100,110,120
Gi0/19 1-3,100,110,120
Gi0/20 1-3,100,110,120
Gi0/21 1-3,100,110,120
Gi0/22 1-3,100,110,120
Port Vlans in spanning tree forwarding state and not pruned
Gi0/7 1-3,100,110,120
Gi0/19 1-3,100,110,120
Gi0/20 1-3,100,110,120
Gi0/21 1-3,100,110,120
Gi0/22 1-3,100,110,120
Thanks,
04-21-2021 05:29 PM
Matt
There are 2 significant differences between your new config and the older config:
- your new config changes the native vlan from vlan 1 to vlan 3. If devices are expecting to see untagged frames on vlan 1 and tagged frames on vlan 3 (as specified in old config) and begin to see tagged frames on vlan 1 and untagged frames on vlan 3 (as specified in the new config) it could cause problems.
- your new config restricts vlans to be carried on the trunk
switchport trunk allowed vlan 1-3,100
while the old config allowed all vlans on the trunk. In looking at the output of show interface trunk we see that the old config carried 2 vlans (110 and 120) that are not allowed in the new config. My guess is that VMware is using those vlans. I suggest that either you add 110 and 120 to the allowed parameters in the new config or that you remove the statements in the new config restricting the allowed vlans on the trunk.
Here are a couple of discussions about port fast on a trunk port
https://community.cisco.com/t5/switching/spanning-tree-portfast-trunk/td-p/1393770
So I would say that in absolute terms it not a no-no but that the situations in which it is a good idea are pretty limited. Don't think it would be beneficial in your situation.
04-22-2021 04:55 AM
Conf t
vlan 110
vlan 120
default int range gi1/0/19 - 20
int range gi1/0/19 - 20
switchport mode trunk
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide