cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

158
Views
0
Helpful
7
Replies

Would policy applied on the interface affect the sub-interface as well?

Hi,

 I am new here so please ignore my rookie questions and un-orthodox manner.

My question is that i am applying a policy on main interface, would it affect the sub-interface as well? There is only one sub-interface under the main interface.

 

configure terminal

ip access-list extended acl-SERVERS

 permit ip any host 10.22.21.22

!

class-map match-any class_VOICE-1Mbps-AtLeast

 match protocol h323

class-map match-any class_SERVERS-2Mbps-AtLeast

 match access-group name acl-SERVERS

class-map match-any class_BLOCK-TORRENT-DROP

 match protocol edonkey

 match protocol fasttrack

 match protocol bittorrent

!

policy-map policy_LIMIT-ON-MPLS-OUT

 class class_VOICE-1Mbps-AtLeast

 bandwidth 1024

 set ip dscp ef

 class class_SERVERS-2Mbps-AtLeast

 bandwidth 2048

 set ip dscp af21

 class class_BLOCK-TORRENT-DROP

 drop

 class class-default

!

interface GigabitEthernet0/1
no ip address
ip flow ingress
duplex auto
speed auto

service-policy output policy_LIMIT-ON-MPLS-OUT

end

!

interface GigabitEthernet0/1.1065

encapsulation dot1Q 1065 
ip address 10.95.18.194 255.255.255.252
end

 

 

Please advise?

I actually applied this and traffic routed thru the subinterface was being marked ef and af21 as checked thru "show access-list acl-SERVERS "  command.. there is no other markings applied. Any help will be highly appreciated.

7 REPLIES 7
VIP Mentor

Re: Would policy applied on the interface affect the sub-interface as well?

Hi
so theres a design setup you must follow to apply to subs , 1 outbound policy will cover all subs , but on LAN inbound you can have multiple , your right what you have there and yes it will work on sub by default , 1 policy fits all when outbound

Cisco IOS logical interfaces do not inherently support a state of congestion and do not support the direct application of a service policy that applies a queuing method. Instead, you first need to apply shaping to the subinterface using either generic traffic shaping (GTS) or class-based shaping. Refer to Policing and Shaping for more information.

https://www.cisco.com/c/en/us/support/docs/quality-of-service-qos/qos-policing/10104-qos-subint.html

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
CBWFQ : Not supported on subinterfaces

Re: Would policy applied on the interface affect the sub-interface as well?

Dear Mark,
Thanks for the quick response, really appreciate it.
Yes, i have already gone thru that article and know that i need to implement hierarchical policy to make this work properly, but its just that i just want to work with the configuration mentioned above due to some restrictions.

As long as its confirmed that the policy on main interface will work for the sub-interface as well (at the time of congestion) its good with me.
One more question, the link bandwidth is 20Mbps.. do i need to use "Bandwidth 20000" command on main interface or the sub-interface, or both?
VIP Mentor

Re: Would policy applied on the interface affect the sub-interface as well?

Hi
The config you have above should work fine in terms of design its not an issue , the BW you can place it on both but phsyical should work for all as its a 1 policy setup , the BW statement is only for the routing metrics calculations to define parameters of what which route gets added to the table , its optional statement but advised to use

as its on the WAN if its plied to the physical the calculation will apply to the subs too , when you run the show policy-map interface x/x you will see everything's under the physical when applied like that , but if you have multiple LAN input policies you can see each individual one under the sub interfaces itself like show interface g0/0/0.100, so in your setup whatevers applied to wan will apply to the sub

Re: Would policy applied on the interface affect the sub-interface as well?

 

My understanding was that as the physical interface is 1Gbps so we need to use the "bandwidth 20000" command, so that router will detect congestion when the traffic rate is beyond 20Mbps..

what i understand from what you said above is that the link congestion detection is not dependent upon the "bandwidth 20000" command, as its optional and used in routing metric calculation, while the congestion is detected otherwise... in our case 2Mbps for servers and 1Mbps for voice will be reserved whatever the BW is... but what if we use bandwidth percent command, that would depend on the bandwidth set using bandwidth command... right?

VIP Mentor

Re: Would policy applied on the interface affect the sub-interface as well?

QOS uses its as a reference bandwidth yes and the statement applied to an interface works for the routing protocols to base metrics off and it also is used by TCP to adjust its transmission at that layer
BW statement in QOS does not limit bandwidth but guarantees bandwidth during congestion issues

Re: Would policy applied on the interface affect the sub-interface as well?

I am sorry to bother you with so may questions and i really appreciate your patience and replying to nicely.

here is what i am not getting... the interface bandwidth is 1Gig and the BW from ISP is 20Mbps, so should i mention this in bandwidth command under interface for my QoS policy to work right or would the policy work even if i dont mention it?

in my policy i am reserving bandwidth in bps but whet if instead of bps i use percentage, would it be according to the interface bandwidth or the bandwidth set thru command on the interface?

Highlighted
VIP Mentor

Re: Would policy applied on the interface affect the sub-interface as well?

Hi

"so should i mention this in bandwidth command under interface for my QoS policy to work right or would the policy work even if i dont mention it?"

Yes you should , i provided a real time example off one of my routers below,if you follwo this style it should be fine



interface GigabitEthernet0/0/1
description
bandwidth 10000
no ip address
ip nbar protocol-discovery
ip flow monitor LIVEACTION-FLOWMONITOR input
ip flow monitor LIVEACTION-FLOWMONITOR output
speed 10
no negotiation auto
service-policy output pmap-shape-10mbps
service-policy type performance-monitor input LIVEACTION-POLICY-UNIFIED
service-policy type performance-monitor output LIVEACTION-POLICY-UNIFIED
end

1#sh run int g0/0/1.100
Building configuration...

Current configuration : 494 bytes
!
interface GigabitEthernet0/0/1.100
description xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
bandwidth 10000
encapsulation dot1Q 100
vrf forwarding H2S_FVRF
ip address xxxxxxxxxxxxxxxxxxxxxx


Parameter
bandwidth-kbps
Amount of bandwidth, in kbps, to be assigned to the class.

remaining percent percentage
Amount of guaranteed bandwidth, based on a relative percent of available bandwidth. The percentage can be a number from 1 to 100.

percent percentage
Amount of guaranteed bandwidth, based on an absolute percent of available bandwidth. The percentage can be a number from 1 to 100. (By default, only 75 percent can be reserved.)

in my policy i am reserving bandwidth in bps but whet if instead of bps i use percentage, would it be according to the interface bandwidth or the bandwidth set thru command on the interface? the BW set
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards