cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
504
Views
0
Helpful
5
Replies

ASA-5520 8.3 VPN Clients cannot access the dmz network.

Kerry Kriegel
Beginner
Beginner

My VPN clients have been access the "inside" network for a long time.  Recently there was a need to add a dmz network and allow access from the VPN clients. 

VPN clients can connect, and access the inside network.

VPN clients can connect, but cannot access the dmz.

What have I missed?

Result of the command: "sh run"

: Saved
:
ASA Version 8.3(1)
!
hostname MK-xxxxxx
domain-name xxxxxxx.net
enable password xxxxx encrypted
passwd xxxxx encrypted
names
!
interface GigabitEthernet0/0
 nameif outside
 security-level 0
 ip address 199.xxx.yyy.zzz 255.255.255.248
!
interface GigabitEthernet0/1
 description my customer Company
 nameif inside
 security-level 100
 ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 description xxxxx.
 nameif dmz
 security-level 50
 ip address 10.10.12.1 255.255.255.0
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
boot system disk0:/asa831-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 66..xxx.yyy.zzz
 name-server 66..xxx.yyy.zzz
 domain-name xxxxx
object network xxxxx
object network inside
 subnet 10.10.10.0 255.255.255.0
object network server
 host 10.10.10.10
 description server Web Server      
object network NETWORK_OBJ_10.10.10.0_24
 subnet 10.10.10.0 255.255.255.0
object network NETWORK_OBJ_10.10.11.0_24
 subnet 10.10.11.0 255.255.255.0
object network server_2
 host 10.10.10.20
 description server Web Server   
object network remote site
 subnet 10.22.233.0 255.255.255.0
object network NETWORK_OBJ_10.10.12.0_24
 subnet 10.10.12.0 255.255.255.0
object network dmz
 subnet 10.10.12.0 255.255.255.0
object-group service DM_INLINE_TCP_1 tcp
 port-object eq www
 port-object eq https
 port-object eq 8080
 port-object eq 8443
object-group network BLACKLIST
 network-object host 223.95.116.174
 network-object 223.255.0.0 255.255.128.0
 network-object 223.255.236.0 255.255.252.0
 network-object 223.255.252.0 255.255.254.0
access-list customer_splitTunnelAcl standard permit 10.10.10.0 255.255.255.0
access-list outside_access_in extended deny ip object-group BLACKLIST any
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any object OH_AS400 object-group DM_INLINE_TCP_1
access-list outside_1_cryptomap extended permit ip 10.10.10.0 255.255.255.0 object OH_Washington
access-list customer_splitTunnelAcl standard permit 10.10.10.0 255.255.255.0
access-list customer_splitTunnelAcl_1 standard permit 10.10.10.0 255.255.255.0
access-list customer_splitTunnelAcl_2 standard permit 10.10.10.0 255.255.255.0
access-list netflow-export extended permit ip any any
access-list customer_splitTunnelAcl_3 standard permit 10.10.10.0 255.255.255.0
pager lines 24
logging enable
logging asdm-buffer-size 512
logging asdm informational
logging host outside 66.185.29.62
logging permit-hostdown
no logging message 106015
no logging message 313001
no logging message 313008
no logging message 106023
no logging message 710003
no logging message 106100
no logging message 302015
no logging message 302014
no logging message 302013
no logging message 302018
no logging message 302017
no logging message 302016
no logging message 302021
no logging message 302020
flow-export destination outside 66.xxx.yyy.zzz 2055
flow-export template timeout-rate 2
flow-export delay flow-create 60
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool OH_VPN_Pool 10.10.11.1-10.10.11.254 mask 255.255.255.0
ip verify reverse-path interface outside
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-632.bin
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_10.10.10.0_24 NETWORK_OBJ_10.10.10.0_24 destination static NETWORK_OBJ_10.10.11.0_24 NETWORK_OBJ_10.10.11.0_24
nat (inside,outside) source static NETWORK_OBJ_10.10.10.0_24 NETWORK_OBJ_10.10.10.0_24 destination static remote_site remote_site
nat (inside,outside) source static NETWORK_OBJ_10.10.12.0_24 NETWORK_OBJ_10.10.12.0_24 destination static NETWORK_OBJ_10.10.11.0_24 NETWORK_OBJ_10.10.11.0_24
!
object network inside
 nat (inside,outside) dynamic interface
object network server
 nat (inside,outside) static 199.xxx.yyy.zzz
object network server_2
 nat (inside,outside) static 199.xxx.yyy.zzz
object network dmz
 nat (dmz,outside) dynamic interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 199..xxx.yyy.zzz
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server Office_SBS protocol radius
aaa-server Office_SBS (inside) host 192.168.1.10
 timeout 5
 key *****
 acl-netmask-convert auto-detect
aaa-server RadiusServers protocol radius
aaa-server RadiusServers (outside) host 66.xxx.yyy.zzz
 key *****
aaa-server RadiusServers (outside) host 66.xxx.yyy.zzz
 key *****
aaa authentication ssh console RadiusServers LOCAL
aaa authentication http console RadiusServers LOCAL
http server enable
http 192.xxx.yyy.zzz 255.255.255.224 outside
snmp-server host outside 66.xxx.yyy.zzz community ***** version 2c
snmp-server host outside 66.xxx.yyy.zzz poll community ***** version 2c
snmp-server location DC-2  A8
snmp-server contact noc@my company.net
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 172.2.37.165
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.xxx.yyy.zzz 255.255.255.224 outside
ssh 66.xxx.yyy.zzz 255.255.255.255 outside
ssh timeout 5
console timeout 0
management-access inside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 199.xxx.yyy.zzz source outside
ntp server 199.xxx.yyy.zzz source outside
webvpn
group-policy customer internal
group-policy customer attributes
 dns-server value 8.8.4.4 8.8.8.8
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value customer_splitTunnelAcl_3
 default-domain value customer.local
group-policy customer_1 internal
group-policy customer_1 attributes
 wins-server value 192.168.1.10
 dns-server value 192.168.1.10
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value customer_splitTunnelAcl_1
 default-domain value customer.local
username vpntest password xxUgRv3WsDIsl/.d encrypted privilege 0
tunnel-group customer type remote-access
tunnel-group customer general-attributes
 address-pool OH_VPN_Pool
 default-group-policy customer
tunnel-group customer ipsec-attributes
 pre-shared-key *****
tunnel-group 172.xxx.yyy.zzz type ipsec-l2l
tunnel-group 172.xxx.yyy.zzz ipsec-attributes
 pre-shared-key *****
!
class-map netflow-export-class
 match access-list netflow-export
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
  inspect icmp
 class netflow-export-class
  flow-export event-type all destination 66.185.29.62
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:41767e4b38138f09c3084d4899f3c439
: end

1 Accepted Solution

Accepted Solutions

Your Identity NAT statement appears to be on the wrong interface - shows inside but 10.10.12.0/24 should be for DMZ:

no nat (inside,outside) source static NETWORK_OBJ_10.10.12.0_24 NETWORK_OBJ_10.10.12.0_24 destination static NETWORK_OBJ_10.10.11.0_24 NETWORK_OBJ_10.10.11.0_24
nat (dmz,outside) source static NETWORK_OBJ_10.10.12.0_24 NETWORK_OBJ_10.10.12.0_24 destination static NETWORK_OBJ_10.10.11.0_24 NETWORK_OBJ_10.10.11.0_24

Alternatively you could combine the networks in a single object group and do something like this:

nat (any,outside) source static LOCAL-SUBNETS LOCAL-SUBNETS destination static IPPOOL IPPOOL 

View solution in original post

5 Replies 5

Marius Gunnerud
VIP Advisor VIP Advisor
VIP Advisor

you are missing the 10.10.12.0/24 in your split tunnel ACL.

access-list customer_splitTunnelAcl_3 standard permit 10.10.12.0 255.255.255.0

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

Added that line with no change.

Cleansed running-config is attached.

In the IPsec VPN client, under the Status menu select Statistics and then click on the route Details tab.  are both the inside and DMZ network subnets listed here?

--

Please remember to select a correct answer and rate helpful posts

--
Please remember to select a correct answer and rate helpful posts

Your Identity NAT statement appears to be on the wrong interface - shows inside but 10.10.12.0/24 should be for DMZ:

no nat (inside,outside) source static NETWORK_OBJ_10.10.12.0_24 NETWORK_OBJ_10.10.12.0_24 destination static NETWORK_OBJ_10.10.11.0_24 NETWORK_OBJ_10.10.11.0_24
nat (dmz,outside) source static NETWORK_OBJ_10.10.12.0_24 NETWORK_OBJ_10.10.12.0_24 destination static NETWORK_OBJ_10.10.11.0_24 NETWORK_OBJ_10.10.11.0_24

Alternatively you could combine the networks in a single object group and do something like this:

nat (any,outside) source static LOCAL-SUBNETS LOCAL-SUBNETS destination static IPPOOL IPPOOL 

Absolutely correct.

Thanks for seeing that.  Copy-n-paste does not always make things go quicker.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers