cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
33797
Views
7
Helpful
15
Replies

ASA IOS Image/Rommon help needed!

martinezaw
Beginner
Beginner

I powered up an ASA 5520 and received the below message:

Launching BootLoader...

Default configuration file contains 1 entry.

Searching / for images to boot.

Error 28: Selected item cannot fit into memory

unable to boot an image

Someone thought that I should erase flash and tftpdnld from Rommon. I deleted disk0:

Next in Rommon, I tried doing the following commands...

ADDRESS=192.168.2.1 (ASA's address)

SERVER=192.168.2.2 (connected to my laptop for tftp via a cross-over cable)

GATEWAY=192.168.2.1 (have also tried leaving this blank and the laptop's IP)

PORT=GigabitEthernet0/0 (port cable is plugged into)

I usually will get that GigabitEthernet0/0 is UP

I then enter the tftpdnld command, and it's like the ASA can't see the connection between it and the laptop.

It can't even ping.

I know the TFTP works because I tried it with a different ASA while in the IOS and it worked fine.

What am I doing wrong?

15 Replies 15

francisco_1
Rising star
Rising star

rommon #1> ADDRESS=192.168.1.10

rommon #2> SERVER=192.168.1.1

rommon #3> GATEWAY=192.168.1.1

rommon #4> IMAGE=asa800-232-k8.bin

rommon #5> PORT=Ethernet0/0

The above configuration will assign an IP address of 192.168.1.10 to interface Ethernet0/0 of the firewall appliance. It will also tell the firewall that the TFTP SERVER is at address 192.168.1.1 and the image to load is asa800-232-k8.bin

Step5: Execute the TFTP upload from the ASA using:

rommon #6> tftp

see this link http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a00804708d8.shtml#t3

These are my variables...

rommon #6> set

ROMMON Variable Settings:

ADDRESS=192.168.2.1

SERVER=192.168.2.2

GATEWAY=192.168.2.2

PORT=GigabitEthernet0/0

VLAN=untagged

IMAGE=asa723-k8.bin

CONFIG=

LINKTIMEOUT=20

PKTTIMEOUT=4

RETRY=3

192.168.2.2 is my tftp server. The ASA cannot even ping the server (which is directly connected with a cross-over cable). I have tried using the management0/0 interface as well with the same problem.