cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1073
Views
15
Helpful
3
Replies

ASA' proxy-arp doesnt work

I have multisubnet setup where clients behind one of the interfaces fail to configure default gateway properly. to speedup process i've configured NAT-rule (1st in chain)

nat (VLAN.803,any) source static VLAN803 VLAN803 destination static BMUVLANS BMUVLANS route-lookup

with it i expected ASA to start to respond ARP-queries from clients in VLAN 803 with its own VLAN.803 MAC, but it doesnt do.

i've verified it with capture. what can prevent ASA from ARP-proxying in this case?

3 Replies 3

Marvin Rhoads
Hall of Fame
Hall of Fame

Check the output from "show run all | i proxyarp".

Hi Marvin

highly appreciate your input, it looks like this for target VLAN

no sysopt noproxyarp VLAN.803 .  negating of negating 

Hmm so the double negative means the interface should proxy-arp as needed. The NAT rule doesn't specify the "no proxy-arp" option so that shouldn't affect it either.

Review Cisco Networking products for a $25 gift card