cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
457
Views
0
Helpful
3
Replies

ASA5505 Open Port

Todd Vohs
Level 1
Level 1

I am struggling here and not sure what I need to do but think it should be fairly straight forward.  I grew up on old IOS and IGS/MGS/CGS routers but have been out of the industry for quite some time so a lot of the new commands are foreign to me.  Someone else set this up.  I have a device on the inside of my network that needs to talk to a device on the outside of my network on TCP/17709 for management purposes through my ASA5505.  What am I doing wrong?  If you would, please be specific; if you say you need to add NAT or add ACL statement, I don't know so if you could spell it out, I would appreciate it.  And if there is anything I don't need, feel free to make suggestions for removal.  Thanks in advance.

Network is: ExternalMGT_Device <-> Internet -<MyISP static>- ASA5505 -<10.1.2.x>- Cisco 3750/L3 -<172.16.100.x,192.168.x.x, etc.>RemoteMGT_Device(172.16.100.x dhcp address).

 

ASA5505 Config is as follows:

 

ASA Version 9.2(4) 
!
hostname asa5505
domain-name mydomain.com
enable password CCCCCCCCC encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd DDDDDDDDDencrypted
names
name 208.67.222.222 OpenDNS.1
name 208.67.220.220 OpenDNS.2
name 172.16.100.200 InternalDNS.1
dns-guard
ip local pool VPNPool 10.1.4.20-10.1.4.24 mask 255.255.255.0
!
interface Ethernet0/0
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
 description myisp
 switchport access vlan 30
!
interface Ethernet0/4
 description inside
 switchport trunk allowed vlan 1-2
 switchport trunk native vlan 1
 switchport mode trunk
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
 description outside
 switchport trunk allowed vlan 30
 switchport trunk native vlan 1
 switchport mode trunk
!
interface Vlan1
 nameif management
 security-level 100
 ip address 10.10.10.254 255.255.255.0 
!
interface Vlan2
 description inside
 nameif inside
 security-level 100
 ip address 10.1.2.254 255.255.255.0 
!
interface Vlan30
 description myisp
 nameif myisp
 security-level 0
 ip address dhcp 
!
boot system disk0:/asa924-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup management
dns domain-lookup myisp
dns server-group DefaultDNS
 name-server OpenDNS.1
 name-server OpenDNS.2
 name-server InternalDNS.1
 domain-name mydomain.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network windows-server
 host 172.16.100.200
 description windows-server
object network obj-data
 subnet 172.16.100.0 255.255.255.0
object network obj-inside
 subnet 172.16.100.0 255.255.255.0
 description inside
object network myisp
 host xxx.xxx.xxx.xxx
 description myisp
object service 17709
 service tcp source eq 17709 
object network mgt_device_outside
 host yyy.yyy.yyy.yyy
 description mgt_device_outside
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group network Anyconnect-client
 network-object 10.1.4.0 255.255.255.0
object-group network local-network
 network-object 172.16.100.0 255.255.255.0
 network-object 192.168.1.0 255.255.255.0
 network-object 10.1.1.0 255.255.255.0
 network-object 10.1.4.0 255.255.255.0
 network-object 10.10.10.0 255.255.255.0
 network-object 10.1.2.0 255.255.255.0
 network-object 192.168.0.0 255.255.255.0
object-group network inside-network
 network-object 10.1.1.0 255.255.255.0
 network-object 10.1.4.0 255.255.255.0
 network-object 172.16.100.0 255.255.255.0
 network-object 192.168.1.0 255.255.255.0
 network-object 10.1.2.0 255.255.255.0
 network-object 192.168.0.0 255.255.255.0
 network-object 10.10.10.0 255.255.255.0
object-group service HOSTMGT tcp
 port-object eq 17709
access-list split standard permit 172.16.100.0 255.255.255.0 
access-list split standard permit 192.168.1.0 255.255.255.0 
access-list split standard permit 10.1.1.0 255.255.255.0 
access-list split standard permit 10.10.10.0 255.255.255.0 
access-list split standard permit 10.1.2.0 255.255.255.0 
access-list split standard permit 192.168.0.0 255.255.255.0 
access-list myisp_in extended permit ip any4 host xxx.xxx.xxx.zzz 
access-list myisp_in extended permit ip host xxx.xxx.xxx.zzz any4 
access-list raven_tcp_in extended permit object-group TCPUDP any any eq 17709 
pager lines 40
logging enable
logging buffered debugging
logging host management 10.10.10.202
mtu management 1500
mtu inside 1500
mtu evertek 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-751.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,evertek) source static local-network local-network destination static Anyconnect-client Anyconnect-client
nat (inside,evertek) source static local-network local-network destination static mgt_device_outside mgt_device_outside
!
nat (inside,evertek) after-auto source dynamic any interface
route myisp 0.0.0.0 0.0.0.0 100.42.87.1 10
route inside 10.1.1.0 255.255.255.0 10.1.2.1 1
route inside 10.1.4.0 255.255.255.0 10.1.2.1 1
route inside 10.1.100.0 255.255.255.0 10.1.2.1 1
route inside 172.16.100.0 255.255.255.0 10.1.2.1 1
route inside 192.168.0.0 255.255.255.0 10.1.2.1 1
route inside 192.168.1.0 255.255.255.0 10.1.2.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server CiscoVPN protocol radius
 ad-agent-mode
aaa-server has-server protocol radius
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
http server enable
http 10.10.10.0 255.255.255.0 management
http 10.1.2.0 255.255.255.0 inside
http 172.16.100.0 255.255.255.0 inside
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto ca trustpoint _SmartCallHome_ServerCA
 no validation-usage
 crl configure
crypto ca trustpoint ASDM_TrustPoint0
 enrollment self
 subject-name CN=hasasa5505
 proxy-ldc-issuer
 crl configure
crypto ca trustpool policy
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca eb78458 c61f381e a4c4cb66
  quit
crypto ca certificate chain ASDM_TrustPoint0
 certificate 1 2024c3b8 b3e2af2c 1baf
  quit
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
telnet timeout 5
ssh stricthostkeycheck
ssh 10.10.10.0 255.255.255.0 management
ssh 172.16.100.0 255.255.255.0 inside
ssh 10.1.1.0 255.255.255.0 inside
ssh 192.168.1.0 255.255.255.0 inside
ssh 10.1.2.0 255.255.255.0 inside
ssh timeout 30
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcp-client client-id interface myisp
dhcprelay timeout 60
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server InternalDNS.1
ssl trust-point ASDM_TrustPoint0 evertek
webvpn
 enable myisp
 anyconnect-essentials
 anyconnect image disk0:/anyconnect-win-4.1.04011-k9.pkg 1
 anyconnect enable
 tunnel-group-list enable
group-policy "GroupPolicy_MYCOMPANY AnyConnect VPN" internal
group-policy GroupPolicy_HAS internal
group-policy GroupPolicy_HAS attributes
 wins-server value 172.16.100.200
 dns-server value 172.16.100.200
 vpn-tunnel-protocol ikev2 ssl-client 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split
 default-domain value holsteinagservices.com
username administrator password EEEEEEEE encrypted privilege 15
tunnel-group FFF type remote-access
tunnel-group FFF general-attributes
 address-pool FFFVPNPool
 default-group-policy GroupPolicy_HAS
tunnel-group FFF webvpn-attributes
 group-alias FFF enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
service call-home
call-home reporting anonymous
call-home
 contact-email-addr me@mydomain.com
 profile CiscoTAC-1
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:af944a89cfef0532a4a827b4e1944e8e
: end

Thanks, Todd Vohs Owner Holstein Ag Services, LLC
3 Replies 3

Akshay Rastogi
Cisco Employee
Cisco Employee

Hi Todd,

As far as i could understand, you have a device on outside which you wish to manage from Inside.

From the configuration I do not see any interface with name 'evertek' for which nat statements are configured.

"nat (inside,evertek) source static local-network local-network destination static Anyconnect-client Anyconnect-client
nat (inside,evertek) source static local-network local-network destination static mgt_device_outside mgt_device_outside
!
nat (inside,evertek) after-auto source dynamic any interface "

 

I do not find them relevant anywhere.

If traffic needs to be only initiated from Inside host to outside host then you could configure dynamic nat statement or else you could create Static.

For static(for compete subnet or for host ), you could something like :

object network obj-inside-host

      host <ip address of inside host>

       nat (inside,myisp) static <public mapped IP in Outside subnet or use 'interface' keyword if you wish to use outside interface ip>

for dynamic, use dynamic keyword for dynamic NAT

Also if you wish to initiate traffic to this inside host from outside, then allow the traffic on myisp interface with the help of access-list.

i do see on access-list created with myisp name but could not see any access-group to apply the same on interface.

access-list myisp_in extended permit ip any4 host xxx.xxx.xxx.zzz 
access-list myisp_in extended permit ip host xxx.xxx.xxx.zzz any4

I am not sure what it is. apply the same to interface. 

access-group myisp_in in interface myisp

 

I would suggest you to go through the configuration with your network team. there might different issue.

Regards,

Akshay Rastogi

Akshay,

 

Thanks.  I must have forgot to replace a couple of evertek's with myisp so the nat statements are correct.  Also, I am my network team so this is it.  Traffic needs to be initiated from outside host.  It is a device from a company that they monitor.  It is actually an RTK base station that supplies sub-inch correction signal to farm equipment, tractors, combines, sprayers, etc. for auto steering over the internet as they drive through the field.  The farm equipment has a 3G cellular modem also.  The base station, my device, also has a backup cellular modem on it so if my internet goes down, it can still provide the correction signals to the farm equipment across the internet. The outside company monitors and manages and I am notified by them when there is a network outage.  I can set my DHCP server with a reservation for the device so it will always get the same IP and try your solution.

Thanks, Todd Vohs Owner Holstein Ag Services, LLC

Akshary,

To simplify, I have removed all the other commands and think I should only be working with the following commands:

object service 17709
 service tcp source eq 17709
object network raven_sling_mgt
 host x.x.x.x
 description raven_sling_mgt
object network raven_sling_base
 host 172.16.100.112
 description raven_sling_base
access-list evertek_access_in extended permit object 17709 any4 object evertek
access-list evertek_access_in extended permit object 17709 object evertek any4

nat (inside,evertek) source static local-network local-network destination static Anyconnect-client Anyconnect-client
nat (inside,evertek) source static raven_sling_base raven_sling_base destination static raven_sling_mgt raven_sling_mgt service 17709 17709 net-to-net
nat (inside,evertek) source static raven_sling_mgt raven_sling_mgt destination static raven_sling_base raven_sling_base service 17709 17709 net-to-net
nat (inside,evertek) after-auto source dynamic any interface

 

My outside interface on my asa is called evertek and has an object defined with the static IP from my ISP.

The host that needs to get in on port 17709 is defined as the object raven_sling_mgt.

The host that needs to get out on port 17709 is defined as the object raven_sling_base.

I didn't think it would be this difficult just to open a single port between 2 IP addresses.  Basically, raven_sling_mgt (x.x.x.x) in Sioux Falls, SD needs to mange raven_sling_base (172.16.100.112) inside my network and it needs to be 2-way communication so mgt can initiate the communication and base can initiate a communication.

Any other ideas?

Thanks, Todd Vohs Owner Holstein Ag Services, LLC
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card