Showing results for 
Search instead for 
Did you mean: 

ASDM unable to load the firewall configuration


I am trying to login using asdm and i keep getting the error ASDM unable to load the firewall configuration.

The firewall is running ASA version 9.5(1) and the ASDM version is 7.5(1).

Java version installed is java 8 update 60 I was on windows 7 but now moved to windows 10 so not really sure what could be the issue.


I can however access on a mac fine but need this to be working on windows 10 any help appreciated?

39 Replies 39

Barrett Cowan

Same issue I had with a customer of mine, shame on anyone that goes to Windows 10. Stay away from Windows 10, there are ALWAYS issues with new operating systems and should never be considered till AT LEAST one year after they have came out .. ESPECIALLY in the business environment.


Here is the link to the bug description on this issue:

Bumping this because downgrading Java IS NOT a solution.  Any version previous to 8u72 has a known exploit that will allow "complete compromise" to your machine.

Windows 10 has been out nearly a year Cisco.  How about an Estimated Time to a real solution? Does version 6 of the FirePOWER module software still have this issue with ASA9.5.2 and ASDM 7.5.2?

If so, our solution is we will be unplugging the FirePOWER modules or not configuring them. Effective Immediately.

Hmmm.... This is very bad.

The above exploit is nasty and in active use. There's a certain irony here - The device I intend to use to protect my network against the exploitation of such vulnerabilities requires me to specifically open up an additional vulnerability - and specifically of the kind that has scared me enough to purchase said device. I'm not sure we've built up that kind of trust relationship yet...! 

For those coming across this thread - the very vulnerable Java 8u51 can be installed from here -

My advice is to install ASDM-IDM, then immediately turn off all browser plugins.

Have same problem. as long as Firepower is connected. ASDM is not working.

Downgrade to 1.8.51 does no help.


This problem is back once again with Windows Server 2019. I have tried various Java versions 7u51and 7u80 don't work at all. It loads the asa portion but stalls at the Firepower portion. I have tried 8u131 and the current 8u211 both 32 and 64 bit. It is seeing Server 2019 as Server 2016 so my guess is that it is also not compatible with 2016.

ASDM Version 7121

IOS 9.8(2)

sfr ASA FirePOWER Up


Java log:

Caused by: com.teamdev.jxbrowser.chromium.internal.EnvironmentException: Unsupported operating system. Supported OS: Windows XP (SP2), 7, 8, 10, Vista, 2003 (SP1), 2008, 2012, Mac OS X & Linux. Current OS: Windows Server 2016
at com.teamdev.jxbrowser.chromium.internal.Environment.checkEnvironment(Unknown Source)
at com.teamdev.jxbrowser.chromium.internal.WebViewManager.<init>(Unknown Source)
at com.teamdev.jxbrowser.chromium.internal.WebViewManager.<clinit>(Unknown Source)
... 31 more


As before it works fine with my Win7 laptop but this is a remote site and I really need this working from this server.

I think I finally fixed it. I tried installing ASDM on multiple machines won Win 10/2012/2016 (all machines in our environment) and finally found something that works on ALL of them:

C:\Program Files (x86)\Cisco Systems\ASDM\run.bat


This batch file contains:


start javaw.exe -Xms64m -Xmx512m -Dsun.swing.enableImprovedDragGesture=true -classpath lzma.jar;jploader.jar;asdm-launcher.jar;retroweaver-rt-2.0.jar



This works on ALL versions of Win AND Java I have tested with (from 8u51-8u211) !!!


update: sry guys, I take that back :( I thought 2 of my VMs were on 201/211 java but they were still on 8u181. After I updated java to 212 it stopped working again. I downgraded all VMs to 181 thou and it does work using the bat file, just not the desktop shortcut created by installer

The fix mentioned above does not seem to work on newer windows 10 1709 or higher versions. I've tried Java 8u51 to 8u231 and it doesn't seem to want to work anymore.


Any Ideas?

Try to download latest jxbrowser and replace it in C:\Users\User\.asdm\jxbrowser

For me this is working



Try to download latest jxbrowser and replace it in C:\Users\User\.asdm\jxbrowser


This works only if no SFR module support is needed as the newer jxbrowser does not connect to sfr (firepower).

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: