cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

512
Views
0
Helpful
4
Replies

Cisco ASA connectivity for IOS upgrade from TFTP server

Greeting everyone. I have been struggling with getting an IOS image to ASA. I really need help to identify what I don't understand to remove forward. So far, I'm using a Solarwinds tftp server with the IOS in the C:\TFTP-ROOT file with Server Binding all correct. I have configure port gig0/1 on the ASA with 172.18.82.75 turned on and PC static IP as 172.18.82.10. I have enabled inbound under PC firewall settings and turn it off. I set up access-list 100 extended permit icmp any any echo and echo-reply for pinging and an access-list for permit of tftp, but the ASA and PC cannot communicate with a ping. I defaulted the config to remove issue to get upload to work. 

 

I really need help with understanding the process for image upload on an ASA. If it can communicate, I can handle the rest.

 

Thank for the help!

4 REPLIES 4
balaji.bandi
VIP Expert

We are not sure about your config how it was configured  and what went wrong, you need to look at the global config :

 

look at below document TFTP section : hope that help you :

 

https://www.cisco.com/c/en/us/support/docs/content-networking/file-transfer-protocol-ftp/200194-ASA-9-x-Configure-FTP-TFTP-Services.html#anc20



BB


*** Rate All Helpful Responses ***

ciscoasa# sh run
: Saved

:
: Serial Number: FCH22477E97
: Hardware: ASA5555, 16384 MB RAM, CPU Lynnfield 2792 MHz, 1 CPU (8 cores)
:
ASA Version 9.8(2)
!
hostname ciscoasa
enable password $sha512$5000$rUHeXDYpJs9dzSZxhRcZiA==$lNHZBeg9CjagrR1fOnXLfQ== pbkdf2
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names

!
interface GigabitEthernet0/0
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/1
nameif Inside
security-level 100
ip address 172.18.82.75 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/7
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
object network obj-172.18.82.75
host 172.18.82.75
access-list 100 extended permit udp any host 172.18.82.10 eq tftp
access-list INSIDE extended permit icmp any4 any4 echo-reply
access-list INSIDE extended permit icmp any4 any4 time-exceeded
access-list INSIDE extended permit icmp any4 any4 timestamp-reply
access-list INSIDE extended permit icmp any4 any4 unreachable
pager lines 24
mtu Inside 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 32768
!
object network obj-172.18.82.75
nat (Inside,Inside) static 172.18.82.10
access-group 100 in interface Inside
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication login-history
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
!
tls-proxy maximum-session 1000
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
!
class-map inspection_default
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect dns preset_dns_map
inspect icmp
policy-map type inspect dns migrated_dns_map_2
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:a82009e54dab1ca7b31c468b4021f801
: end
ciscoasa#
ciscoasa#
ciscoasa#
johnlloyd_13
Engager

hi,

is this a direct cable connection from ASA to your PC?

you just need to configure a layer 3 IP on an interface and do TFTP.

you can alternatively use the USB or ASDM to upload/upgrade the ASA image.

https://wannabecybersecurity.blogspot.com/2018/09/cisco-asa-5506w-x-software-image-upgrade.html

https://ccnpsecuritywannabe.blogspot.com/2014/03/backup-asa-configuration.html

https://ccnpsecuritywannabe.blogspot.com/2015/06/asa-file-system-and-bootvar-command.html

Hi John,

 

Yes, I have my PC directly connected to ASA on gig0/1. I have tried a usb, but the file does not show on the usb. I formated to FAT which should be the correct one, placed IOS on it, put it into the asa with disk1: showing, and file does not show up, then I tried a reboot but same result. Not sure if we have ASDM for use, but I see as I'm new to this company. 

 

I have the config in the reply above if you like to look.

 

Regards

Content for Community-Ad