cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1267
Views
0
Helpful
1
Replies

Configure double NAT on ASA

mjvenema
Level 1
Level 1

Hello,

 

I'm running a Cisco 5506-x with ASA code. I have the device set up at my house and I would like to use it with a existing network. I have the outside interface plugged into my modem directly which is not in bridge mode so I believe I need to configure some sort of double NAT? The outside interface should pick up an address from 10.0.0.0/24 network that it receives from my modem running DHCP. However like I said the modem is not in bridge mode so the address it gives out is already a NAT address. Then the firewall is configured to give out a 172.16.0.1/24 address on the inside interfaces. This is working when I test a client however I am not able to get out to the internet. Any help or tips would be very appreciated! I guess what I'm trying to do should look like this:

 

public ip > 10.0.0.6(nat address from modem) > 172.16.0.1

 

Here is my running config:

(password line has been removed)

 

no mac-address auto

!
interface GigabitEthernet1/1
nameif Outside
security-level 0
ip address 10.0.0.6 255.255.255.0
!
interface GigabitEthernet1/2
nameif Inside
security-level 100
ip address 172.16.0.1 255.255.255.0
!
interface GigabitEthernet1/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/7
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/8
shutdown
no nameif
no security-level
no ip address
!
interface Management1/1
management-only
nameif management
security-level 0
ip address 10.0.1.2 255.255.255.0
!
ftp mode passive
dns server-group DefaultDNS
domain-name fcn.net
same-security-traffic permit intra-interface
pager lines 24
mtu Outside 1500
mtu Inside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
!
nat (Inside,Outside) after-auto source dynamic any interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication login-history
http server enable
http 10.0.0.249 255.255.255.255 management
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcp-client client-id interface Outside
dhcpd address 172.16.0.10-172.16.0.200 Inside
dhcpd dns 8.8.8.8 8.8.4.4 interface Inside
dhcpd auto_config Outside interface Inside
dhcpd enable Inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect dns migrated_dns_map_1
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
policy-map type inspect dns migrated_dns_map_2
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
!

1 Reply 1

ilay
VIP
VIP

You can just config a Dynamic PAT to solve this problem

NAT subnet 172.16.0.0/24 to asa outside interface address (172.16.0.0/24 --> 10.0.0.6, 10.0.0.6 --> your public ip)

object network PAT
 subnet 172.16.0.0 255.255.255.0
 nat (inside,outside) dynamic interface
!
route outside 0.0.0.0 0.0.0.0 10.0.0.x // set default route to modem address

configure reference:

https://www.cisco.com/c/en/us/td/docs/security/asa/asa96/configuration/firewall/asa-96-firewall-config/nat-basics.html  

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card