04-21-2019 05:32 PM
I have successfully set up some vlans on the ASA 5506-X. Each vlan is given access to the Internet with Dynamic PAT with a public IP unique for each. I have also removed "same-security permit inter-interface" to prevent inter-VLAN communication. This also works well.
I noticed that it would be nice to give access to the management vlan from vlan 10, but I really struggle with creating the proper extended ACLs and understanding the traffic flow. I tried reading the configuration guides, but it is complicated. Possibly need to take a look at some different resources.
Maybe someone can show me some simple examples with an ACL that lets vlan 10 access vlan 20 (management)? It would be great to take a look at: opening up for full communication from vlan 10 to vlan 20 and how to just open for ssh and http to 10.0.20.1. I find that comparing a couple examples gives good insight in how things work and to learn efficiently. I still need to make sure that the vlans are not blocked from accessing the Internet.
!
interface GigabitEthernet1/1
nameif outside
security-level 0
ip address 4.3.2.3 255.255.255.240
!
interface GigabitEthernet1/2
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/2.10 vlan 10 nameif inside-10 security-level 100 ip address 10.0.10.1 255.255.255.0 ! interface GigabitEthernet1/2.20 vlan 20 nameif inside-20 security-level 100 ip address 10.0.20.1 255.255.255.0 !
object network obj_vlan_10
subnet 10.0.10.0 255.255.255.0
nat (inside-10,outside) dynamic 4.3.2.1
object network obj_vlan_20
subnet 10.0.20.0 255.255.255.0
nat (inside-20,outside) dynamic 4.3.2.2
!
ssh 10.0.20.0 255.255.255.0 inside-20
ssh 10.0.10.0 255.255.255.0 inside-10
http 10.0.20.0 255.255.255.0 inside-20
http 10.0.10.0 255.255.255.0 inside-10
!
04-21-2019 09:32 PM
04-22-2019 05:28 AM
04-28-2019 08:57 PM
05-05-2019 03:38 AM
Thhe ssh server ip in vlan 20 is 10.0.20.3
05-06-2019 08:38 PM
I don't have your full config but let's assume you already have an acl for GigabitEthernet1/2.10 and GigabitEthernet1/2.20 named respectively inside-10_in and inside-20_in.
if you want to allow vlan 10 to ssh only server 10.0.20.3 in vlan 20, deny any other ssh but allow everything else, the 3 ace lines would be:
object network SSH-SRV
host 10.0.20.3
object network VLAN10-NET
subnet 10.0.10.0 255.255.255.0
object network VLAN20-NET
subnet 10.0.20.0 255.255.255.0
object service SSH-PORT
service tcp destination eq 22
!
access-list inside-10_in extended permit tcp object SSH-PORT object VLAN10-NET object SSH-SRV
access-list inside-10_in extended deny tcp object SSH-PORT object VLAN10-NET object VLAN20-NET
access-list inside-10_in extended permit ip object VLAN10-NET object VLAN20-NET
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide