Showing results for 
Search instead for 
Did you mean: 

IDM 5.1 and Java memory heap size


This is really getting annoying. I have an ASA 5510 with SSM-10, and I'm trying to use the IDM. I'm running Windows XP SP3 with 1 gig of RAM. When I try to load the IDM, I get the error message:

"Your current Java memory heap size is less than 256 MB. You must increase the Java memory heap size before launching IDM."

Ok. I've done that, and it still doesn't work. I was running the latest version of Java. I then read advice to downgrade to Java 5, so I downgraded to 5u22 and tried it again. Same error message. So I once again adjusted the memory heap under Control Panel | Java, Java Applet Runtime Settings. There, on the only entry on the list (JRE 1..0_22), I added the runtime parameters "-Xms256 -Xmx512". I tried yet again and still get the error message.

What's going on with this?

6 Replies 6

Scott Fringer
Cisco Employee
Cisco Employee


  Are you running IDM directly from a web browser, or are you launching through ASDM?

  Also, if you are running IPS release 5.x you will be unable to install current signature updates, as the 5.x train of software is not able to update to the latest analysis engine (E4) which is needed to install signature updates afeer S479.  You would benefit from updating the AIP-SSM software.

  If you update your AIP-SSM software to either 6.2(2)E4 or 7.0(3)E4 you will also have a new version of IDM which does not run as a Java applet, and will overcome the Java heap issue you are encountering.


Hi Scott.

I'm running it directly from the browser. I'm running ASDM v6.0(30)60 which doesn't allow me to access the IDM from it. Unfortunately I'm still waiting for the memory upgrade to the ASA to get approved by our budget people so I can get it running the latest version (as best as I know, it requires 512MB while my ASA currently only has 256MB).

Is this memory upgrade required for the latest IDM as well?


  Frequently after resetting the Java heap setting you need to restat your system (or at least the full Java sub-system to allow the heap change to take effect).

  The memory update is not necessary for the upgrade to the AIP-SSM software.  The AIP-SSM is a separate system with its own CPU and memory.  You can update it to release 6.2(2)E4 or 7.0(3)E4 as they are.  What is the current version of software running on the ASA/



The ASA version is 8.0(3)19. This may be further behind than it should be (even without the additional memory) because this ASA has been unused since sometime in late 2008. I've just started the process of configuring this device to replace a SonicWALL NSA3500, but I'm stuck waiting for budget approval on SMARTnet and the memory upgrade purchase.

I've rebooted and it still seems to not be working. I'll try applying the IDM update via the CLI. Hopefully that will resolve the issue... I'll let you know how it turns out.

Thanks for your help so far.


  You should have no issue upgrading the AIP-SSM to either release with the host ASA running 8.0(3); both 6.2 and 7.0 are compatible.


Lee Valentin

I know this question is outdated but I searched for similar answers and didn't find it so I figured I'd post. Had this same issue when trying to connect to the IDM for the Cisco IPS 4235 via https.My Java Version is 1.6. Should work the same for 1.5

The fix is to go to Start > Control Panel select Java Control Panel and click on the Java tab. In the Java Runtime Environment Settings click View and add the following to the Runtime Parameters -Xmx512m

Cisco IDM showing up with no issues now. Good luck.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: