Showing results for 
Search instead for 
Did you mean: 


iPhone OS 3.0 - internet tethering and Cisco VPN Client


The latest OS for the iPhone allows users to tether their iPhone to a Mac/PC so that the user can browse the internet through the carriers mobile 3G network.

I can confirm that internet tethering works on my Macbook Pro, but the following error is displayed when i load the CiscoVPN Client (version 4.9.01 (0100))

"Error 51: Unable to communicate with the VPN subsystem.

Please make sure that you have at least one network interface that is cuurently active and has an ip address and start this application again."

Does this mean that the Cisco VPN client cannot see the internet connection supplied by the iPhone even though i can browse the internet while this error is being displayed??


Eddie S


Do you also use the username edy80y by any chance?

If so, looks like you might already have a possible solution - using Bluetooth.

Thought I'd post the link here just in case anyone else is looking here for a solution...

Hi James, Yes i do. Thanks for the update, Ill try it now.


Do you mean that are you using iphone like a modem or trying to use vpnclient preloaded on iphone?

Well, it was one way of trying it, but tethering over bluetooth allows me to run the CiscoVPN CLient on my Mac without issues, which is what my main concern was.

Same problem here and I'm wondering the same. I also noticed that the same error comes also when my ethernet connection and iPhone tethering are active at the same time. Then there really should be a connection.

Despite that, I have the same problem and using bluetooth tethering doesn't solve this. Still the same error even though Internet connection works otherwise fine.

Any suggestions? Have Cisco tested this?

I'm using MacBook Pro 13" OS X 10.5.8, iPhone 3GS 3.0.1 with official finnish carrier Sonera, Cisco Systems VPN Client 4.9.01 (0100)

Funny thing. Today the tethering worked fine at least with bluetooth. Only thing I did is I tried my iPhone 3G 3.0 with my laptop. First it worked and I was quite amazed. After that I tried 3GS 3.0.1 and also it worked. Also, I had restarted the network settings of my iPhone 3GS earlier today.

It's hard to say did the installation of 3G as bluetooth device or the reset of 3GS network settings fix the issue.

Bluetooth defintiely works for me, and USB doesnt (for VPN).

I have noticed that every so often i need to pair the iphone to the macbook so that the BT connection sticks, then in network preferences if you have multiple locations, you need to make sure you have selected the location that contains your bt network adaptor and click 'Apply'. hope that helps

Content for Community-Ad