10-18-2010 11:09 PM - edited 03-11-2019 11:56 AM
Hi,
This the part to the previously problem thread I posted.
I have finnally upgraded to version 724 both IOS and ASDM have now isolated the fault to NATing.
Its quite funny as the ISP utilises a POE time connection with login credentials set on their Router which is connected directly to our ASA5520 outside interface with the IP of 172.16.1.2.
Inside accessing outside is OK
Inside access DMZ is OK
But Outside accessing the DMZ server keeps stopping at the NAT rule when a Packet tracer is run.
Below is the config
---------------------------------
: Saved
:
ASA Version 7.2(4)
!
hostname DIC
domain-name xxx.xxx.xxx
enable password mRwXlfpuQX1.Qti6 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
dns-guard
!
interface GigabitEthernet0/0
description LAN Facing Interface
speed 100
duplex full
nameif Inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface GigabitEthernet0/1
description DMZ Facing Interface
nameif DMZ
security-level 50
ip address 192.168.2.1 255.255.255.0
!
interface GigabitEthernet0/2
description Internet Facing Interface
speed 100
duplex full
nameif Outside
security-level 0
ip address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.3.1 255.255.255.0
management-only
!
banner exec Unauthorised Access is Prohibitted.
banner exec Violation is deemed illegal and intruders will be prosecuted
banner login Unauthorised Access is Prohibitted.
banner login Violation is deemed illegal and intruders will be prosecuted
banner motd Unauthorised Access is Prohibitted.
banner motd Violation is deemed illegal and intruders will be prosecuted
boot system disk0:/asa724-k8.bin
ftp mode passive
clock timezone PGT 10
dns domain-lookup Outside
dns server-group DefaultDNS
name-server nnn.nnn.nnn.nnn
name-server mmm.mmm.mmm.mmm
domain-name gopng.gov.pg
access-list Outside_access_in remark Internet to Inside
access-list Outside_access_in extended permit tcp any any eq www
access-list Outside_access_in remark Permit Internet to Web Server
access-list Outside_access_in extended permit ip any host 20.20.20.20
access-list Outside_access_in remark Test created implicit rule
access-list Outside_access_in extended permit ip any any
access-list Inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.128
access-list Inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list Inside_access_in remark Inside accessing Internet
access-list Inside_access_in extended permit ip 192.168.0.0 255.255.255.0 any
access-list Inside_access_in remark Inside Accessing DMZ
access-list Inside_access_in extended permit ip 192.168.0.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list DMZ_access_in remark DMZ to Inside
access-list DMZ_access_in extended permit ip 192.168.2.0 255.255.255.0 192.168.0.0 255.255.255.0 log
access-list DMZ_access_in remark Webserver to Internet
access-list DMZ_access_in extended permit ip host 192.168.2.5 any
pager lines 24
logging enable
logging timestamp
logging list test level debugging
logging asdm informational
logging debug-trace
mtu Inside 1500
mtu DMZ 1500
mtu Outside 1500
mtu management 1500
ip verify reverse-path interface Inside
ip verify reverse-path interface DMZ
ip verify reverse-path interface Outside
ip audit attack action drop
no failover
monitor-interface Inside
monitor-interface DMZ
monitor-interface Outside
monitor-interface management
icmp unreachable rate-limit 1 burst-size 1
icmp permit any Inside
icmp permit any DMZ
icmp permit any Outside
asdm image disk0:/asdm-524.bin
asdm history enable
arp timeout 14400
nat-control
global (DMZ) 1 192.168.2.10-192.168.2.254 netmask 255.255.255.0
global (Outside) 1 interface
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 192.168.0.0 255.255.255.0
static (DMZ,Outside) tcp interface www 192.168.2.5 www netmask 255.255.255.255 dns
access-group Inside_access_in in interface Inside
access-group DMZ_access_in in interface DMZ
access-group Outside_access_in in interface Outside
route Outside 0.0.0.0 0.0.0.0 gatewayip 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.3.0 255.255.255.0 management
http 192.168.0.0 255.255.255.0 Inside
snmp-server location 8th Floor Somare FND
snmp-server contact bill gates
snmp-server community infocom
snmp-server enable traps snmp authentication linkup linkdown coldstart
no sysopt connection permit-vpn
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map Outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map Outside_map 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map interface Outside
crypto isakmp identity hostname
crypto isakmp enable Outside
crypto isakmp policy 10
authentication pre-share
encryption aes
hash md5
group 2
lifetime 86400
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
no vpn-addr-assign local
telnet timeout 5
ssh scopy enable
ssh 192.168.0.0 255.255.255.0 Inside
ssh timeout 5
console timeout 0
dhcpd dns 124.240.221.33 202.165.192.23
dhcpd domain xxx.xxx.xx.xx
!
dhcpd address 192.168.0.50-192.168.0.100 Inside
dhcpd enable Inside
!
dhcpd address 192.168.2.100-192.168.2.200 DMZ
dhcpd enable DMZ
!
dhcpd address 192.168.3.10-192.168.3.20 management
dhcpd enable management
!
group-policy Infocom internal
group-policy Infocom attributes
dns-server value 124.240.221.33 202.165.192.23
default-domain value xxx.xx.xx.x
username gunigaga password b8P4vzQGzm3w9Ajk encrypted privilege 0
username user2 password iS5o8BaNdLW4rit5 encrypted privilege 0
username user2 attributes
vpn-group-policy yaiks
username gunigugu password 6GKGhYBQ6C7H0m8W encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns migrated_dns_map_1
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b7d0ab14838af0c46698fdae77bb8309
: end
asdm image disk0:/asdm-524.bin
asdm location 192.168.1.5 255.255.255.255 DMZ
asdm location 192.168.0.0 255.255.255.255 Inside
asdm location 192.168.2.5 255.255.255.255 DMZ
asdm location 20.20.20.20 255.255.255.255 Outside
asdm history enable
thanks
10-18-2010 11:23 PM
Hello Pius,
Mike here, Would you please paste the whole packet tracer ?
Cheers
Mike
10-19-2010 08:22 AM
I don't see a rule that translates 172.16.1.2 on the outside. I see
global (DMZ) 1 192.168.2.10-192.168.2.254 netmask 255.255.255.0
global (Outside) 1 interface
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 192.168.0.0 255.255.255.0
static (DMZ,Outside) tcp interface www 192.168.2.5 www netmask 255.255.255.255 dns
But I don't see the webserver being tasnalted to 172.xxxx.
You would need a static for that
static (DMZ,Outside) tcp interface www 172.xxxx www netmask 255.255.255.255 dns
I hope it helps.
PK
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide