Showing results for 
Search instead for 
Did you mean: 


Strange console port problem - ASA 5510 with USB-RS232 Adapter

I recently began work on an ASA 5510 for a customer and have encountered a problem with Console Port output that I have never experienced before.  Due to the fact that my laptop (like most current models) lacks a built-in native COM port, I use a USB-to-RS232 adapter.  It is branded by "Zonet" and uses a Prolific PL-2303 IC.  It has worked flawlessly with all other Cisco devices I have interfaced with using it, which - for recent verification purposes - included a 2821 router, a 3750 switch stack and my own personal PIX 501.  In all cases, all output from applying power to any and all interaction with the device in question is perfectly presented, both echoed input characters and device output.

In the case of the ASA 5510 in question, however, the output is hideously mangled and completely unintelligible.  I am attaching two text files which exhibit the mess that I see onscreen  when interfacing with the ASA, and the correct, intelligible output  from a PIX 501 just moments later.  I have used the console cable that came with the ASA as well as others I have around (in case it was like the VPN 3000 series devices, which IIRC used a straight-through rather than rollover cable arrangement).  I have tried different terminal emulations in HyperTerminal although, again, the setup I have used thus far works with any other Cisco device I need to or choose to work with.  I have verified that the hardware release notes that came with this ASA state the familiar 9600 8-None-1-No HW Flow Control setup.

As an added complication, the ASA's console ouput is perfectly intelligible when connected to a native built-in COM port on a desktop PC.  However, it will not be viable to deploy such a device as a companion to the ASA for access purposes, and field portability of such a solution is less than optimal too.  I am perplexed, because I have never had an issue with USB Serial Port adapters before, and I just don't know what is going on with this device's console port.  Particularly with the v7 code series, with its established foundation in the Finesse OS, I would be very surprised if some kind of regression in serial port handling had occurred in the codebase.

FWIW, the ASA shipped with ASA SW v7.0(8) and ASDM 5.0(8).  I originally experienced an additional glitch wherein ASDM would state that the "Main Window is Coming Up" but never did launch.  I determined that this seems to be related to that very old version of ASDM not cooperating with an up-to-date Java (Java 6 Update 21 in the case of my laptop).  I was able to get it to launch using the older Java 5 Update 22 that is part of OS X 10.5.8 (9L31a) on my alternate workstation.  I have also verified in the course of speculative updates of ASA and ASDM to 8.0(5)/6.3(1) and 8.3(1)/6.3(1) that the ASDM launch issue in relation to contemporary Java releases is resolved.  So I can access the device by ASDM.  However, CLI console port output remains garbled in all of these release software combinations; I had been hoping against hope for a defect resolution!  I also booted the device to 7.2(4)/5.2(4) in the interim, as a test, but that release suffered all the same defects as the original 7.0(8)/5.0(8).

Because I consider myself more proficient with the CLI than ASDM, and because console access in the event of a crash to ROMMON would of course be highly desirable, I would be grateful to anyone who might be able to shed some light on this.  Has anyone experienced this before, with an ASA 5500-series in particular?  Or any other Cisco hardware?  Thanks very much for any suggestions and/or guidance!


I have identified a resolution or at least a work-around which has worked for me.  In lieu of using HyperTerminal - although it works fine for all other Cisco devices using my laptop and USB-Serial adapter - I installed an updated Tera Term (v4.76).  All session handling, input and output, is perfectly clear.  I don't know what the underlying issue is, but I don't care so long as this fix continues to work for me.  I hope this may benefit someone else who might stumble upon this problem someday.

I'm afraid I can't mark this "Answered" unless someone else posts here, for the sensible reason that somebody who does that could just be trolling and awarding themselves points.

Content for Community-Ad