cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

417
Views
0
Helpful
3
Replies
Highlighted
Beginner

Trying to decide which version of software I should upgrade to on my ASA 5515X

I am currently running interim release 9.6(4)42. I want to upgrade one last time before I cannot get contract support next November. Can anyone recommend a good major release that is stable. We use Firepower 6.4.0.4 with an FMC. We also run Anyconnect 4.7 with about 125 users. Highest concurrent user for vpn has been about 85.

 

Thanks

3 REPLIES 3
Highlighted
VIP Advisor

Hi,
I also have an ASA 5515-X, it does not support the very latest versions. If you are running ASA, the latest version you can run is 9.12 (9.14 is the very latest, but not supported on the 5515) or if running FTD, then 6.4 is the latest major version you can running (6.6 is the very latest, but not supported on the 5515).

HTH
Highlighted
Hall of Fame Guru

When there's a Gold Star version in the downloads page go with that. For AnyConnect Cisco generally recommends (an I agree) to go with the latest version.

So in your case that means:

Firepower 6.4.0.9:

https://software.cisco.com/download/home/286271171/type/286277393/release/6.4.0.9?i=!pp

(need to upgrade FMC to that version first)

ASA 9.12(3)12:

https://software.cisco.com/download/home/284143128/type/280775065/release/9.12.3%20Interim

AnyConnect 4.9.00086:

https://software.cisco.com/download/home/286281283/type/282364313/release/4.9.00086

Highlighted
Beginner

Unless you have specific needs that might be catered only on certain releases, which is very rare, always go with the version that have the gold star next to them.
If there are more that one gold star versions, then see which version does what you need exactly.

------------------------------------------------------------------
If this was helpful, please vote as helpful by clicking on the star icon below.
-------------------------------------
Content for Community-Ad