Showing results for 
Search instead for 
Did you mean: 

Unable to launch Device Manager - ASDM issue

Level 1
Level 1

Hi There,

I have recently upgraded our spare ASA 5510 router to version 9.1(3) with ASDM image Version 7.1(5)100.

The client i'm attempting to run the ASDM launcher on is Windows 7 x64 running the latest version of Java (7 update 5).

I am able to get to the main screen when I https to the device.  I can install the ASDM launcher, but once I enter the hostname and Password I receive the following error "Unable to launch Device Manager 192.168.X.XXX".

I have gone through a check list and I can confirm the following:

- the 3des-sha1 licence is enabled

- Http server is enabled for my clients subnet

- ssl encryption is enabled

- Tried Firefox and IE10

When I attempt to run the ASDM via the browser I get as far as asking for the password and although the initial prompt seems to accept it, another authentication box appears asking for it over and over again in an endless loop.

I have been through many forum posts and check lists, but cannot seem to pinpoint this problem.

If it helps, the box was previously flashed back to factory-default before I then applied the configuration from scratch (based on the config of our live ASA 5510).

Can somebody help please?


54 Replies 54

I followed the steps you listed correctly and afterwards it was working perfectly!

I can open the Cisco ASA Firewall via ASDM now! No more error messages! Two thumbs up for you! Thank you so much and I really appreciate this! :D

Hello Anthony,

Wow its working for me , thank you very much


CISCO-ASA-1(config)# show run all ssl

ssl server-version any

ssl client-version any

ssl encryption rc4-md5 rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1

ssl certificate-authentication fca-timeout 2





Hi Raj,


I have the same problem. Could you please clarify steps to overcome the problem?


Many thanks

Level 1
Level 1

Hi Anthony,

I had this same issue. I resolved it by opening Java (Windows - Control Panel Java - Select Security Tab Select Manage Certificates. Select Certificate Type and choose Secure Site) on a known working ASDM installed computer.

Export the "Trusted Site" cert and import it on the computer with ASDM issue.

This resolved the issue for me.  I exported the self-signed certificates from each of my ASAs and then imported them into the "secure site" section in Java console (the "trusted certificates" section did not work).  I have seen this previously for another java application as well.  This was with ASDM 7.1(5)100 and Java version 7 update 51.

@ Joel Asaro:

thanks man. you saved my day...

Thanks nypizzar0x and Joel Asaro.  You guys helped me out too.

This one is the solution! Thanks :)

This worked here. I have been searching for a solution for a long time. i have uninstalled the latest version and installed the above. now working fine.

Tried everything, but this worked. Thanks!

Level 1
Level 1

The solution works. Thank you very much.

Level 1
Level 1

thanks mate!! you people saved my day.. its working fine for me..

Added username and password and changed the security level to medium in java control  panel in windows 7.

Now need to explore ASDM.. :-)

hi guys,


would you please explain to me how to export the self signed ssl certificate from the ASA (CLI) in order to import it in Java secure web site?


Many thnaks in advance

Level 1
Level 1

This worked for me. Thanks!

Run: asdm-launcher.jar on C:\Program Files (x86)\Cisco Systems\ASDM
Windows 8.1 64 bit

ASDM 6.1
JRE 8 Update 20

Review Cisco Networking for a $25 gift card