cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
58182
Views
12
Helpful
11
Comments
siskum
Spotlight
Spotlight

IP Helper-addres for VLANsIP Helper-addres for VLANs

This is simple solution to reduce a bottle neck of router which is issuing ip address to clients using IP DHCP pool "Vlanxx". IP Helper-Address command can point to enterprize DHCP Server instead to issues ip address to their all VLANs clients. Then this separate DHCP Server will take fully control issuing IP address to all VLAN clients. Step-by-step configuration follows. This documentation is created by for beginers who wants improve their network with reliability. Please thumbs up if this is helpful to you then it will be helpful to others.

Router1 Configurations

Router1#
Router1#config t
Router1(config)#interface GigabitEthernet0/0
Router1(config-if)# no ip address
Router1(config-if)# no shutdown
Router1(config-if)#
Router1(config-if)#interface GigabitEthernet0/0.10
Router1(config-subif)# encapsulation dot1Q 10
Router1(config-subif)# ip address 192.168.10.1 255.255.255.0
Router1(config-subif)# no shutdown
Router1(config-subif)#
Router1(config-subif)#interface GigabitEthernet0/0.11
Router1(config-subif)# encapsulation dot1Q 11
Router1(config-subif)# ip address 192.168.11.1 255.255.255.0
Router1(config-subif)# no shutdown
Router1(config-subif)#
Router1(config-subif)#interface GigabitEthernet0/1
Router1(config-if)# no ip address
Router1(config-if)# duplex auto
Router1(config-if)# speed auto
Router1(config-if)# no shutdown
Router1(config-if)#
Router1(config-if)#interface GigabitEthernet0/1.50
Router1(config-subif)# encapsulation dot1Q 50
Router1(config-subif)# ip address 192.168.50.1 255.255.255.0
Router1(config-subif)# no shutdown
Router1(config-subif)#
Router1(config-subif)#interface GigabitEthernet0/1.100
Router1(config-subif)# encapsulation dot1Q 100
Router1(config-subif)# ip address 192.168.100.1 255.255.255.0
Router1(config-subif)# no shutdown
Router1(config-subif)#
Router1(config-subif)#interface GigabitEthernet0/1.120
Router1(config-subif)# encapsulation dot1Q 120
Router1(config-subif)# ip address 192.168.120.1 255.255.255.0
Router1(config-subif)# no shutdown
Router1(config-subif)#
Router1(config-subif)#interface GigabitEthernet0/1.130
Router1(config-subif)# encapsulation dot1Q 130
Router1(config-subif)# ip address 192.168.130.1 255.255.255.0
Router1(config-subif)# no shutdown
Router1(config-subif)#
Router1(config-subif)#interface GigabitEthernet0/2     //you can spare one port to connect to an internet router or a switch 
Router1(config-if)# no ip address
Router1(config-if)# duplex auto
Router1(config-if)# speed auto
Router1(config-if)# shutdown
Router1(config-if)#


Router1 - Show Run Command
--------------------------
Router1#sh run
Building configuration...
!
hostname Router1
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.11
encapsulation dot1Q 11
ip address 192.168.11.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
!
interface GigabitEthernet0/1.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet0/1.120
encapsulation dot1Q 120
ip address 192.168.120.1 255.255.255.0
!
interface GigabitEthernet0/1.130
encapsulation dot1Q 130
ip address 192.168.130.1 255.255.255.0
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!

CORE Switch1 Configuration

CoreSwitch1#
CoreSwitch1#config t
CoreSwitch1(config)#int rang F0/1-3
CoreSwitch1(config-if)# switchport trunk encapsulation dot1q
CoreSwitch1(config-if)# switchport mode trunk
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#int rang G0/1-2
CoreSwitch1(config-if)# switchport trunk encapsulation dot1q
CoreSwitch1(config-if)# switchport mode trunk
CoreSwitch1(config-if)# exit
CoreSwitch1(config)#interface FastEthernet0/1
CoreSwitch1(config-if)# description CoreSwitch1-DHCPSever 192.168.1.1 connection
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface FastEthernet0/2
CoreSwitch1(config-if)# description CoreSwitch1-Switch3 connection
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface FastEthernet0/3
CoreSwitch1(config-if)# description CoreSwitch1-Router1 G0/1 sub-interface connection
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface GigabitEthernet0/1
CoreSwitch1(config-if)# description CoreSwith1-Switch2 connection
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface GigabitEthernet0/2
CoreSwitch1(config-if)# description CoreSwitch1-Router1 G0/0 sub-interface connection
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#int rang F0/10-19
CoreSwitch1(config-if)# switchport access vlan 11
CoreSwitch1(config-if)# switchport mode access
CoreSwitch1(config-if)# switchport nonegotiate
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan1
CoreSwitch1(config-if)# ip address 192.168.1.2 255.255.255.0
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan10
CoreSwitch1(config-if)# ip address 192.168.10.2 255.255.255.0
CoreSwitch1(config-if)# ip helper-address 192.168.1.1
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan11
CoreSwitch1(config-if)# ip address 192.168.11.2 255.255.255.0
CoreSwitch1(config-if)# ip helper-address 192.168.1.1
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan50
CoreSwitch1(config-if)# ip address 192.168.50.2 255.255.255.0
CoreSwitch1(config-if)# ip helper-address 192.168.1.1
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan100
CoreSwitch1(config-if)# ip address 192.168.100.2 255.255.255.0
CoreSwitch1(config-if)# ip helper-address 192.168.1.1
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan120
CoreSwitch1(config-if)# ip address 192.168.120.2 255.255.255.0
CoreSwitch1(config-if)# ip helper-address 192.168.1.1
CoreSwitch1(config-if)#
CoreSwitch1(config-if)#interface Vlan130
CoreSwitch1(config-if)# ip address 192.168.130.2 255.255.255.0
CoreSwitch1(config-if)# ip helper-address 192.168.1.1
CoreSwitch1(config-if)#

CORE Switch1-Show Run Command
----------------------------
CoreSwitch1#
CoreSwitch1#sh run
!
interface FastEthernet0/1
description CoreSwitch1-DHCPSever 192.168.1.1 connection
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
description CoreSwitch1-Switch3 connection
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
description CoreSwitch1-Router1 G0/1 sub-interface connection
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
!
!
interface FastEthernet0/10
switchport access vlan 11
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/11
switchport access vlan 11
switchport mode access
switchport nonegotiate
!
!
interface FastEthernet0/18
switchport access vlan 11
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/19
switchport access vlan 11
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/20
!
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
description CoreSwith1-Switch2 connection
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
description CoreSwitch1-Router1 G0/0 sub-interface connection
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
!
interface Vlan10
mac-address 0040.0b45.ab01
ip address 192.168.10.2 255.255.255.0
ip helper-address 192.168.1.1
!
interface Vlan11
mac-address 0040.0b45.ab02
ip address 192.168.11.2 255.255.255.0
ip helper-address 192.168.1.1
!
interface Vlan50
mac-address 0040.0b45.ab03
ip address 192.168.50.2 255.255.255.0
ip helper-address 192.168.1.1
!
interface Vlan100
mac-address 0040.0b45.ab04
ip address 192.168.100.2 255.255.255.0
ip helper-address 192.168.1.1
!
interface Vlan120
mac-address 0040.0b45.ab05
ip address 192.168.120.2 255.255.255.0
ip helper-address 192.168.1.1
!
interface Vlan130
mac-address 0040.0b45.ab06
ip address 192.168.130.2 255.255.255.0
ip helper-address 192.168.1.1
!

Switch2 - Configurations
=========================

Switch2#conf t
Switch2(config)#int rang f0/1-12
Switch2(config-if-range)# switchport mode access
Switch2(config-if-range)# switchport access vlan 10
Switch2(config-if-range)#
Switch2(config-if-range)#int rang f0/13-24
Switch2(config-if-range)# switchport mode access
Switch2(config-if-range)# switchport access vlan 50
Switch2(config-if-range)#
Switch2(config-if-range)#interface GigabitEthernet0/1
Switch2(config-if)# description Switch2-CoreSwitch1 connection (trunking auto)
Switch2(config-if)#
Switch2#

Switch2 - Show Run Command
--------------------------
Switch2#
Switch2#sh run

!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
!
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/13
switchport access vlan 50
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/14
switchport access vlan 50
switchport mode access
switchport nonegotiate
!
!
!
interface FastEthernet0/23
switchport access vlan 50
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/24
switchport access vlan 50
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1
description Switch2-CoreSwitch1 connection (trunking auto)
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!


Switch3 - Configurations
========================

Switch#
Switch#conf t
Switch(config)#
Switch(config)#vlan 100
Switch(config-vlan)# name Production
Switch(config-vlan)#
Switch(config-vlan)#vlan 120
Switch(config-vlan)# name Finance
Switch(config-vlan)#
Switch(config-vlan)#vlan 130
Switch(config-vlan)# name Admin
Switch(config-vlan)# exit
Switch(config)#
Switch(config)#int rang g1/0/1-8
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 100
Switch(config-if-range)#
Switch(config-if-range)#int rang g1/0/9-16
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 120
Switch(config-if-range)#
Switch(config-if-range)#int rang g1/0/17-24
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 130
Switch(config-if-range)# exit
Switch(config)#
Switch(config)#int g1/1/1
Switch(config-if)# description Switch3-CoreSwitch F0/2 connection (trunking auto)
Switch(config-if)# exit
Switch(config)#


Switch3 - Show Run Command
--------------------------

Switch#
Switch#sh run
!
interface GigabitEthernet1/0/1
switchport access vlan 100
switchport mode access
switchport nonegotiate
!
!
!
interface GigabitEthernet1/0/8
switchport access vlan 100
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet1/0/9
switchport access vlan 120
switchport mode access
switchport nonegotiate
!
!
!
interface GigabitEthernet1/0/16
switchport access vlan 120
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet1/0/17
switchport access vlan 130
switchport mode access
!
!
!
interface GigabitEthernet1/0/24
switchport access vlan 130
switchport mode access
!
interface GigabitEthernet1/1/1
description Switch3-CoreSwitch F0/2 connection (trunking auto)
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
mac-address 0030.a394.6801
no ip address
!
interface Vlan120
mac-address 0030.a394.6802
no ip address
!
interface Vlan130
mac-address 0030.a394.6803
no ip address

DHCP Server - Configuration

1. First, Configure the DHCP Server with static ip address manually as below;

Configure Static IP Address to DHCP ServerConfigure Static IP Address to DHCP Server

 

2. Secondly, select from top menu "Services" and select "DHCP" from left menu and configure DHCP pool IP address as below:

IP Helper-Address DHCP pool IP addresses for VLANsIP Helper-Address DHCP pool IP addresses for VLANs

 

3. Finally, select the clients on each VLAN and select IP configuration and select DHCP radio button instead of Static.

Client PC select DHCPClient PC select DHCP

 

Comments
Jimena Saez
Community Manager
Community Manager

Thank you Sisira for this valuable contribution! 

marcmontreal514
Level 1
Level 1

Wow this thing help me a lot, a huge thank you for the time and all this nice lab config you share.

Thank you again 

CS-mit
Level 1
Level 1

This is exactly what I needed and with such precise detail, I wish I could give you multiple likes sir! Thank you very much for the time put forth!

siskum
Spotlight
Spotlight

Thanks for you all, for your appreciation comments.

janbaztaimoor
Level 1
Level 1

I am working on something similar but a bit complicated. Need your help.

 

siskum
Spotlight
Spotlight

@janbaztaimoor , please feel free to ask me here which kind of problem you came a cross or you can send me private message describing where you stucked in.

Look forward to hear from you..!

Best regards,

Siskum

siskum
Spotlight
Spotlight
Hi Janbaztaimoor,

You can tell me where you are facing the problem and why it complicated for you. which configuration bit complicated for you?

Best regards,
Sisira/siskum
Hussein Salum
Level 1
Level 1

Thanks for the answer and solution but I have encountered a problem when trying to implement it.

I'm using Cisco Packet Tracer 8.1.1 and I can't use the 3650-24PS switch because it is off and I can't power it on.

How can I do it?

 

Rich R
VIP
VIP
siskum
Spotlight
Spotlight

@Hussein Salum, I am so sorry for late reply due to I was on vacation. Regarding your question about L3 3650-24PS switch, I have to inform you all CISCO switches do not have inbuilt power-on-switch, only power-on-switch comes in CISCO routers. Switches have direct power supply, you don't have to worry on it just make connection with UTP cables then switches will start communicate one and other.

If you need further assisnt please asked question here. Thanks for your paitiency.

/Siskum

siskum
Spotlight
Spotlight

IP Helper-Address helps to lease IP address from cooperate office via serial connection to remote office VLANs. Below link configurations helps you to see how does it work.

https://community.cisco.com/t5/networking-knowledge-base/implement-ip-helper-address-leases-ips-to-remote-office-via-wan/ta-p/4984208/message-revision/4984208:14

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: