cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7714
Views
0
Helpful
0
Comments
SunilKhanna
Level 1
Level 1

     

     

    Introduction

    BGP Neighbors associated in a Peer-Group share similar routing policies. Update policies are usually set by route maps, distribute-lists and filter-lists, etc. Instead of defining the same policies for each separate neighbor, we define a peer group name and assign these policies to the peer group.

     

    Members of the peer group inherit all of the configuration options of the peer group. Members can also be configured to override these options if these options do not affect outbound updates; you can only override options set on the inbound.

     

    The command to configure peer group is neighbor peer-group-name peer-group and to associate a member to a group is neighbor {ipv4/ipv6 address} peer-group peer-group-name .

     

    NOTE: The members of a peer group may not necessarily be in a same autonomous system.

    Background

    In this documentation, we are configuring IPv6 EBGP relationship by creating two peer groups on Router R1, named BOISE and MONTANA. Neighbors associated in group BOISE are R2 & R3 whereas R4 & R5 are associated with group MONTANA. For demonstration, we have configured two route-maps for each peer-group.

     

    The command to attache peer-group with the route-map is neighbor peer-group-name route-map route-map-name out/in, the command is configured under the address-family mode.

     

    All configurations are carried in Lab environment on Cisco 3745 Router operating on Cisco IOS 12.4 version.

     

    Topology Summarization

    Topology_Summarization.bmp

    Topology Diagram

    Topology_Diagram.bmp

    Configuration

    Summary Steps
    1. enable
    2. configure terminal
    3. router bgp as-number
    4. neighbor peer-group-name peer-group
    5. neighbor {ip-address | ipv6-address[%] | peer-group-name} remote-as autonomous-system-number [alternate-as autonomous-system-number ...]
    6. address-family ipv6 [vrf vrf-name] [unicast | multicast | vpnv6
    7. neighbor {ip-address | peer-group-name | ipv6-address %} activate
    8. neighbor ip-address | ipv6-address} send-label
    9. neighbor {ip-address | ipv6-address} peer-group peer-group-name
    10. exit

     

    Router R1

    R1

    hostname R1

    ip cef

    no ip domain lookup

    ipv6 unicast-routing

     

     

    interface Serial0/2

    no ip address

    ipv6 address 2012:1:CA1:12::1/64

    ipv6 enable

    clock rate 72000

    !

    interface Serial0/3

    no ip address

    ipv6 address 2012:1:CA1:13::1/64

    ipv6 enable

    clock rate 72000

    !

    interface Serial0/4

    no ip address

    ipv6 address 2012:1:CA1:14::1/64

    ipv6 enable

    clock rate 72000

    !

    interface Serial0/5

    no ip address

    ipv6 address 2012:1:CA1:15::1/64

    ipv6 enable

    clock rate 72000

    !

    router bgp 100

    bgp router-id 1.1.1.1

    no bgp default ipv4-unicast

    bgp log-neighbor-changes

    neighbor BOISE peer-group

    neighbor MONTANA peer-group

    neighbor 2012:1:CA1:12::2 remote-as 22

    neighbor 2012:1:CA1:12::2 peer-group BOISE

    neighbor 2012:1:CA1:13::3 remote-as 33

    neighbor 2012:1:CA1:13::3 peer-group BOISE

    neighbor 2012:1:CA1:14::4 remote-as 44

    neighbor 2012:1:CA1:14::4 peer-group MONTANA

    neighbor 2012:1:CA1:15::5 remote-as 55

    neighbor 2012:1:CA1:15::5 peer-group MONTANA

    !

    address-family ipv6

      neighbor BOISE route-map LIST1 out

      neighbor MONTANA route-map LIST2 out

      neighbor 2012:1:CA1:12::2 activate

      neighbor 2012:1:CA1:13::3 activate

      neighbor 2012:1:CA1:14::4 activate

      neighbor 2012:1:CA1:15::5 activate

      network 2012:1:CA1:11::1/64

      network 2012:1:CA1:22::2/64

    exit-address-family

    !

    route-map LIST2 permit 10

    match ipv6 address LIST_2

    !

    route-map LIST1 permit 10

    match ipv6 address LIST_1

    !

    ipv6 access-list LIST_1

    permit ipv6 host 2012:1:CA1:11::1 any

    !

    ipv6 access-list LIST_2

    permit ipv6 host 2012:1:CA1:22::2 any

    !

    end

     

    Router R2, R3, R4 & R5

    R2R3R4R5

    hostname R2

    ip cef

    no ip domain lookup

    ipv6 unicast-routing

    !

    interface Serial0/0

    no ip address

    ipv6 address 2012:1:CA1:12::2/64

    ipv6 enable

    clock rate 2000000

    !

    router bgp 22

    bgp router-id 2.2.2.2

    no bgp default ipv4-unicast

    bgp log-neighbor-changes

    neighbor 2012:1:CA1:12::1 remote-as 100

    neighbor 2012:1:CA1:12::1 ebgp-multihop 2

    !

    address-family ipv6

      neighbor 2012:1:CA1:12::1 activate

    exit-address-family

    !

    end

    hostname R3

    ip cef

    no ip domain lookup

    ipv6 unicast-routing

    !

    interface Serial0/0

    no ip address

    ipv6 address 2012:1:CA1:13::3/64

    ipv6 enable

    clock rate 2000000

    !

    router bgp 33

    bgp router-id 3.3.3.3

    no bgp default ipv4-unicast

    bgp log-neighbor-changes

    neighbor 2012:1:CA1:13::1 remote-as 100

    neighbor 2012:1:CA1:13::1 ebgp-multihop 2

    !

    address-family ipv6

      neighbor 2012:1:CA1:13::1 activate

    exit-address-family

    !

    end

    hostname R4

    ip cef

    no ip domain lookup

    ipv6 unicast-routing

    !

    interface Serial0/0

    no ip address

    ipv6 address 2012:1:CA1:14::4/64

    ipv6 enable

    clock rate 2000000

    !

    router bgp 44

    bgp router-id 4.4.4.4

    no bgp default ipv4-unicast

    bgp log-neighbor-changes

    neighbor 2012:1:CA1:14::1 remote-as 100

    neighbor 2012:1:CA1:14::1 ebgp-multihop 2

    !

    address-family ipv6

      neighbor 2012:1:CA1:14::1 activate

    exit-address-family

    !

    end

    hostname R5

    ip cef

    no ip domain lookup

    ipv6 unicast-routing

    !

    interface Serial0/0

    no ip address

    ipv6 address 2012:1:CA1:15::5/64

    ipv6 enable

    clock rate 2000000

    !

    router bgp 55

    bgp router-id 5.5.5.5

    no bgp default ipv4-unicast

    bgp log-neighbor-changes

    neighbor 2012:1:CA1:15::1 remote-as 100

    neighbor 2012:1:CA1:15::1 ebgp-multihop 2

    !

    address-family ipv6

      neighbor 2012:1:CA1:15::1 activate

    exit-address-family

    !

    end

     

    Verification

         show bgp ipv6 unicast summary

    Output1.bmp

         show bgp ipv6 unicast peer-group

    Output2.bmp

         show ipv6 route bgp

    Output3.bmp

    References

    Implementing Multiprotocol BGP for IPv6

    Border Gateway Protocol

    IP Version 6 (IPv6

    IPv6 Frequently Asked Questions (FAQ)

    Getting Started

    Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: