cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
79854
Views
15
Helpful
9
Comments

 

 

Introduction

This document explains the solution for the error message %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error,

Interface <interface> Power Controller reports power Imax error detected.

 

Core Issue

 

Power Imax / Tstart errors may be reported with some third party PDs.

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error,Interface <interface> 

Power Controller reports power Imax error detected.


For Example:

Log:

Sep 21 22:25:13.675 GMT:%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error,

Interface Fa0/15:  Power Controller reports power Imax error detected

Explanation


You are hitting the bug CSCsw18530 : Power Imax / Tstart errors may be reported with some third party PDs

This error indicates that PD is drawing over-current more than allowed/supported per IEEE 802.3af standard.

Seen with some of the 3750,3750G,3750-E,3560-E, 3750-X, 3560-X, 3560-C, 2960S, 2960,2960C switches.

Resolution

This issue is fixed in 12,2(55)SE3 , 12.2(58)SE1 and later releases. The following interface configuration commands have to be applied

to resolve the issue,

 

Switch(config)# int x/y

 

Switch(config-if)# power inline port 2x-mode

 

Switch(config-if)# shut

 

Switch(config-if)# no shut 

 

The fix is present in the following platforms only : 3750-E,3560-E, 3750-X, 3560-X, 3560-C, 2960S, 2960,2960C.The other platforms

do not support 2X power mode and the workaround would be to use a longer cable.Possible workaround is using Longer cable (>50ft)

seems to fix the issue in most cases.

 

 

Source: https://supportforums.cisco.com/thread/157276

 

Related Information

 

Troubleshooting Power over Ethernet

This error indicates that PD is drawing over-current more than allowed/supported per IEEE 802.3af standard.
Comments

Please tell me what is this 2x mode which we defined after power inline command ???

What does it specify., I am aware about static and never but not about 2x mode.

Rajan R
Level 1
Level 1

Getting the same error on

15.0(2)SE2 3750 v2 48PS

nextira_grob
Level 1
Level 1

Same problems on C3560-48PS, running 12.2(55)SE6.

No possibillity to configure mentioned configuration on the interface.

We've than exchanged the switch, but problem still occured on the same port.

So might be the end-device be the problem? (Alcatel ipTouch)

Evan Cameron
Level 1
Level 1

 

 

I am running 12.2 (55)SE3 code on a 2960s stack with the power inline 2x-mode configured on the interface and still getting a consistent "Tstart error condition"

 

the PD is an Ingenico iSC Touch 480

 

 

 

 

Brian Luger
Level 1
Level 1

We are having trouble with Ingenico iSC Touch 480 as well.

Switch :

WS-C3850-12X48U    03.07.02E

Log message :

*Jan 12 09:45:17.734: %ILPOWER-7-DETECT: Interface Gi1/0/4: Power Device detected: IEEE PD
*Jan 12 09:45:18.596: %ILPOWER-5-IEEE_DISCONNECT: Interface Gi1/0/4: PD removed

test cable diagnostic output :

Interface Speed Local pair Pair length Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/4 auto Pair A 0 +/- 1 meters N/A Normal
Pair B 0 +/- 1 meters N/A Normal
Pair C 1 +/- 1 meters N/A Short
Pair D 2 +/- 1 meters N/A Short

Same issue here too.  Ingenico iSC Touch 480.

Switch:

WS-C2960X-24PS-L

15.0(2a)EX5

Log Messages:

%ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi1/0/1: Power Controller reports power Tstart error detected

Show power inline:

Gi1/0/1   auto   faulty     0.0     n/a                 n/a   30.0

test cable tdr output:

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/1   auto  Pair A     N/A                N/A         Normal
                Pair B     N/A                N/A         Normal
                Pair C     1    +/- 10 meters N/A         Short
                Pair D     1    +/- 10 meters N/A         Short

Anyone have any resolution to this yet?

Brian Luger
Level 1
Level 1

It ended up being an issue with the Ingenico device. They were able to identify which devices had the issue by the serial number. 

I am seeing this on a a  WS-C3560G-24PS-S with a Meraki MR42, also saw it on a 3750 and swaped switch out to the 3560G, hoping to fix it.

IOS version 

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 28 WS-C3560G-24PS 15.0(2)SE8 C3560-IPSERVICESK9-M

 

 

*Mar 1 03:58:31.149: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi0/3: Power Controller reports power Imax error detected
*Mar 1 03:58:41.106: %ILPOWER-7-DETECT: Interface Gi0/3: Power Device detected: IEEE PD

prashantk
Level 1
Level 1

Hi,

 

I am also having the same logs under my 3560-cx switch for CISCO AP as a PD. 

 

TShoot steps which I follows:

 

1) Run cable test

 

Switch#test cable-diagn tdr int G1/0/3

verify: Switch# sh cable-diagn tdr int G1/0/3 - No cable Fault

 

2) Upgrade the firmware IOS  Version 15.2(7)E2. Still Out of luck

3) 

Switch(config)# int G1/0/3
Switch(config-if)# power inline never 
Switch(config-if)# shut
Switch(config-if)# no shut

Switch(config-if)#power inline auto

Switch(config-if)# power inline port 2-event  (in my switch IOS  Version 15.2(7)E2 )

Switch(config-if)# exit

 

Also applied static power allocation and all possible config. STILL NO LUCK.

 

4) Finally, change the Ethernet cable. Everything is working fine. ISSUE Resolved.

 

With Regards,

 

Prashant K

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: