cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1463
Views
0
Helpful
0
Comments
teegeorg
Cisco Employee
Cisco Employee

Description of the issue

Multicast Receivers are unable to receive traffic initiated by the Multicast source.

Verify if your device configuration matches the following configuration.

##### FE1  ########

ip routing


ip multicast-routing vrf Engineering

ip pim vrf Engineering rp-address 200.2.3.100

ip pim vrf Engineering register-source Loopback500


!

interface Loopback0

 description Fabric Node Router ID

 ip address 70.0.0.1 255.255.255.255

ip router isis

!

vrf definition Engineering

 rd 1:4099

 !

 address-family ipv4

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

!

interface Vlan1021
 mac-address 0000.5000.5000 < ---- Anycast MAc for gateway
 vrf forwarding Engineering
 ip address 100.1.1.1 255.255.255.0 <---- Anycast Gateway IP
 ip pim sparse-dense-mode
 no lisp mobility liveness test
 lisp mobility v4eid
 !

interface Loopback500
 vrf forwarding Engineering
 ip address 153.3.3.3 255.255.255.255
 ip pim sparse-mode
end


!


router lisp

 locator-set rloc_set1

  IPv4-interface Loopback0 priority 10 weight 10

  auto-discover-rlocs

  exit-locator-set

 !

 service ipv4

  encapsulation vxlan

  map-cache-limit 5119

  database-mapping limit dynamic 3000

  itr map-resolver 71.0.0.1

  etr map-server 71.0.0.1 key key1

  etr map-server 71.0.0.1 proxy-reply

  etr

  sgt

  proxy-itr 70.0.0.1

  use-petr 71.0.0.1

  exit-service-ipv4

 !

instance-id 4097

  remote-rloc-probe on-route-change

  service ipv4

   eid-table default

   exit-service-ipv4

  !

  exit-instance-id

 !

 instance-id 4099

remote-rloc-probe on-route-change
  dynamic-eid v4eid
   database-mapping 100.1.0.0/16 locator-set rloc_set1
   exit-dynamic-eid

  service ipv4

   eid-table vrf Engineering

database-mapping 153.3.3.3/32 locator-set rloc_set1 < — To register the address used by PIM source to the LISP MS/MR

map-cache 0.0.0.0/0 map-request

   exit-service-ipv4

  !

  exit-instance-id

 !

 ipv4 locator reachability exclude-default

 ipv4 source-locator Loopback0

 exit-router-lisp

!

interface LISP0.4099
 ip pim sparse-mode

!




##### FE2  ########

ip routing


ip multicast-routing vrf Engineering

ip pim vrf Engineering rp-address 200.2.3.100

ip pim vrf Engineering register-source Loopback500


!

interface Loopback0

 description Fabric Node Router ID

 ip address 70.0.0.2 255.255.255.255

ip router isis

!

vrf definition Engineering

 rd 1:4099

 !

 address-family ipv4

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

!

interface Vlan1021
 mac-address 0000.5000.5000 < ---- Anycast MAc for gateway
 vrf forwarding Engineering
 ip address 100.1.1.1 255.255.255.0 <---- Anycast Gateway IP
 ip pim sparse-dense-mode
 no lisp mobility liveness test
 lisp mobility v4eid
 !

interface Loopback500
 vrf forwarding Engineering
 ip address 153.3.3.4 255.255.255.255
 ip pim sparse-mode
end


!


router lisp

 locator-set rloc_set1

  IPv4-interface Loopback0 priority 10 weight 10

  auto-discover-rlocs

  exit-locator-set

 !

 service ipv4

  encapsulation vxlan

  map-cache-limit 5119

  database-mapping limit dynamic 3000

  itr map-resolver 71.0.0.1

  etr map-server 71.0.0.1 key key1

  etr map-server 71.0.0.1 proxy-reply

  etr

  sgt

  proxy-itr 70.0.0.2

  use-petr 71.0.0.1

  exit-service-ipv4

 !

instance-id 4097

  remote-rloc-probe on-route-change

  service ipv4

   eid-table default

   exit-service-ipv4

  !

  exit-instance-id

 !

 instance-id 4099

remote-rloc-probe on-route-change
  dynamic-eid v4eid
   database-mapping 100.1.0.0/16 locator-set rloc_set1
   exit-dynamic-eid

  service ipv4

   eid-table vrf Engineering

database-mapping 153.3.3.4/32 locator-set rloc_set1 < — To register the address used by PIM source to the LISP MS/MR

map-cache 0.0.0.0/0 map-request

   exit-service-ipv4

  !

  exit-instance-id

 !

 ipv4 locator reachability exclude-default

 ipv4 source-locator Loopback0

 exit-router-lisp

!

interface LISP0.4099
 ip pim sparse-mode

!

##### FB1  ########

ip routing


ip multicast-routing vrf Engineering

ip pim vrf Engineering rp-address 200.2.3.100

ip pim vrf Engineering register-source Loopback500


!

interface Loopback0

 description Fabric Node Router ID

 ip address 71.0.0.1 255.255.255.255

ip router isis

!

vrf definition Engineering

 rd 1:4099

 !

 address-family ipv4

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

 !

 address-family ipv6

  route-target export 1:4099

  route-target import 1:4099

 exit-address-family

!

interface Loopback1021 ----- ( Anycast gateway IP configured for DHCP OFFER punt)

 vrf forwarding Engineering

 ip address 100.1.1.1 255.255.255.255

!

interface Loopback500
 vrf forwarding Engineering
 ip address 200.2.3.100 255.255.255.255
 ip pim sparse-mode
end


!

interface Vlan 2001
 vrf forwarding Engineering
 ip address 200.0.0.1 255.255.255.0
 ip pim sparse-mode
end


!


router lisp

 locator-set rloc_set1

  IPv4-interface Loopback0 priority 10 weight 10

  auto-discover-rlocs

  exit-locator-set

 !

 service ipv4

  encapsulation vxlan

  map-cache-limit 5119

  database-mapping limit dynamic 3000

  itr map-resolver 71.0.0.1

  etr map-server 71.0.0.1 key key1

  etr map-server 71.0.0.1 proxy-reply

  etr

  sgt

  proxy-etr

  proxy-itr 71.0.0.1

  map-server

  map-resolver

  exit-service-ipv4

 !

instance-id 4097

  remote-rloc-probe on-route-change

  service ipv4

   eid-table default

   route-export site-registrations

   distance site-registrations 250

   map-cache site-registration

   exit-service-ipv4

  !

  exit-instance-id

 !

 instance-id 4098

  remote-rloc-probe on-route-change

  service ipv4

   eid-table vrf DEFAULT_VN

   route-export site-registrations

   distance site-registrations 250

   map-cache site-registration

   exit-service-ipv4

  !

exit-instance-id

 !

 instance-id 4099

  remote-rloc-probe on-route-change

  service ipv4

   eid-table vrf Engineering

database-mapping 200.2.3.100/32 locator-set rloc_set1 < — To register the RP address to the LISP MS/MR

route-import database bgp 65001 route-map database locator-set rloc_set1 ( — Replacement of redistribute bgp under router ospf)

   route-export site-registrations

   distance site-registrations 250

   map-cache site-registration

   exit-service-ipv4

  !

  exit-instance-id

 !

!

 site site_uci

  authentication-key key1

  eid-record instance-id 4097 0.0.0.0/0 accept-more-specifics

  eid-record instance-id 4098 0.0.0.0/0 accept-more-specifics

  eid-record instance-id 4099 0.0.0.0/0 accept-more-specifics

  exit-site

 !

 !

 ipv4 locator reachability exclude-default

 ipv4 source-locator Loopback0

 exit-router-lisp

!

interface LISP0.4099
 ip pim sparse-mode

!

router bgp 65001

 bgp router-id interface Loopback0

 bgp log-neighbor-changes

 bgp graceful-restart

 !

address-family ipv4 vrf vn1

  network 173.168.127.1 mask 255.255.255.255 

  network 200.2.3.100 mask 255.255.255.255 < ---- To advertise the RP address to upstream routers

  aggregate-address 173.168.227.0 255.255.255.0 summary-only

  aggregate-address 173.168.127.0 255.255.255.0 summary-only

  neighbor 200.0.0.2 remote-as 65002

  neighbor 200.0.0.2 activate

 exit-address-family

!

route-map database permit 10

 match ip address prefix-list external_prefix

!

ip prefix-list external_prefix seq 5 permit 200.0.0.0/8

Solution

Run the commands in the Post-SDA Troubleshooting to verify your device configuration. Fix errors, if any.

Pre-SDA Troubleshooting

show ip mroute vrf <vrf_name>

show ip mfib vrf <vrf_name>

 

Post-SDA Troubleshooting

  1. Check if the PIM tunnel is up.
    ===== FE1 ======

    FE1#show  ip pim  vrf Engineering tunnel 
    Tunnel3 
      Type       : PIM Encap
      RP         : 200.2.3.100
      Source     : 153.3.3.3
      State      : UP
      Last event : Created (00:07:29)
  2.  Ensure IGMP joins are received on the Fabric node connected to the Multicast receiver.
    FE1#show  ip igmp  vrf Engineering groups  226.1.1.1 detail

    Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,

           SS - Static Source, VS - Virtual Source,

           Ac - Group accounted towards access control limit

    Interface: Vlan1021

    Group: 226.1.1.1

    Flags: L U 

    Uptime: 00:01:50

    Group mode: EXCLUDE (Expires: 00:02:27)

    Last reporter: 100.1.1.10

    Source list is empty
  3. Verify if RPF check passes for RP address.
    FE1#show  ip rpf vrf Engineering 200.2.3.100 

    RPF information for ? (200.2.3.100)

      RPF interface: LISP0.4099

      RPF neighbor: ? (71.0.0.1)

      RPF route/mask: 200.2.3.100/32

      RPF type: unicast ()

      Doing distance-preferred lookups across tables

      RPF topology: ipv4 multicast base
  4. Verify the output on receipt of joins from receiver and before sending traffic from source.
    FE1#show  ip mroute  vrf Engineering 226.1.1.1

    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report, 
           Z - Multicast Tunnel, z - MDT-data group sender, 
           Y - Joined MDT-data group, y - Sending to MDT-data group, 
           G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
           N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
           Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
           V - RD & Vector, v - Vector, p - PIM Joins on route, 
           x - VxLAN group, c - PFP-SA cache created entry, 
           * - determined by Assert
    Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 226.1.1.1), 00:01:34/00:02:58, RP 200.2.3.100, flags: SJCL
      Incoming interface: LISP0.4099, RPF nbr 71.0.0.1 < — RLOC of FB1
      Outgoing interface list:
        Vlan1021, Forward/Sparse-Dense, 00:01:34/00:02:58
  5. Verify S, G entry after starting traffic from the source.
    FE1#show  ip mroute  vrf Engineering 226.1.1.1 < — 

    IP Multicast Routing Table

    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

           L - Local, P - Pruned, R - RP-bit set, F - Register flag,

           T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

           U - URD, I - Received Source Specific Host Report, 

           Z - Multicast Tunnel, z - MDT-data group sender, 

           Y - Joined MDT-data group, y - Sending to MDT-data group, 

           G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 

           N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 

           Q - Received BGP S-A Route, q - Sent BGP S-A Route, 

           V - RD & Vector, v - Vector, p - PIM Joins on route, 

           x - VxLAN group, c - PFP-SA cache created entry, 

           * - determined by Assert

    Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join

     Timers: Uptime/Expires

     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 226.1.1.1), 00:21:37/stopped, RP 200.2.3.100, flags: SJCL

      Incoming interface: LISP0.4099, RPF nbr 71.0.0.1

      Outgoing interface list:

        Vlan1021, Forward/Sparse-Dense, 00:21:37/00:02:15

    (200.5.6.100, 226.1.1.1), 00:02:12/00:00:47, flags: JT <---- S,G entry after traffic sent from source

      Incoming interface: LISP0.4099, RPF nbr 71.0.0.1

      Outgoing interface list:

        Vlan1021, Forward/Sparse-Dense, 00:02:12/00:02:15
  6. Verify traffic hitting the mfib entry.
    FE1#show  ip mfib  vrf Engineering  226.1.1.1 

    Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,

                    ET - Data Rate Exceeds Threshold, K - Keepalive

                    DDE - Data Driven Event, HW - Hardware Installed

                    ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB 

                    MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary

                    MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.

    I/O Item Flags: IC - Internal Copy, NP - Not platform switched,

                    NS - Negate Signalling, SP - Signal Present,

                    A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,

                    MA - MFIB Accept, A2 - Accept backup,

                    RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second

    Other counts:      Total/RPF failed/Other drops

    I/O Item Counts:   FS Pkt Count/PS Pkt Count

    VRF Engineering

     (*,226.1.1.1) Flags: C HW

       SW Forwarding: 0/0/0/0, Other: 0/0/0

       HW Forwarding:   625/0/104/0, Other: 0/0/0

       LISP0.4099 Flags: A NS

       Vlan1021 Flags: F IC NS

         Pkts: 0/0

     (200.5.6.100,226.1.1.1) Flags: HW

       SW Forwarding: 0/0/0/0, Other: 0/0/0

       HW Forwarding:   2523851/9899/104/8043, Other: 0/0/0 <---- Verify counters incrementing for S,G entry

       LISP0.4099 Flags: A

       Vlan1021 Flags: F IC NS

         Pkts: 0/0
  7. Repeat steps on FE2.
    ==== FE2 ====

    FE2#show  ip pim  vrf Engineering tunnel 
    Tunnel3 
      Type       : PIM Encap
      RP         : 200.2.3.100
      Source     : 153.3.3.4
      State      : UP
      Last event : Created (00:07:29)

    FE2#show  ip igmp  vrf Engineering groups  226.1.1.1 detail

    Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
           SS - Static Source, VS - Virtual Source,
           Ac - Group accounted towards access control limit

    Interface: Vlan1021
    Group: 226.1.1.1
    Flags: L U 
    Uptime: 00:01:50
    Group mode: EXCLUDE (Expires: 00:02:27)
    Last reporter: 100.1.1.11
    Source list is empty


     

    FE2#show  ip rpf vrf Engineering 200.2.3.100
    RPF information for ? (200.2.3.100)
      RPF interface: LISP0.4099
      RPF neighbor: ? (71.0.0.1)
      RPF route/mask: 200.2.3.100/32
      RPF type: unicast ()
      Doing distance-preferred lookups across tables
      RPF topology: ipv4 multicast base





    FE2#show  ip mroute  vrf Engineering 226.1.1.1 <--- Output  on Sending joins from receiver and  before sending traffic from source)
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report, 
           Z - Multicast Tunnel, z - MDT-data group sender, 
           Y - Joined MDT-data group, y - Sending to MDT-data group, 
           G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
           N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
           Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
           V - RD & Vector, v - Vector, p - PIM Joins on route, 
           x - VxLAN group, c - PFP-SA cache created entry, 
           * - determined by Assert
    Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 226.1.1.1), 00:01:34/00:02:58, RP 200.2.3.100, flags: SJCL
      Incoming interface: LISP0.4099, RPF nbr 71.0.0.1
      Outgoing interface list:
        Vlan1500, Forward/Sparse-Dense, 00:01:34/00:02:58


     

    FE2#show  ip mroute  vrf Engineering 226.1.1.1 < — Verify S,G entry after starting traffic from source
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report, 
           Z - Multicast Tunnel, z - MDT-data group sender, 
           Y - Joined MDT-data group, y - Sending to MDT-data group, 
           G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
           N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
           Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
           V - RD & Vector, v - Vector, p - PIM Joins on route, 
           x - VxLAN group, c - PFP-SA cache created entry, 
           * - determined by Assert
    Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 226.1.1.1), 00:21:37/stopped, RP 200.2.3.100, flags: SJCL
      Incoming interface: LISP0.4099, RPF nbr 71.0.0.1
      Outgoing interface list:
        Vlan1021, Forward/Sparse-Dense, 00:21:37/00:02:15

    (200.5.6.100, 226.1.1.1), 00:02:12/00:00:47, flags: JT <---- S,G entry after traffic sent from source
      Incoming interface: LISP0.4099, RPF nbr 71.0.0.1
      Outgoing interface list:
        Vlan1021, Forward/Sparse-Dense, 00:02:12/00:02:15


     

    FE2#show  ip mfib  vrf Engineering  226.1.1.1
    Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                    ET - Data Rate Exceeds Threshold, K - Keepalive
                    DDE - Data Driven Event, HW - Hardware Installed
                    ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB 
                    MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                    MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
    I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                    NS - Negate Signalling, SP - Signal Present,
                    A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                    MA - MFIB Accept, A2 - Accept backup,
                    RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
    Other counts:      Total/RPF failed/Other drops
    I/O Item Counts:   FS Pkt Count/PS Pkt Count
    VRF vrf5000
     (*,226.1.1.1) Flags: C HW
       SW Forwarding: 0/0/0/0, Other: 0/0/0
       HW Forwarding:   625/0/104/0, Other: 0/0/0
       LISP0.4099 Flags: A NS
       Vlan1021 Flags: F IC NS
         Pkts: 0/0
     (200.5.6.100,226.1.1.1) Flags: HW
       SW Forwarding: 0/0/0/0, Other: 0/0/0
       HW Forwarding:   2523851/9899/104/8043, Other: 0/0/0 <---- Verify counters incrementing for S,G entry
       LISP0.4099 Flags: A
       Vlan1021 Flags: F IC NS
         Pkts: 0/0
  8. Repeat steps on Fabric Border (FB)
    ==== FB1 ====




    FB1#show  ip pim  vrf Engineering tunnel 
    Tunnel5 
      Type       : PIM Encap
      RP         : 200.2.3.100*
      Source     : 200.2.3.100
      State      : UP
      Last event : Created (02:39:37)
    Tunnel7* 
      Type       : PIM Decap
      RP         : 200.2.3.100*
      Source     : -
      State      : UP
      Last event : Created (02:39:37)





    FBR#show  ip mroute  vrf Engineering 226.1.1.1 <--- Output  on Sending joins from receiver and  before sending traffic from source)
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report, 
           Z - Multicast Tunnel, z - MDT-data group sender, 
           Y - Joined MDT-data group, y - Sending to MDT-data group, 
           G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
           N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
           Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
           V - RD & Vector, v - Vector, p - PIM Joins on route, 
           x - VxLAN group, c - PFP-SA cache created entry, 
           * - determined by Assert
    Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 226.1.1.1), 00:04:39/00:03:03, RP 200.2.3.100, flags: S
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        LISP0.4099, 70.0.0.1, Forward/Sparse, 00:04:39/00:03:03 < ---- 2 entries as there are 2 receivers behind 2 FEs


          LISP0.4099, 70.0.0.2, Forward/Sparse, 00:04:39/00:03:03 <-----

     

    SG-FBR1#show  ip mroute  vrf vrf5000 226.1.1.1 <---- Verify S,G entry after starting traffic from source
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report, 
           Z - Multicast Tunnel, z - MDT-data group sender, 
           Y - Joined MDT-data group, y - Sending to MDT-data group, 
           G - Received BGP C-Mroute, g - Sent BGP C-Mroute, 
           N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed, 
           Q - Received BGP S-A Route, q - Sent BGP S-A Route, 
           V - RD & Vector, v - Vector, p - PIM Joins on route, 
           x - VxLAN group, c - PFP-SA cache created entry, 
           * - determined by Assert
    Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
     Timers: Uptime/Expires
     Interface state: Interface, Next-Hop or VCD, State/Mode

    (*, 226.1.1.1), 00:26:17/00:03:02, RP 200.2.3.100, flags: S
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        LISP0.4099, 70.0.0.1, Forward/Sparse, 00:26:17/00:03:02


         LISP0.4099, 70.0.0.2, Forward/Sparse, 00:26:17/00:03:02

    (200.5.6.100226.1.1.1), 00:06:03/00:01:55, flags: T
      Incoming interface: Vlan2001, RPF nbr 200.0.0.2
      Outgoing interface list:
        LISP0.4099, 70.0.0.1, Forward/Sparse, 00:06:03/00:03:02


         LISP0.4099, 70.0.0.2, Forward/Sparse, 00:06:03/00:03:02

     

    FB1#show  ip mfib vrf Engineering  226.1.1.1
    Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                    ET - Data Rate Exceeds Threshold, K - Keepalive
                    DDE - Data Driven Event, HW - Hardware Installed
                    ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB 
                    MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                    MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
    I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                    NS - Negate Signalling, SP - Signal Present,
                    A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                    MA - MFIB Accept, A2 - Accept backup,
                    RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
    Other counts:      Total/RPF failed/Other drops
    I/O Item Counts:   FS Pkt Count/PS Pkt Count
    VRF Engineering
     (*,226.1.1.1) Flags: C HW
       SW Forwarding: 0/0/0/0, Other: 0/0/0
       HW Forwarding:   3/0/84/0, Other: 0/0/0
       Tunnel7 Flags: A
       LISP0.4099, 70.0.0.1 Flags: F NS
         Pkts: 0/0
     (200.5.6.100,226.1.1.1) Flags: HW
       SW Forwarding: 0/0/0/0, Other: 0/0/0
       HW Forwarding:   8428458/10000/99/7812, Other: 0/0/0
       Vlan2001 Flags: A
       LISP0.4099, 70.0.0.1Flags: F NS
         Pkts: 0/0


      LISP0.4099, 70.0.0.2Flags: F NS
         Pkts: 0/0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: