cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Communication Between Devices on Different Network

904
Views
0
Helpful
0
Comments
Beginner

Please excuse another beginner trying to learn. I have a feeling I'm missing something simple here, but after a couple of days of searching, I haven't been able to figure it out. 

 

I have the below configuration running on a 1921. 

GE 0/0 is connected directly to a computer used that's acting as a DNS server.
GE 0/1 is connected to a wireless switch. 

GE 0/1/0-3 are connected to various wired devices. 

ATM0/0/0 is connected to DSL. 

 

I can access the Internet from devices attached to each part of the network, but devices on different networks cannot communicate (eg. ping 192.168.2.2 from 192.168.1.15 times out). 

 

Current configuration : 3430 bytes 
!
version 15.7
!
ip dhcp pool WIRELESS_NETWORK
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.2
!
ip dhcp pool WIRED_NETWORK
network 192.168.2.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.2
!
ip dhcp pool vlan2
network 192.168.3.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.2
!
no cdp run
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
no cdp enable
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface ATM0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
ip address dhcp
ip nat outside
ip virtual-reassembly in
atm route-bridged ip
pvc 8/35
encapsulation aal5snap
!
interface GigabitEthernet0/1/0
switchport access vlan 2
switchport mode access
no ip address
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1/1
switchport access vlan 2
switchport mode access
no ip address
no cdp enable
!
interface GigabitEthernet0/1/2
switchport access vlan 2
switchport mode access
no ip address
no cdp enable
!
interface GigabitEthernet0/1/3
switchport access vlan 2
switchport mode access
no ip address
no cdp enable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list DYNAMIC_NAT_ACL interface ATM0/0/0.1 overload
!
ip access-list extended DYNAMIC_NAT_ACL
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
permit ip 192.168.3.0 0.0.0.255 any
ip access-list extended VTY_ACCESS
permit ip 192.168.1.0 0.0.0.255 any
!
no service-routing capabilities-manager
!
end