cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2639
Views
0
Helpful
6
Replies

Nexus Insights 6.0 Install on vND

maced129
Level 1
Level 1

Hello,

 

I am trying to install Nexus Dashboard Insights on the virtual version of Nexus Dashboard however it is failing to install. The install process indicates a failure: "job/post-enable error" and never successfully installs. I looked at logs within the /logs directory but didn't find much of value for troubleshooting. Any other app installs correctly, including NDO, and Nexus Fabric Controller. 

 

Has anyone else seen this issue or something similar, are there any tools to troubleshoot the installation? 

1 Accepted Solution

Accepted Solutions

It ended up being the fact that I didn't have 6 total nodes (3 additional worker nodes) as part of the vND cluster. Once I added the worker nodes to the cluster I was able to install. It did mention this in the documentation, but it didn't seem like a hard requirement. Insights is up and working on the cluster along with MSO. I have not gotten flows to come in but I believe that is another problem.

 

Thanks

Miles

View solution in original post

6 Replies 6

roxadiaz
Cisco Employee
Cisco Employee

Hi maced what version are you trying to install, I test ND 2.1(1d) and NI 6.0.1.37. Can you share the versions that you are ussing? 

I can help yo review if need it. 

Beau Dorman
Cisco Employee
Cisco Employee

Hello Maced129,

 

Are you running Nexus Dashboard version 2.0+?

If so, Nexus Dashboard Release 2 (virtual) does not support Nexus insights. At this time it only supports MSO. Ref: https://www.cisco.com/c/en/us/td/docs/dcn/nd/2x/deployment/cisco-nexus-dashboard-deployment-guide-2x/m-nd-deploy-overview.html

 

Please let me know if this answers your question.

Thank You

It ended up being the fact that I didn't have 6 total nodes (3 additional worker nodes) as part of the vND cluster. Once I added the worker nodes to the cluster I was able to install. It did mention this in the documentation, but it didn't seem like a hard requirement. Insights is up and working on the cluster along with MSO. I have not gotten flows to come in but I believe that is another problem.

 

Thanks

Miles

Hello Miles,

 

Great! I'm glad you were able to work out the issue!

As far as the flows, just make sure you add the subnets when configuring your site groups.

Here are the steps to configure your flows and get that telemetry going:

 

Configure Flow Telemetry as follows.
1. In the Overview screen, at the top, choose your Site Group.
2. Click the Actions menu next to it and choose Configure Site Group
3. In the Configure Site Group page, click Flows.
4. In the General tab, locate the appropriate site and click the Edit icon. (The General tab table
displays the site name and whether the flow collection is enabled or disabled.)
5. In the Edit Flow page, in the Flow Collection Modes area, enable the Flow Telemetry button
All the flows are disabled by default. The sFlow button will remain grayed out as it is not
supported for ACI type.
6. Click Save.
7. In the Flow Telemetry Rules area, the filters are displayed.
8. To add a rule, click the Add link and choose the rule Name, Tenant, VRF details as desired, and
click the checkmark.
9. Next in the Rule Subnets area, add the subnet.
10. In the Rule Subnets field, enter the source and destination IP addresses. If you have endpoints
that are under the same endpoint groups, then you can provide a rule to monitor the subnet.)
11. Click Save
This enables the rule for the Flow Telemetry process to begin

https://www.cisco.com/c/dam/en/us/td/docs/dcn/ndi/6x/user-guide/aci/cisco-ndi-user-guide-release-601-aci.pdf

 

Thank You

mirok
Level 1
Level 1

Hello Maced129,

I run into the similar issue you mentioned "job/post-enable has failed".

My setup:

vND 2.1(2d) (3x APP VM Master, 3x DATA VM Worker)
NI 6.0.2.1945

 

Could you post your exact vND topology? How many vND VMs  APP and/or DATA you have in your cluster?

Did you modified any App Infra Services? If yes to which value?

 

Thanks in advance.

Solved.

vND needs to be build in a way that Data Cluster first and then add APP nodes as workers. Forming the cluster out of 6 Nodes.

After that vND works and you can install NI without issues.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: