cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
185
Views
0
Helpful
7
Replies
Highlighted
Cisco Employee

Commands getting ignored in "commit dry-run"

Hi Team ,

I was trying to automate this snippet of config , Once all of the commands are configured from NSO  for a device, the dry run ignores a few of the commands (Highlighted in RED below) which were allowed on the CLI . Appreciate any inputs on what I could be missing ?

!

ip vrf CUSTOMER-A <customer_name>

rd 100:1  <value_x:value_y>

route-target both <value_y:value_x>

!

!

interface GigabitEthernet4 <pe_to_ce_facing_interface>

no shutdown

ip vrf forwarding CUSTOMER-A <customer_name>

ip address 192.168.100.4 255.255.255.0 <ce_to_pe_facing_interface_ipaddress>

!

!

router eigrp 100

!

address-family ipv4 vrf CUSTOMER-A <customer_name>

  redistribute bgp 1 metric 1500 400 20 20 1500// MISSING

  network 192.168.100.4 <ce_to_pe_facing_interface_ipaddress>

  autonomous-system 100 // MISSING

exit-address-family

!

router bgp 1

bgp log-neighbor-changes

neighbor 4.4.4.4 remote-as 1  <side_b_loopback0_ip_address>

neighbor 4.4.4.4 update-source Loopback0 <side_b_loopback0_ip_address>

!

address-family vpnv4

  neighbor 4.4.4.4 activate <side_b_loopback0_ip_address>

  neighbor 4.4.4.4 send-community both <side_b_loopback0_ip_address>

exit-address-family

!

address-family ipv4 vrf CUSTOMER-A <customer_name> //MISSING

  redistribute eigrp 100 // MISSING

exit-address-family

!

admin@ncs(config-router)# commit dry-run outformat native

native {

  device {

  name SP1

  data interface GigabitEthernet4

  ip vrf forwarding CUSTOMER-A

  ip address 192.168.100.4 255.255.255.0

  no shutdown

  exit

  router bgp 1

  neighbor 10.10.10.10. remote-as 1

  neighbor 10.10.10.10 update-source Loopback0

  address-family vpnv4 unicast

  neighbor 10.10.10.10 activate

  neighbor 10.10.10.10 send-community both

  exit-address-family

  !

  !

  router eigrp 100

  address-family ipv4 vrf CUSTOMER-A

  network 192.168.100.4

  exit-address-family

  !

  !

  }

}

Package details

admin@ncs# show packages package cisco-ios

packages package cisco-ios

package-version 5.8.2

description "NED package for the Cisco IOS"

ncs-min-version [ 3.4.11 4.2.2 4.3.0.2 4.4.2 ]

directory ./state/packages-in-use/1/cisco-ios

component IOSDp

  callback java-class-name [ com.tailf.packages.ned.ios.IOSDp ]

component cisco-ios

  ned cli ned-id cisco-ios

  ned cli java-class-name com.tailf.packages.ned.ios.IOSNedCli

  ned device vendor Cisco

NAME VALUE

-------------------------------------------------------------------------------------------------

show-tag interface

entitlement-tag regid.2015-10.com.cisco.cisco-ios-NED,1.0_d9eca34d-1f6a-4595-ad74-9c0c57e03c27

build-info date "2018-03-14 03:14:44"

build-info file ncs-4.6-cisco-ios-5.8.2.tar.gz

build-info arch linux.x86_64

build-info java "compiled Java class data, version 51.0"

build-info python ""

build-info erlang 18.3.4.5

build-info package name cisco-ios

build-info package version 5.8.2

build-info package ref 5.8.2

build-info package sha1 bfca19f

build-info ncs version 4.6

build-info ncs sha1 ""

build-info dev-support version 1.0

build-info dev-support branch 6f43434

build-info dev-support sha1 6f43434

oper-status up

Thank you !

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Hi Vikas,

This appears to be a bug. I would suggest opening a TAC case to chase this down. One thing, to check is to determine what exactly gets pushed to the router vs. what is in the dry-run. In other words, does the configuration show up on the router?

-Dan

View solution in original post

7 REPLIES 7
Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Team , any pointers here ?

Regards,

vikas

Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Okay, I can't see any text formatted in RED, so I'm not exactly sure what you mean.

-Dan

Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Thanks Daniel ,

My apologies for that , it looks like the color does not show up after saving in the code snippet .

I have appended those lines with "// MISSING"


Please ignore the variable names I have put in  < > , those are just for my refrence .


Regards,

Vikas

Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Hi Vikas,

Ok, when you say missing what do you mean? Are you able to execute a sync-from the device and see the commands in the CDB or are they "missing" after a sync-from operation?

-Dan

Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Hi Daniel ,

The actual routers are not configured with these commands and are added to NSO .

I configure the commands above via NSO , from the "devices device <Router> config "

And after entering the commands above , when I do a "commit dry-run outf xml or native or cli" " I  see all the commands entered above reflected in the dry run except the commands I mentioned as missing .

Let me know if you need further details .

Regards,

Vikas

Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Hi Vikas,

This appears to be a bug. I would suggest opening a TAC case to chase this down. One thing, to check is to determine what exactly gets pushed to the router vs. what is in the dry-run. In other words, does the configuration show up on the router?

-Dan

View solution in original post

Highlighted
Cisco Employee

Re: Commands getting ignored in "commit dry-run"

Thank you Daniel , I will push the changes to the Router and check . Thanks for the prompt responses!

Sent from my iPhone