Showing results for 
Search instead for 
Did you mean: 

Windows 7 and CTC

Level 1
Level 1

                  I'm sure this has been covered on here before but just got a new laptop with Windows 7 and cannot get CTC to work, CTP is fine and works much better under Windows 7 because it can make use of the additional memory but CTC just hangs while it is loading, anyone who has got this working can they post up instructions please.



7 Replies 7

Level 1
Level 1

32 Views but no one using Windows 7, I sometimes wish I wasn't on the bleeding edge of technology, much prefer following along behind :-)

Level 1
Level 1

Quoting Amit's response from another related thread:

"CTC does run on a newer version of Windows including Win-7. Look at the reference manual “PC and UNIX Workstation Requirements” section to get full details. You will need to ensure correct version of JRE as per your release. I guess you are probably using R7.x."

Hope this helps.


This should fix it.

netsh interface tcp set global autotuninglevel=disabled

Thanks guys, so far nothing has worked, I've downloaded various versions of Java but it keeps coming up with an error message

Cisco Transport Controller 07.22-007B-15.13 Status:

Cannot run program "". CreateProcess error=2, The

system cannot find the file specified

Using Windows 7 64bit OS

Any suggestions gratefully received

It seems like you are having a couple issues.  The first is with java which looks like you are trying to run a version that either doesn't work with Windows 7 or doesn't run with 64 bit.  When you are installing java you will need to install the 64 bit version as well as the 32 bit one.   Have you tried running CTC using "startctc.exe" which you can download it from the node?

The next issue is a Windows 7 issue which can be fixed using th ecommand I supplied yesterday.

netsh interface tcp set global autotuninglevel=disabled

and verify it is disabled using

netsh interface tcp show global

More information can be found

Another thing you may need to check is how you are being routed to the node.  If you are you using a PIX/ASA you may be running into the MSS (Maximum Segment Size) problem. More information can be found here:

Hope at least some of this helps.

Thanks to everyone who has replied so far, still can't get CTC to work under Windows 7, I now have a Windows XP machine just for CTC access but that is a desktop so won't be much help on customers sites.

Any other suggestions gratefully received.

With a bit of help from someone at Di-Data I have manged to get CTC working under Windows 7 Enterprise 64 bit by using the Virtual XP platform:

Is all I did was to install Virtual PC and XP Mode following these instructions:

Its not running under Windows 7 as such but it works and saves me having to carry another laptop just to access the ONS15xxx, incidentaly I have another vendors application that wouldn't work under Windows 7 and its fixed that as well :-)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: