cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
439
Views
0
Helpful
2
Replies

LAN QoS

p.holley
Level 1
Level 1

Hi All,

I have the following config to give priority to my video endpoint on the LAN with an IP Precedence 4. This is assuming that my ISP has QoS set on the WAN Edge router on the MPLS cloud (I do not have access to this router). Here is my config.

Switch

mls qos srr-queue input threshold 2 50 50

mls qos srr-queue input priority-queue 1 bandwidth 40

mls qos srr-queue input dscp-map queue 1 threshold 2 32 40 48 56

mls qos srr-queue input dscp-map queue 2 threshold 1 0 6 16 24

mls qos

class-map match-all Video_Traffic

match access-group 101

!

!

policy-map Mission_Critical

class Video_Traffic

set ip dscp 32

class class-default

set ip precedence 0

interface range FastEthernet1/0/1 - 23

switchport access vlan 4

switchport mode access

no ip address

duplex full

speed 100

service-policy input Mission_Critical

mdix auto

spanning-tree portfast

interface FastEthernet1/0/24

description *** connection to ISP MPLS WAN***

switchport access vlan 11

switchport mode access

no ip address

priority-queue out

mdix auto

spanning-tree portfast

access-list 101 permit udp any any range 3230 3235

access-list 101 permit tcp any any range 3230 3235

access-list 101 permit ip any any precedence flash-override

-----------------------------------------------------------

Will this config work in providing Video (ip prec 4)Priority on the LAN, and outgoing to the LAN interface of the router. If not can someone send me a working config?

Thanks

2 Replies 2

d.heo
Level 1
Level 1

Try like this,

I'm not 100% sure because I can't access my equipments right now.

After you do that, check it with ip accounting.

mls qos srr-queue input threshold 2 50 50

mls qos srr-queue input priority-queue 1 bandwidth 40

mls qos srr-queue input dscp-map queue 1 threshold 2 32 40 48 56

mls qos srr-queue input dscp-map queue 2 threshold 1 0 6 16 24

mls qos

class-map match-all Video_Traffic

match access-group 101

!

!

policy-map Mission_Critical

class Video_Traffic

set ip precedence 4

class class-default

set ip precedence 0

interface range FastEthernet1/0/1 - 23

switchport access vlan 4

switchport mode access

no ip address

duplex full

speed 100

mdix auto

spanning-tree portfast

interface FastEthernet1/0/24

description *** connection to ISP MPLS WAN***

switchport access vlan 11

switchport mode access

no ip address

service-policy output Mission_Critical

mdix auto

spanning-tree portfast

access-list 101 permit udp any any range 3230 3235

access-list 101 permit tcp any any range 3230 3235

I thought service-poicy can only be applied as input on Cat switches. I will try out your config. Thanks