cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3240
Views
0
Helpful
6
Replies

Valcom Overhead Paging System with FXO - Disable DTMF Tones

mpaul
Beginner
Beginner

I have a valcom V2000a paging system. http://www.valcom.com/v-2000a.htm

I have it connected to an FXO port on a 1760 router. The router is configured with MGCP connected to a call manager 4.01 cluster. I have a dial pattern 5550 configured to dial the FXO port connected to the Valcom device. When you dial you hear on the speakers, beep, beep, beep, beep "This is a test."

The beep, beep, beep, beep is the DTMF tones being broadcast over the speakers.

How do I disable the DTMF tones? We cannot use the forward-digits 0 on the dial peer since it is MGCP. I also tried to globally disable forward of dtmf tones to test. This did not work and we'll eventually need DTMF tones enabled so this is not a valid alternative for us.

We have a similar configuration with a previous client however it is on Call Manager 3.3. We resolved this exact problem by creating a dial pattern, 5550. and configured the pattern to drop pre-dot. This worked for this 3.3 call manager client.

I tried this same configuration with the 4.0 call manager client. The pattern is 5550. and setup to drop pre-dot. However when I dial I receive a fast busy and callerid of "External Call". In reviewing the Call Manager trace files I see a "nopatternmatch" statement. I tried the following variation in the pattern, if I do a 5550. and set it to drop predot but added a * for prefix digits the result is a little better in I only hear one beep over the speakers.

I found an interesting Service Parameter called: DTMF Silence Tone Flag. The default is false. According to call manager it states, "This parameter applies only to Cisco Analog Station and Cisco Analog Trunk gateways. This parameter designates whether silence is played after receiving the Alert message. Valid values are True (the digital gateway plays silence) or False (the digital gateway does not play silence). Setting this parameter to False may enable a full-duplex path before the Connect message is received on ISDN calls, which could result in echo. "

I changed the setting to True but it did not make a difference and have since set it back to the default. Can anybody shed some light on how other Valcom paging systems were configured to eliminate this DTMF tone or has Cisco changed a Call Manager setting I could adjust back to how it was on Call manager 3.3?

Thank you in advance.

6 Replies 6

mciarfello
Enthusiast
Enthusiast

Hehe. We've had the same problem for years. The ladies in the office think it's cute so I stopped investigating it. Actually they said it's better than the 2 second tone that was heard on the pbx. Expectations.

I would think you would want some kind of tone before a voice announcement.

Let me know what you come up with. I never tried the get rid of pre-dot back then.

Well with the pre-dot for the pattern on CM 3.3 the DTMF tones disappeared completely. That was very clever. Just trying to duplicate what they have now. On the 4.0 CM that doesn't work. I have opened a TAC case and the first suggestion they had was forward-digits 0 on the dial peer. Great for h.323 but MGCP, is a no go. I'll post back if I find a solution. Thanks for your reply.

p.choi
Beginner
Beginner

I was able to set up a workaround in which I configured a route pattern with 1 single digit.

I used 6.

So when you dial 6-it takes you directly to the overhead paging system, no DTMF tones.

The partition was set to PT Local

beowulfs
Beginner
Beginner

I'm using a valcom off a 2651xm fxo. i don't remember what it is though. here's the router config.

dial-peer voice 8 pots

preference 1

destination-pattern 71

port 1/1/3

prefix 1

The prefix is the paging zone for the valcom. we only use pagig zone 1.

CCM 4.02a

The route plan is 71. the only change to default is no outside dial tone and my route group. the route list in the route group discards NONE. i don't hear the dtmf tones. don't know if this will help, but wanted to chime in. i saw your workaround too.

I would be highly interested to know how you made this work. Cisco TAC has assigned this bug ID for this problem.

CSCef80100

MGCP with a 4.0 callmanager. Both of the workarounds they suggest are not great.

I had the same problem using Cisco Unified CM Administration version 11.5, a Cisco 4331 router with a NIM 2FXS/4FXO card, a Viking Model FBI-1A and a Valcom V-2001A.

The solution was to modify the Route Pattern from 70 (which is what we use to page) to 70. (70 dot)

Then, you can set the Called Party Transformations section -Discard Digits - to PreDot. 

Then be sure to Save.

Doing this will stop the 70 digits from playing over the paging system.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: