Hello, I'm trying to get my head around putting in VoIP across a Frame Relay link. and im new to putting in QoS across frame.
We have the main office with call manager and a satellite office with 25 phones.
the link has a 2meg port speed with a 1meg CIR.
Can some one have a look at my config and let me know if i have done it right
thanks in advance
(I've only included the relevant parts of the config)
!
class-map match-all VoIP-Sig
match ip dscp af31
match ip precedence 3
match access-group name ACL-VoIP-Sig
class-map match-all VoIP-RTP
match ip dscp ef
match ip precedence 5
match access-group name ACL-VoIP-RTP
!
policy-map VOICE-POLICY
class VoIP-RTP
priority 480
class VoIP-Sig
bandwidth 16
class class-default
fair-queue
!
!
interface Serial0/0
no ip address
service-policy output VOICE-POLICY
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
frame-relay lmi-type ansi
!
interface Serial0/0.16 point-to-point
ip address 10.10.10.18 255.255.255.252
no ip route-cache
no ip mroute-cache
no cdp enable
frame-relay interface-dlci 16 IETF
!
!
map-class frame-relay VOIPovFR
frame-relay cir 1024000
frame-relay bc 10240
frame-relay mincir 1024000
service-policy output VOICE-POLICY
frame-relay fragment 320
!
ip access-list extended ACL-VoIP-RTP
permit udp any any range 16384 32768
ip access-list extended ACL-VoIP-Sig
permit tcp any eq 1720 any
permit tcp any any eq 1720
permit tcp any any eq 2000
permit tcp any eq 2000 any
!