01-29-2013 08:22 AM - edited 03-01-2019 07:15 AM
I have connected a Nexus 4001i blade switch to two Nexus 5548 switches. I created a vpc from the two Nexus 5548 switches down to a port-channel that I created on the Nexus 4001i on ports e1/15 and e1/16. The Nexus 5548 does not have the layer 3 hardware so it is a layer 2 switch only. I have a Catalyst 3750X connected to the Nexus 5548 and I am using the Catalyst 3750 for all vlan routing. I also had two Nexus 2248 switches connected to the Nexus 5548. I can route traffic fine from the FEX but can not route traffic from the Nexus 4001i. My question is should I be able to route traffic from Nexus 4001i or do I have to have the layer 3 hardware installed in the Nexus 5548 for this to work?
Nexus 4001i config
*****************************
sh run
version 4.1(2)E1(1f)
feature telnet
feature interface-vlan
feature lacp
feature lldp
vrf context management
ip route 0.0.0.0/0 172.16.17.1
vlan 1
interface port-channel15
switchport mode trunk
switchport trunk native vlan 999
speed 10000
interface Ethernet1/1
switchport mode trunk
switchport trunk native vlan 999
spanning-tree port type edge
speed auto
interface Ethernet1/2
switchport mode trunk
switchport trunk native vlan 999
spanning-tree port type edge
speed auto
interface Ethernet1/3
switchport mode trunk
switchport trunk native vlan 999
spanning-tree port type edge
speed auto
interface Ethernet1/4
switchport mode trunk
switchport trunk native vlan 999
spanning-tree port type edge
speed auto
interface Ethernet1/5
spanning-tree port type edge
speed auto
interface Ethernet1/6
spanning-tree port type edge
speed auto
interface Ethernet1/7
spanning-tree port type edge
speed auto
interface Ethernet1/8
spanning-tree port type edge
speed auto
interface Ethernet1/9
spanning-tree port type edge
speed auto
interface Ethernet1/10
spanning-tree port type edge
speed auto
interface Ethernet1/11
spanning-tree port type edge
speed auto
interface Ethernet1/12
spanning-tree port type edge
speed auto
interface Ethernet1/13
spanning-tree port type edge
speed auto
interface Ethernet1/14
spanning-tree port type edge
speed auto
interface Ethernet1/15
switchport mode trunk
switchport trunk native vlan 999
speed 10000
channel-group 15
interface Ethernet1/16
switchport mode trunk
switchport trunk native vlan 999
speed 10000
channel-group 15
interface Ethernet1/17
speed 10000
interface Ethernet1/18
speed 10000
interface Ethernet1/19
speed 10000
interface Ethernet1/20
speed 10000
interface mgmt0
vrf member management
ip address 172.16.17.15/24
interface mgmt1
cli alias name blade1 telnet 172.16.17.15 vrf management
cli alias name blade2 telnet 172.16.17.16 vrf management
cli alias name core1 telnet 172.16.17.5 vrf management
cli alias name wr copy run startup
cli alias name core2 telnet 172.16.17.6 vrf management
boot kickstart bootflash:/n4000-bk9-kickstart.4.1.2.E1.1f.bin
boot system bootflash:/n4000-bk9.4.1.2.E1.1f.bin
system health loopback frequency 60
ip route 0.0.0.0/0 172.16.17.1
N4000.k6.Module7.blade1#
*************************************************
Nexus 5548 config
version 5.2(1)N1(2a)
hostname N5548.k6.Core1
feature telnet
cfs eth distribute
feature interface-vlan
feature hsrp
feature lacp
feature vpc
feature lldp
feature vtp
feature fex
no password strength-check
banner motd #Nexus 5000 Switch
#
ip domain-lookup
class-map type qos class-fcoe
class-map type queuing class-fcoe
match qos-group 1
class-map type queuing class-all-flood
match qos-group 2
class-map type queuing class-ip-multicast
match qos-group 2
class-map type network-qos class-fcoe
match qos-group 1
class-map type network-qos class-all-flood
match qos-group 2
class-map type network-qos class-ip-multicast
match qos-group 2
policy-map type control-plane copp-system-policy-customized
class copp-system-class-default
police cir 2048 kbps bc 6400000 bytes
fex 129
pinning max-links 1
description "FEX0129"
fex 130
pinning max-links 1
description "FEX0130"
vrf context management
vpc domain 1
role priority 2000
peer-keepalive destination 172.16.251.2
delay restore 150
peer-gateway
port-profile default max-ports 512
interface Vlan1
interface Vlan17
no shutdown
ip address 172.16.17.5/24
interface port-channel1
description ## Connected Nexus 4001i module 7 PORT e1/15 ##
switchport mode trunk
switchport trunk native vlan 999
speed 10000
vpc 1
interface port-channel2
description ## Connected Nexus 4001i module 7 PORT e1/15 ##
switchport mode trunk
switchport trunk native vlan 999
speed 10000
vpc 2
interface port-channel27
description ## PORT CHANNEL TO CATALYST 3750 ##
switchport mode trunk
switchport trunk native vlan 999
speed 1000
vpc 27
interface port-channel29
description ## Channel Group Fex Fabric 29 ##
switchport mode fex-fabric
fex associate 129
vpc 29
interface port-channel30
description ## Channel Group Fex Fabric 30 ##
switchport mode fex-fabric
fex associate 130
vpc 30
interface port-channel32
description ## Port-Channel Peer-Link CORE 2 ##
switchport mode trunk
spanning-tree port type network
speed 10000
vpc peer-link
interface Ethernet1/1
description ## Nexus 4001i module 7 PORT e1/15 ##
switchport mode trunk
switchport trunk native vlan 999
channel-group 1
interface Ethernet1/2
description ## Nexus 4001i module 7 PORT e1/15 ##
switchport mode trunk
switchport trunk native vlan 999
channel-group 2
interface Ethernet1/3
interface Ethernet1/4
interface Ethernet1/5
interface Ethernet1/6
interface Ethernet1/7
interface Ethernet1/8
interface Ethernet1/9
interface Ethernet1/10
interface Ethernet1/11
interface Ethernet1/12
interface Ethernet1/13
interface Ethernet1/14
interface Ethernet1/15
interface Ethernet1/16
interface Ethernet1/17
interface Ethernet1/18
interface Ethernet1/19
interface Ethernet1/20
interface Ethernet1/21
interface Ethernet1/22
interface Ethernet1/23
interface Ethernet1/24
interface Ethernet1/25
interface Ethernet1/26
interface Ethernet1/27
description ## CONNECTED TO CATALYST 3750 PORT G1/1/3 ##
switchport mode trunk
switchport trunk native vlan 999
speed 1000
channel-group 27
interface Ethernet1/28
interface Ethernet1/29
description ## CONNECT FEX FABRIC 129 ##
switchport mode fex-fabric
fex associate 129
channel-group 29
interface Ethernet1/30
description ## CONNECT FEX FABRIC 130 ##
switchport mode fex-fabric
fex associate 130
channel-group 30
interface Ethernet1/31
description ## VPC UPLINK NEXUS CORE2 ##
switchport mode trunk
channel-group 32 mode active
interface Ethernet1/32
description ## VPC UPLINK NEXUS CORE2 ##
switchport mode trunk
channel-group 32 mode active
interface mgmt0
vrf member management
ip address 172.16.251.1/30
interface Ethernet129/1/1
interface Ethernet129/1/2
interface Ethernet129/1/3
interface Ethernet129/1/4
interface Ethernet129/1/5
interface Ethernet129/1/6
interface Ethernet129/1/7
interface Ethernet129/1/8
interface Ethernet129/1/9
interface Ethernet129/1/10
interface Ethernet129/1/11
interface Ethernet129/1/12
interface Ethernet129/1/13
interface Ethernet129/1/14
interface Ethernet129/1/15
interface Ethernet129/1/16
interface Ethernet129/1/17
interface Ethernet129/1/18
interface Ethernet129/1/19
interface Ethernet129/1/20
interface Ethernet129/1/21
interface Ethernet129/1/22
interface Ethernet129/1/23
interface Ethernet129/1/24
interface Ethernet129/1/25
interface Ethernet129/1/26
interface Ethernet129/1/27
interface Ethernet129/1/28
interface Ethernet129/1/29
interface Ethernet129/1/30
interface Ethernet129/1/31
interface Ethernet129/1/32
interface Ethernet129/1/33
interface Ethernet129/1/34
interface Ethernet129/1/35
interface Ethernet129/1/36
interface Ethernet129/1/37
interface Ethernet129/1/38
interface Ethernet129/1/39
interface Ethernet129/1/40
interface Ethernet129/1/41
interface Ethernet129/1/42
interface Ethernet129/1/43
interface Ethernet129/1/44
interface Ethernet129/1/45
interface Ethernet129/1/46
interface Ethernet129/1/47
interface Ethernet129/1/48
interface Ethernet130/1/1
switchport access vlan 114
interface Ethernet130/1/2
interface Ethernet130/1/3
interface Ethernet130/1/4
interface Ethernet130/1/5
interface Ethernet130/1/6
interface Ethernet130/1/7
interface Ethernet130/1/8
interface Ethernet130/1/9
interface Ethernet130/1/10
interface Ethernet130/1/11
interface Ethernet130/1/12
interface Ethernet130/1/13
interface Ethernet130/1/14
interface Ethernet130/1/15
interface Ethernet130/1/16
interface Ethernet130/1/17
interface Ethernet130/1/18
interface Ethernet130/1/19
interface Ethernet130/1/20
interface Ethernet130/1/21
interface Ethernet130/1/22
interface Ethernet130/1/23
interface Ethernet130/1/24
interface Ethernet130/1/25
interface Ethernet130/1/26
interface Ethernet130/1/27
interface Ethernet130/1/28
interface Ethernet130/1/29
interface Ethernet130/1/30
interface Ethernet130/1/31
interface Ethernet130/1/32
interface Ethernet130/1/33
interface Ethernet130/1/34
interface Ethernet130/1/35
interface Ethernet130/1/36
interface Ethernet130/1/37
interface Ethernet130/1/38
interface Ethernet130/1/39
interface Ethernet130/1/40
interface Ethernet130/1/41
interface Ethernet130/1/42
interface Ethernet130/1/43
interface Ethernet130/1/44
interface Ethernet130/1/45
interface Ethernet130/1/46
interface Ethernet130/1/47
interface Ethernet130/1/48
cli alias name wr copy run startup
cli alias name core2 telnet 172.16.251.2 vrf management
cli alias name core1 telnet 172.16.251.1 vrf management
cli alias name blade1 telnet 172.16.17.15
cli alias name blade2 telnet 172.16.17.16
line console
line vty
boot kickstart bootflash:/n5000-uk9-kickstart.5.2.1.N1.2a.bin
boot system bootflash:/n5000-uk9.5.2.1.N1.2a.bin
ip route 0.0.0.0/0 172.16.17.1
ip routing multicast software-replicate
N5548.k6.Core1#
Solved! Go to Solution.
01-31-2013 07:48 PM
Hi Maurice,
Are you trying a ping using default vrf or management vrf i mean
ping x.x.x.x or ping x.x.x.x vrf management
if you are just doing ping x.x.x.x its not going to work since there are no IP defined in default vrf context.
If you are trying ping x.x.x.x vrf management then are you able to ping the default gateway, 172.16.17.1 ? if yes see if you have proper routing configured on the L3 router that is your CAT3750.
Hope this helps.
Thank
JayaKrishna
01-31-2013 07:48 PM
Hi Maurice,
Are you trying a ping using default vrf or management vrf i mean
ping x.x.x.x or ping x.x.x.x vrf management
if you are just doing ping x.x.x.x its not going to work since there are no IP defined in default vrf context.
If you are trying ping x.x.x.x vrf management then are you able to ping the default gateway, 172.16.17.1 ? if yes see if you have proper routing configured on the L3 router that is your CAT3750.
Hope this helps.
Thank
JayaKrishna
01-31-2013 11:51 PM
ok, thanks for the help
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide