cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
20620
Views
10
Helpful
6
Replies

sfp validation failed (nexus)

shiraforkosh1
Level 1
Level 1

Hi,

i have a cisco nexus 5000 and i connect to it a fex (model: N2K-C2232PP-10GE).

I have 3 ports in the fex with there error messege of "sfp validation failed". I saw in many sites that the soltuion is to pull out the sfp, then set the port's speed to 1000 and inerst back the sfp. I did it, and also shut/no shut the port, and check it with several sfp, and the error not change.

When i pulled out the sfp , the port not shows as empty (no messege that not sfp inside), and still there was a messege of validation failed. After put other sfp and pull it out again, the port shows as empty(but after inerst it back the error shows again). Also the ports are bliking in orange lights. 

The sfp i use is FET-10G (cisco sfp).

Does anybody know what can be the problem?

6 Replies 6

AFROJ AHMAD
Cisco Employee
Cisco Employee

Hi,

Kindly make sure you have the below command configured on that interface::

"switchport mode fex-fabric"

Thanks-

Afroz

***Ratings Encourages Contributors ***

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

it is been configured already (if it didn't the fex wasn't work at all)

Akheel Kapoor
Cisco Employee
Cisco Employee

Have you tried the following commands.

"service unsupported-transceiver" and "no errdisable detect cause
 gbic-invalid" commands

I have encountered a similar issue,

The interface was showing "down (Transceiver validation failed)"

The issue was with the SFP that we used, once it was replaced from FET to SFP the problem was solved. 

FET-10G - which is for Fabric Extenders.

SFP-10G - which is for Data.

Adam_Lewis
Level 1
Level 1

Altering the speed is just one little part of the solution for a "SPF validation failed".

Before association of Port as FEX, port must be set to FEX speed.

 

Below is my solution that's worked the many times I've run into the "SPF validation failed" issue.

 

The number one cause of FEX "SPF validation failed" was incorrect port speed on the port being used as FEX port.. Often when a port that has previously been used as access/trunk port and later repurposed as FEX, speed may have been altered which can cause havoc with FEX.

 

The issue will sometimes crop up on a subsequent reboot after FEX was configured.  I.E FEX will work on first configuration, but not on reboot.

 

SOLUTION:  (FEX transceiver can remain in the slot)

1) Remove the port from FEX association.

       * no channel-groups

       * no fex associate

       * switchport mode access

       * shutdown

 

2) Change Port speed

       * speed 10000

 

3) Add back to FEX  (assuming your fex is 108 and 8 is channel-group used)

       * switchport mode fex-fabric

       * fex associate 108  

       * channel-group 8

       * no shutdown

 

This solution will fix issue a majority of the time, assuming physical or component issues are not also part of the problem.

 

Hope this helps someone.

Thx

Adam Lewis

smakbarzada
Level 1
Level 1

Hey All,

 

i came across the same issue - if the port is configured in FEC mode, change into Auto mode and turn the port shut. Change the Duplex settings to whatever the connected bandwidth is in my case it's 10000. and turn on the port by no shut.

 

interface Ethernet X/X
ptp
ptp role master
ptp delay-request minimum interval smpte-2059-2 -3
ptp announce interval smpte-2059-2 0
ptp sync interval smpte-2059-2 -3
ptp announce timeout smpte-2059-2 3
speed 10000  <---- change the speed 
ip address 10.X.X.X/XX
ip ospf passive-interface
ip router ospf 1 area 0.0.0.0  <--- remove the ospf routes and re-enter manually.
ip pim sparse-mode
ip igmp version 3
ip igmp immediate-leave
ip igmp suppress v3-gsq
no shutdown

 

Good Luck