cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2043
Views
5
Helpful
4
Replies
lunar_rover
Beginner

single sided VPC to a 3750 switch

Hi,

Have set up a simple VPC arrangement between two Nexus 7ks, offering a vpc down to a 3750 switch.

I was sort of expecting the 3750 switch end to be spanning tree forwarding on both of it's port-channel's member ports, but it's actually blocking on the link going to the second 7k.

Am I expecting the wrong thing, or have I misconfigured somewhere?

Thanks in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi

When I look at the Catalyst 3750 the ports are showing with an I (stand-alone) flag i.e., they're not part of the port-channel, but still considered as individual links. I believe the reason for this is that they are not receiving LACPDU from the Nexus 7000. You should be able to confirm this with the show lacp counters commands.

The reason the Nexus 7000 is not sending LACPDU is that in the interface configuration the command channel-group 100 actually configures the port-channel as a static port-channel and not an LACP port-channel.

From the Configuring Port Channels section of the NX-OS Interfaces Configuration Guide for the channel-group command:

This command creates the port channel associated with this channel group if the port channel does not already exist. All static port-channel interfaces are set to mode on. You must set all LACP-enabled port-channel interfaces to active or passive. The default mode is on.

If you change the interface command to channel-group 100 mode active I think you'll correct the issue. The unfortunate thing is that to do this you'll have to remove the channel-group command completely and re-add it.

Regards

View solution in original post

Ah, got you, I didn't appreciate the "on" state meant that, much obliged for the answer Steve.

View solution in original post

4 REPLIES 4
Steve Fuller
Engager

Hi,

You're not expecting the wrong thing here. The Catalyst 3750 should see its two links bundled together as part of the same port-channel interface wit both links forwarding.

Can you paste the output of a show vpc and a show port-channel summary from the Nexus and a show etherchannel summary from the Catalyst? If you can post the configuration for the physical and port-channel interfaces from both the Nexus and the Catalyst that would also help.

Regards

Hi Steve, thanks for replying:

3750

3750#sh eth summ

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:          1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SD)        LACP      Gi1/0/27(I) Gi1/0/28(I)

interface GigabitEthernet1/0/27

description 7k1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

interface GigabitEthernet1/0/28

description 7k2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree link-type point-to-point

7k1 (and 7k2, output is identical on both)

7K1# sh vpc

Legend:                 (*) - local vPC is down, forwarding via vPC

peer-link vPC domain id                    : 10

Peer status                                : peer adjacency formed ok

vPC keep-alive status                      : peer is alive

Configuration consistency status           : success

Per-vlan consistency status                : success

Type-2 consistency status                  : success

vPC role                                   : primary

Number of vPCs configured                  : 4

Peer Gateway                               : Enabled

Peer gateway excluded VLANs                : -

Dual-active excluded VLANs                 : -

Graceful Consistency Check                 : Enabled

Auto-recovery status                       : Enabled (timeout = 240 seconds)

vPC Peer-link status

---------------------------------------------------------------------

id  Port  Status Active vlans

--  ----  ------ --------------------------------------------------

1    Po1000 up    1,10,20,30,100

vPC status

----------------------------------------------------------------------

id  Port  Status Consistency Reason                    Active vlans

--  ----  ------ ----------- ------                    ------------

10  Po10  up    success    success                    10,20,30,100

20  Po20  up    success    success                    10,20,30,100

30  Po30  up    success    success                    10,20,30,100

100 Po100 up    success    success                    10,20,30,100

7K1# sh port-channel summ

Flags:  D - Down        P - Up in port-channel (members)

         I - Individual  H - Hot-standby (LACP only)

         s - Suspended   r - Module-removed

         S - Switched    R - Routed

         U - Up (port-channel)

         M - Not in use. Min-links not met

--------------------------------------------------------------------------------

Group Port-      Type    Protocol  Member Ports       Channel

--------------------------------------------------------------------------------

10    Po10(SU)    Eth      LACP      Eth1/9(P)    Eth1/17(P)

20    Po20(SU)    Eth      LACP      Eth1/21(P)  Eth1/25(P)

30    Po30(SU)    Eth      LACP      Eth1/22(P)  Eth1/26(P)

100   Po100(SU)   Eth      NONE      Eth1/47(P)

1000  Po1000(SU)  Eth      LACP      Eth1/1(P)    Eth1/5(P)

vpc domain 10

  peer-switch

  role priority 10

  peer-keepalive destination 192.168.1.2 source 192.168.1.1 vrf VPC_KPAL

  peer-gateway   auto-recovery

interface port-channel100

   switchport

   switchport mode trunk

   switchport trunk native vlan 888

   switchport trunk allowed vlan 2-4094

   spanning-tree port type normal

   vpc 100

interface Ethernet1/47

   description 3750switch

   switchport

   switchport mode trunk

   switchport trunk native vlan 888

   switchport trunk allowed vlan 2-4094

   channel-group 100

   no shutdown

Obviously the "NONE2 instead of "LACP" stands out, but both ends are doing LACP so I'm not sure what's going on here...

Hi

When I look at the Catalyst 3750 the ports are showing with an I (stand-alone) flag i.e., they're not part of the port-channel, but still considered as individual links. I believe the reason for this is that they are not receiving LACPDU from the Nexus 7000. You should be able to confirm this with the show lacp counters commands.

The reason the Nexus 7000 is not sending LACPDU is that in the interface configuration the command channel-group 100 actually configures the port-channel as a static port-channel and not an LACP port-channel.

From the Configuring Port Channels section of the NX-OS Interfaces Configuration Guide for the channel-group command:

This command creates the port channel associated with this channel group if the port channel does not already exist. All static port-channel interfaces are set to mode on. You must set all LACP-enabled port-channel interfaces to active or passive. The default mode is on.

If you change the interface command to channel-group 100 mode active I think you'll correct the issue. The unfortunate thing is that to do this you'll have to remove the channel-group command completely and re-add it.

Regards

View solution in original post

Ah, got you, I didn't appreciate the "on" state meant that, much obliged for the answer Steve.

View solution in original post

Content for Community-Ad