cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
504
Views
3
Helpful
7
Replies

1721 Config for SBC DSL - Round 1

jwynacht
Level 1
Level 1

Hi,

I've been working with a Cisco 1721 as I want to use it as my home office router. I grabbed the config from my SBC-provided Cayman router and went to work.

I'm having a hard time getting it connected to the SBC side of things. I can set up FE0 and ping the router and all that but getting it connected to the WAN isn't happening. I've read a bunch of docs from cisco.com about this but haven't come to any great conclusion. I'm thinking, given the time put it, it's really something simple I've overlooked.

Here is the conifg so far, let me know what you think, if anything.

Thanks,

Jon

Router#show run

Building configuration...

Current configuration : 996 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

!

interface FastEthernet0

ip address <current_router_ip> <current_lan_subnet>

ip nat inside

speed auto

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

shutdown

!

interface Vlan1

no ip address

!

interface BVI1

ip address <current_wan_ip> <current_wan_subnet>

ip nat outside

!

ip classless

no ip http server

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

!

end

7 Replies 7

Hello,

as far as I can see, you are missing a few NAT statements, your NAT interfaces do not know what and where to translate to. Try and add the following to your configuration (all in global config mode):

ip nat inside source list 1 interface bvi1 overload

access-list 1 permit X.X.X.X

ip route 0.0.0.0 0.0.0.0 bvi1

whereby X.X.X.X is the network you are using for your LAN.

Regards,

GP

GP,

Thanks for getting back to me. I updated my config (see below) but I'm still not getting any connectivity. Not even a light for CDL. Here are some specs about my box:

Cisco 1721/ADSL-WIC/4-Port Enet Switch

WAN IP: 68.xxx.xxx.14

WAN Gateway: 68.xxx.xxx.13

WAN Subnet: 255.255.255.252

LAN Gateway: 64.xxx.xx.54

LAN Subnet: 255.255.255.248

Static IPs: 64.xxx.xx.49-53

DNS: 206.13.28.12, 206.13.31.12

Also when I do a show ip interface brief I get this:

Router#show ip interface brief

Interface IP-Address OK? Method Status Protocol

BVI1 68.126.170.14 YES manual up up

Vlan1 unassigned YES unset up down

ATM0 unassigned YES manual up up

FastEthernet0 64.172.43.54 YES manual up down

FastEthernet1 unassigned YES unset administratively down down

FastEthernet2 unassigned YES unset administratively down down

FastEthernet3 unassigned YES unset administratively down down

FastEthernet4 unassigned YES unset administratively down down

This clearly shows my FE0 protocol down, which I'm thinking means it's just misconfigured on my end.

To be clear are the following mappings correct:

interface FastEthernet0

ip address 64.xxx.xx.54 255.255.255.248

ip nat inside

speed auto

interface BVI1

ip address 68.xxx.xxx.14 255.255.255.252

ip nat outside

!

My thought is that's where my issue is.

Thanks for the help!

Jon

Router#show run

Building configuration...

Current configuration : 1112 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

!

interface FastEthernet0

ip address 64.xxx.xx.54 255.255.255.248

ip nat inside

speed auto

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

shutdown

!

interface Vlan1

no ip address

!

interface BVI1

ip address 68.xxx.xxx.14 255.255.255.252

ip nat outside

!

ip nat inside source list 1 interface BVI1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 BVI1

no ip http server

!

!

access-list 1 permit 64.xxx.xx.54

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

!

end

I am having the same issue with a 1751. The 1 port adsl card. I was able to confirm an ATM ping with SBC but I could not route out. I am using a VLAN interface rather than a BVI. But the rest is the same. FastE is nat outside Vlan is nat inside

I'll check back when you solve the problem.

I worked this one out finally. If anybody need assistance I don't mind helping out. Just let me know. Thanks all for helping!

Jon

Hi Jon,

What did you do? I still have no solution.

Thanks,

Michael

Try this. It will get you basic connectivity from FE0.

Jon

Router#show conf

Using 1206 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no logging console

!

no aaa new-model

ip subnet-zero

!

!

!

!

ip name-server

ip name-server

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

!

interface FastEthernet0

ip address

ip nat outside

speed auto

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

shutdown

!

interface Vlan1

no ip address

!

interface BVI1

ip address

ip nat outside

!

ip nat inside source list 1 interface BVI1 overload

ip classless

ip route 0.0.0.0 0.0.0.0

no ip http server

!

!

access-list 1 permit 0.0.0.255

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

!

end

Jon,

thanks,

Mike

Review Cisco Networking for a $25 gift card