01-06-2015 09:45 AM - edited 03-03-2019 07:43 AM
hi all ,I have router that I configured BGP ,it works fine ,here is the output from it
Building configuration...
Current configuration : 2106 bytes
!
! Last configuration change at 17:27:17 UTC Tue Jan 6 2015
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SPIBR001
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
enable secret 5 $1$SqNF$Gju2ru8a2vuU/UkwbI7ph0
!
no aaa new-model
!
ip cef
!
!
!
!
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
!
!
!
license udi pid CISCO2951/K9 sn FCZ1829604J
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username cisco privilege 15 secret 5 $1$44gd$pvcB6PwkI9a4sgXhV7075.
username admin privilege 15 secret 5 $1$gB0E$rPx95YRpsXC4.GRfTnHGE1
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.31.255.246 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 10.39.255.1 255.255.255.252
duplex auto
speed auto
!
router bgp 65040
bgp log-neighbor-changes
aggregate-address 10.39.0.0 255.255.0.0
neighbor 10.39.255.2 remote-as 65040
neighbor 10.39.255.2 password 7 08036969263A
neighbor 10.39.255.2 fall-over bfd
neighbor 10.39.255.2 soft-reconfiguration inbound
neighbor 172.31.255.245 remote-as 65000
neighbor 172.31.255.245 password 7 112B3C223831
neighbor 172.31.255.245 fall-over bfd
neighbor 172.31.255.245 soft-reconfiguration inbound
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ip access-list standard BGP_DAMP
permit 172.31.255.246
!
!
nls resp-timeout 1
cpd cr-id 1
route-map BGP_DAMP permit 10
match ip address BGP_DAMP
set dampening 5 1900 2000 10
!
!
!
control-plane
!
!
!
!
!
!
!
mgcp profile default
!
!
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 106C2C3E2A34
login local
transport input all
!
scheduler allocate 20000 1000
!
end
But also connected core switch and established iBGP between them ,but unfortunately core switch doesnt have route to others ,
i 0.0.0.0 172.31.255.245 0 100 0 65000 65456 29049 i
* i 10.0.0.0/16 172.31.255.245 0 100 0 65000 65001 i
* i 10.1.0.0/16 172.31.255.245 0 100 0 65000 65001 i
* i 10.1.1.32/28 172.31.255.245 0 100 0 65000 65002 i
* i 10.2.0.0/16 172.31.255.245 0 100 0 65000 65002 i
* i 10.24.2.0/23 172.31.255.245 0 100 0 65000 65001 i
* i 10.24.4.0/24 172.31.255.245 0 100 0 65000 65001 i
* i 10.24.6.0/23 172.31.255.245 0 100 0 65000 65001 i
* i 10.24.8.0/23 172.31.255.245 0 100 0 65000 65002 i
*> 10.39.0.0/24 0.0.0.0 0 32768 ?
* i 10.39.0.0/16 10.39.255.1 0 100 0 i
*> 0.0.0.0 32768 i
*> 10.39.30.0/24 0.0.0.0 0 32768 ?
Network Next Hop Metric LocPrf Weight Path
*> 10.39.255.0/30 0.0.0.0 0 32768 ?
* i 10.100.0.0/22 172.31.255.245 0 100 0 65000 i
* i 10.102.0.0/16 172.31.255.245 0 100 0 65000 i
* i 10.202.0.0/16 172.31.255.245 0 100 0 65000 i
* i 31.171.126.128/26
172.31.255.245 0 100 0 65000 65001 i
*
172.31.255.245 0 100 0 65000 65002 65002 65002 65002 i
* i 172.16.8.0/22 172.31.255.245 0 100 0 65000 65001 i
* i 172.17.0.0/17 172.31.255.245 0 100 0 65000 65001 i
* i 172.17.128.0/17 172.31.255.245 0 100 0 65000 65001 i
* i 172.18.0.0/17 172.31.255.245 0 100 0 65000 65002 i
* i 172.18.128.0/17 172.31.255.245 0 100 0 65000 65002 i
* i 172.30.0.0 172.31.255.245 0 100 0 65000 i
* i 172.30.252.0/24 172.31.255.245 0 100 0 65000 65456 i
* i 172.31.0.0 172.31.255.245 0 100 0 65000 i
* i 172.31.252.0/24 172.31.255.245 0 100 0 65000 65456 i
Anybody will help me ?
01-07-2015 12:38 AM
Check that on the core switch you have a route to the BGP next hop "172.31.255.245 ". If not, you need one of these:
a- A route to this ip
b- Route-reflector capability on the ASBR
c- next-hop-self on the ASBR
Remember that on iBGP relationships, the next-hop is not changed when propagating updates/routes
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide