06-10-2006 05:18 AM - edited 03-03-2019 03:35 AM
We have a catalyst 6509 with IOS version 12.1(26)E6. On a layer 3 interface can we configure trunking as normal router?
06-10-2006 05:20 AM
why dont you configure a SVI (interface vlan) and make this routed port a trunk?
ex:
vlan 10
vlan 20
int gi0/1
no swithport
ip address 10.1.1.1 255.255.255.0
---
then
int vlan 10
ip address 10.1.1.1 255.255.255.0
int gi0/1
switchport mode trunk
this way you can have trunk and still have your l3 routed interface, this is the good thing about Multilayer switches.
HTH,
vlad
06-10-2006 05:30 AM
yes you can but can you tell me your exact requirement...
if you want to configure your layer 3 interface as trunk then you can use the same configuration as in your previous post...
regards
Devang
06-10-2006 05:39 AM
In my previous post, i was testing the Catalyst espress 500 with cisco router 2801 and it works well. Then i want to deploy this solution to my production environment with catalyst 6509. What i want to do is : on the express 500 there are several vlans and i must give them routing capability over catalyst 6509. On cat 6509 i cant configure L3 as trunking as cisco 2801. It denies the command in the form "interface g2/1.1".
06-10-2006 05:52 AM
So, use interface vlans, and use interface gi2/1 as trunk.
int gi2/1
no switchport
switchport mode trunk
switchport trunk encap dot1q
take the IP address of this interface and create a vlan for it:
vlan 10
then create and SVI
interface vlan 10
ip address of int gi2/1
All vlans are inside the same subnet? if so you are good to go...all vlans will now have routing capability
HTH,
please remember to rate all posts.
Vlad
06-10-2006 05:58 AM
No all vlans have different subnet...
06-10-2006 06:03 AM
if you have the multiple vlan with the different subnet then you need to creat multiple svi by following the same procedure...do it...
regards
Devang
06-10-2006 06:03 AM
So, then you need to create 1 interface vlan for each subnet
int vlan 10
ip address 10.10.1.0 255.255.255.0
int vlan 20
ip address 10.10.2.0 255.255.255.0
create the vlans
vlan 10
vlan 20
use trunk on the interface giga...
and you'll have inter-vlan routing.
check this link:
http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008015f17a.shtml
Please rate all helpful post.
Vlad
06-10-2006 09:54 AM
Vlad,
Was there a typo in the example you gave above?
//
int gi2/1
no switchport
switchport mode trunk
switchport trunk encap dot1q
//
Right after "no switchport", you wouldn't be able to issue any command related to "switchport", since you've already negated it and made it a routed port.
06-10-2006 10:49 AM
routed interface
Yes, thanks for bringing that to my attention
It should be
switchport , meaning no longer a routed interface
thanks
Vlad
06-10-2006 05:59 AM
look at this example for creating trunk...
rate this post if it helps
regards
Devang
06-12-2006 05:52 AM
I have a similar question, where I have extended vlans on a 6513 out a trunked port (gi1/3) and now I need to bring additional remote sites that do not have layer 3 switches, only 2821 routers. I can't seem to think of a way to attach the 2821 without an access port at the remote site other than changing the 6513 to an access port or a routed port.
Do you have any suggestions?
Thanks,
Greg
06-13-2006 01:08 PM
What do you have at the remote sites, 2821 router and layer 2 switches?
Connect a trunk link from the switch to the router, and configure sub-interfaces on the router.
Basically you'll need to do router-on-a-stick for that site.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide