11-13-2004 02:30 PM - edited 03-02-2019 07:56 PM
Hello,
I installed 4 cisco 2620 routers with the linux computers. Cisco 2620 router has two FastEthernet interfaces. There is a linux computer between two cisco routers. Without cisco routers, there is no problem between two linux machines. Because I meausre the tcp throughput using 'iperf' it says '94Mbit/s' which seems fairly reasonable. However, The throughput between linux and linux through cisco 2620 is terrible - 8Mbit/s. I can't trust my result because the datasheet of Cisco 2620 says that it can handle over 26kpps. With the 1460byte packet, the through put should be over 100M. (26*1000*1460*8bit)/1024/1024.
So I am suspecting my simple configuration. Can anyone tell me what causes this happening? I didn't touch many configuration parameters.
Thank you in advance.
Testbed configuration
Cisco 2620 (FE 0/0) -----(Eth0) Linux (Eth1) --- (FE 0/0) Cisco 2620 (FE 0/1) ----- (Eth0) Linux (Eth1) --- ....
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1
!
!
ip subnet-zero
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
full-duplex
!
interface FastEthernet0/1
ip address 10.2.1.1 255.255.255.0
no ip directed-broadcast
full-duplex
interface FastEthernet0/1
ip address 10.2.1.1 255.255.255.0
no ip directed-broadcast
full-duplex
!
ip classless
ip route 10.1.0.0 255.255.0.0 10.1.1.2
ip route 10.2.0.0 255.255.0.0 10.2.1.2
ip route 10.3.0.0 255.255.0.0 10.2.1.2
ip route 10.4.0.0 255.255.0.0 10.2.1.2
ip route 10.5.0.0 255.255.0.0 10.2.1.2
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
11-15-2004 03:42 AM
I would check the speed/duplex settings on your Linux box as i believe by default they will be set to auto-negotiate.
If this is the case then both sides of your connection (linux and 2620 router) should be configured to auto negotiate.
You can change this on your router interfaces by using "duplex auto"
HTH
Paddy
11-15-2004 04:12 PM
I found out that the Full Duplex link sometimes is on and sometimes off. However in my IOS, there is no command "duplex".
In my Cisco routers, there is no duplex command. I think I need to upgrade current IOS.
Really appreciated.
router2(config-if)#?
Interface configuration commands:
access-expression Build a bridge boolean access expression
arp Set arp type (arpa, probe, snap) or timeout
backup Modify backup parameters
bandwidth Set bandwidth informational parameter
bridge-group Transparent bridging interface parameters
carrier-delay Specify delay for interface transitions
cdp CDP interface subcommands
cmns OSI CMNS
custom-queue-list Assign a custom queue list to an interface
default Set a command to its defaults
delay Specify interface throughput delay
description Interface specific description
exit Exit from interface configuration mode
fair-queue Enable Fair Queuing on an Interface
full-duplex Configure full-duplex operational mode
half-duplex Configure half-duplex and related commands
help Description of the interactive help system
hold-queue Set hold queue depth
11-16-2004 01:46 AM
Hi,
On your router interfaces connecting to your Linux servers, try using
"no full-duplex"
This should set your interfaces to auto negotiate.
You can confirm this on say interface FastEthernet0/0 by:
a) running "show interface Fastt Ethernet 0/0", if both sides are set to auto then you will see " Full-duplex, 100Mb/s" in the output
b) do a show run and look for FastEthernet0/0 (depending on your IOS version you can do "show run int FastEthernet0/0"). The interface configuration should look like:
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
and nothing else.
Good luck
Paddy
11-15-2004 12:48 PM
I have a 2620 router but it only has one FE interface, so I guess the second one is one a WIC card, is it?
I agree with the other response - check the duplex settings on your servers. The one combination that will not work well is auto-full, because the lack of negotiation will force the auto side to revert to half duplex. auto-auto works OK, and auto-half happens to work out, but auto-half is a no-no.
You can tell when you have a duplex mismatch because the full-duplex side (in this case your router) starts counting up lots of runts and framing errors, shown in the show int.
Kevin Dorrell
Luxembourg
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide