cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
268
Views
10
Helpful
2
Replies

configuring isdn

saviopereira
Level 1
Level 1

hi i am tring to configure ISDN line on Cisco803 router's between two location however i am not able to make connection , please have look on thr config and advise me

thankyou

router 1

exhibition#show config

Using 977 out of 8078 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxx

no logging on

enable secret xxxxxx

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 192.168.3.1 255.255.255.0

!

interface BRI0

ip address 192.168.1.2 255.255.255.0

encapsulation ppp

dialer wait-for-carrier-time 60

dialer map ip 192.168.1.3 name main broadcast 17218515

dialer-group 1

isdn switch-type basic-net3

isdn twait-disable

isdn autodetect

ppp multilink

!

interface Dialer0

no ip address

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer hold-queue 10

dialer load-threshold 150 outbound

dialer-group 1

ppp authentication pap

ppp multilink

!

ip classless

ip route 192.168.2.0 255.255.255.0 192.168.1.3

ip http server

!

!

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line vty 0 4

login

!

no rcapi server

router 2

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxx!

no logging on

enable secret xxxxx

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

!

interface BRI0

ip address 192.168.1.3 255.255.255.0

encapsulation ppp

dialer wait-for-carrier-time 60

dialer map ip 192.168.1.2 name main broadcast 17298296

dialer-group 1

isdn switch-type basic-net3

isdn twait-disable

isdn autodetect

ppp multilink

!

interface Dialer0

no ip address

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer hold-queue 10

dialer load-threshold 150 outbound

dialer-group 1

ppp authentication pap

ppp multilink

!

ip classless

ip route 192.168.3.0 255.255.255.0 192.168.1.2

ip http server

!

!

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line vty 0 4

login

!

no rcapi server

!

!

,

2 Replies 2

Hello,

you need to add the following to both routers (the routernames might actually differ form what you have, the password as well, but it must be the same on both sides):

Router 1

username R1 password 0 cisco

interface Dialer 0

ppp pap sent-username R1 pasword cisco

Router 2

username R2 password 0 cisco

interface Dialer 0

ppp pap sent-username R2 pasword cisco

HTH,

Georg

A quick correction: that snippet should read:

Router 1

username R2 password 0 cisco

interface Dialer 0

ppp pap sent-username R1 password cisco

Router 2

username R1 password 0 cisco

interface Dialer 0

ppp pap sent-username R2 password cisco

There must be a username/password entry on each router for the username and password sent by the _other_ router. And both routers must agree on the password they are using with each other ("cisco" in this case). Also be aware that there need to be two "s"s in password :-).