07-08-2003 02:21 PM - edited 03-02-2019 08:42 AM
I am attempting to connect to 1751 routers w/serial interfaces via t1 line. Router "A" (host side) is identical to router "B" remote side. I want to keep them on the same subnet for simplicity purposes. I have performed this feat with csu/dsu modules in the past, but never with serial interfaces. Host side has an internet gateway seperate from the router itself - which the remote side will need access to also. For the life of me I cannot figure out what I am doing wrong. This is the configuration from router "A", router "B's" configuration is identical except for the BVI 1 IP address is x.x.x.22 instead of x.x.x.21. Any help is greatly appreciated.
Using 876 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1
!
enable password xxxx
!
memory-size iomem 25
ip subnet-zero
no ip domain lookup
!
!
!
bridge irb
!
!
interface FastEthernet0/0
description connected to EthernetLAN_1
no ip address
no keepalive
speed auto
bridge-group 1
!
interface Serial0/0
description connected to CiscoB
ip unnumbered FastEthernet0/0
bridge-group 1
!
interface BVI1
ip address 192.168.0.21 255.255.255.0
!
router rip
version 2
network 192.168.0.0
no auto-summary
!
ip classless
no ip http server
!
!
snmp-server community public RO
snmp-server enable traps tty
bridge 1 protocol ieee
!
line con 0
exec-timeout 0 0
password xxxx
login
line aux 0
line vty 0 4
password xxxx
login
!
no scheduler allocate
end
Solved! Go to Solution.
07-10-2003 09:07 AM
Have you tried HDLC encap ? Your LCP is not coming up in PPP , If you change to HDLC encap and you still get protocol down , you need to investigate the CSU being misconfigured ,
Can tou paste in a sh serial X from the B router
07-10-2003 09:15 AM
I have tried HDLC to no avail. I can post sh serial X from the B router - but that will be later as I have no connection to remote router at this point. Should I go back to HDLC at this point?
07-10-2003 09:18 AM
It is the easiest to configure , as long as it a Cisco box that is attached on the other end , I would use HDLC .
07-10-2003 09:30 AM
Yes, two identical cisco 1751 brand spankin new on each side. Let me ask you another question, If the remote router "B" is still on PPP encap aand I have changed the host router "A" to HDLC - should i be able to get a s0/0 is up - line protocol up on the host side? Thanks for all your advice - has been a big help so far.
07-10-2003 09:51 AM
no you must use the same encap on each end HDLC>>>HDLC or PPP >>.PPP , If you are using boxes from differnet vendors on a point to point link you have to use PPP.
07-10-2003 11:25 AM
I know for communication between the two routers each encap has to be the same. But will that in itself cause the message "int s0/0 is up - line protocol down"? I can get the "line protocol" to stay up for a minute or two - and back down.
07-10-2003 11:40 AM
Yes it will, What brings up and keeps up your line protocol the the tranmitting and receipt of keepalive packets . The line protocol will drop after 3 keepalives are missed .
07-10-2003 11:44 AM
Thanks - I am heading to the remote site to switch the encap & clock rate. I had already posted the debug info before I got to this post.
07-10-2003 11:48 AM
I thought you said this is using an external CSU that is provided by the Telco , Who is providing clock , you may not need to set clock on the serial interface , Also the config on the B router can't be the same if you are providing clock on the B router , Does the B router have a DTE or a DCE cable attached ?
07-10-2003 02:12 PM
It has the v.35 winchester cable. True - using external csu/dsu. Telcom said we would need to set the clock - for me, I thought with serial connection it did not matter.
07-11-2003 07:50 AM
Either the csu/dsu or the provider will have to supply clock , You can supply clock on a serial interface with a DCE cable attached , I wouls not recommend this for a long haul wide area connection . If you have access the the Csu's configure one to provide clock and the other to look for clock from the network.
07-11-2003 10:25 AM
I am now in the process of setting to default configuration on both. I will put each on it's own subnet and see what happens. Will let you know.
07-11-2003 11:49 AM
take a look at the following config. I reset both router to defaults (erased) and started from scratch. Router "A" is now on 192.168.0.21 and Router "B" 192.168.10.22 - each on their own subnets. The s0/0 line protocol still toggles up/down about every 10 seconds - toggling faster than before, but still not remaining up. HDLC on both ends. I have called the telecom - "they are investigating", but state everything appears fine from their site. Thanks
sh config
Using 786 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-xxx!
hostname CiscoA
!
enable password xxxx
!
memory-size iomem 25
ip subnet-zero
no ip domain lookup
!
!
!
!
!
interface FastEthernet0/0
description connected to EthernetLAN_1
ip address 192.168.0.21 255.255.255.0
no keepalive
speed auto
!
interface Serial0/0
description connected to CiscoB
ip unnumbered FastEthernet0/0
no logging event link-status
!
router rip
version 2
network 192.168.0.0
no auto-summary
!
ip classless
no ip http server
!
!
snmp-server community public RO
snmp-server enable traps tty
!
line con 0
exec-timeout 0 0
password xxx
login
line aux 0
line vty 0 4
password xxxx
login
!
end
*****************************************
CiscoA#sh interface fastethernet0/0
FastEthernet0/0 is up, line protocol is up
Hardware is PQUICC_FEC, address is 000b.466b.3bf0 (bia 000b.466b.3bf0)
Description: connected to EthernetLAN_1
Internet address is 192.168.0.21/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:02, output 00:00:19, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
30 packets input, 4027 bytes
Received 30 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
7 packets output, 1625 bytes, 0 underruns
3 output errors, 0 collisions, 3 interface resets
0 babbles, 0 late collision, 0 deferred
3 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
******************************************
CiscoA#sh int s0/0
Serial0/0 is up, line protocol is up
Hardware is PowerQUICC Serial
Description: connected to CiscoB
Interface is unnumbered. Using address of FastEthernet0/0 (192.168.0.21)
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 247/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input 00:00:04, output 00:00:03, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/2/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
21 packets input, 504 bytes, 0 no buffer
Received 21 broadcasts, 0 runts, 0 giants, 0 throttles
9 input errors, 0 CRC, 9 frame, 0 overrun, 0 ignored, 0 abort
63 packets output, 8512 bytes, 0 underruns
0 output errors, 0 collisions, 12 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
CiscoA#
07-11-2003 02:28 PM
the config looks ok , what about the B router config ? ALso did you find out who is providing clock ? "Find out from the telco . Also who owns the Csu's , like I said before either one of the cs's or the telco is going to have to supply clock.
07-29-2003 06:57 PM
After weeks of telcom stating everything is ok on their end, we find out they have a bad v.35 jack on the host side. Plugged my config back in on both routers and they work. Thanks for hanging in there with me and helping out.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide