08-30-2004 08:12 AM - edited 03-02-2019 06:07 PM
Hello,
I've got two 7206 routers with E1 cards and I'm trying to setup routing between them locally. I've got the two routers connected with a cross-connect cable between Serial5/0 on each router. My config for each side is the same,
interface Serial5/0:0
description ppp channel 5
ip address 192.168.34.1 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay IETF
ip mroute-cache
no fair-queue
frame-relay interface-dlci 16
frame-relay lmi-type ansi
frame-relay intf-type dce
And I've got a default router of 0.0.0.0 0.0.0.0 192.168.32.0
My problem is I've got PC's off each routers Ethernet port and I can't get a ping to reach the far side of the router. I can ping the local router's E1 interface but no further. From each routers console I can ping the other routers E1 interfacae but not it's own.
Does anyone have any advice for me? I'm losing the battle here!
Thanks,
...Joe
Solved! Go to Solution.
08-31-2004 12:27 AM
Your ip addressing is not proper. From your config, I think that the E1 controllers on port 5/0 are connected together. They should be on the same ip address subnet, but they seem not to be. Also, for your routing config, use a destination address like 192.168.32.0 rather than a network like 192.168.32.0.
08-31-2004 02:17 AM
Im suprised your serial interfaces can ping each other as they are in different IP subnets. Unless that is, there is another route for these interfaces to reach each other via another connection.
Regardless, the serial interface config needs correcting. Both serial interfaces on the active FR link should to be in the same subnet.
08-30-2004 08:15 AM
Oh, and I should note, both interfaces are not set to the same IP addr. One is 192.168.32.1 and the other is 192.168.34.1....
...Joe
08-30-2004 12:51 PM
Joe,
Can you post a copy of the output from the two commands "show run" and then a "show ip route" from each router?
Thanks,
sp
08-30-2004 01:00 PM
Hi,
And thanks for taking a look at this. Here are the sh run and ip routes:
sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2c_rtr_east
!
enable secret xxxx
enable password xxxx
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
--More-- !
frame-relay switching
!
!
!
!
controller E1 5/0
channel-group 0 timeslots 1-31
!
controller E1 5/1
channel-group 0 timeslots 1-31
!
!
process-max-time 200
gateway
!
!
Ethernet1/0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
no cdp enable
!
interface Ethernet1/1
ip address 156.x.x.x.255.255.0
no ip directed-broadcast
no cdp enable
!
!
interface Serial5/0:0
description ppp channel 5
ip address 192.168.34.1 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay IETF
ip mroute-cache
no fair-queue
frame-relay interface-dlci 16
frame-relay lmi-type ansi
frame-relay intf-type dce
!
interface Serial5/1:0
ip address 192.168.32.3 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
fair-queue 64 16 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.34.0
no ip http server
--More-- !
no cdp run
!
c2c_rtr_east#sh ip route
Gateway of last resort is 192.168.34.0 to network 0.0.0.0
156.23.0.0/24 is subnetted, 1 subnets
C 156.23.150.0 is directly connected, Ethernet1/1
C 192.168.34.0/24 is directly connected, Serial5/0:0
S* 0.0.0.0/0 [1/0] via 192.168.34.0
c2c_rtr_west#sh config
Using 2121 out of 129016 bytes
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2c_rtr_west
!
enable secret xxxx
enable password xxxxx
!
syscon address 156.x.x.100 password
syscon shelf-id 0
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
no ip bootp server
--More-- ip audit notify log
ip audit po max-events 100
!
!
frame-relay switching
!
!
!
!
controller E1 5/0
channel-group 0 timeslots 1-31
!
controller E1 5/1
!
!
process-max-time 200
gateway
!
!
!
interface Ethernet2/0
ip address 156.x.x.x.255.255.0
no ip directed-broadcast
no ip mroute-cache
no cdp enable
bridge-group 1
!
interface Ethernet2/1
ip address 156.x.x.x.255.255.0
no ip directed-broadcast
no ip mroute-cache
no cdp enable
--More-- !
!
interface Serial5/0:0
description ppp channel 5
ip address 192.168.32.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay IETF
ip mroute-cache
fair-queue 64 16 0
cdp enable
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
ip classless
--More-- ip route 0.0.0.0 0.0.0.0 192.168.32.0
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
bridge 1 protocol dec
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password xxx
login
!
!
end
c2c_rtr_west#sh ip route
Gateway of last resort is 192.168.32.0 to network 0.0.0.0
156.23.0.0/24 is subnetted, 2 subnets
C 156.23.152.0 is directly connected, Ethernet2/1
C 156.23.151.0 is directly connected, Ethernet2/0
C 192.168.32.0/24 is directly connected, Serial5/0:0
S* 0.0.0.0/0 [1/0] via 192.168.32.0
08-30-2004 01:42 PM
If I understood you correctly earlier, you stated that the routers coul dping each other via their serial interface - Is that the case?
08-30-2004 02:41 PM
Yes, that is correct. From the routers console, I can ping the other routers E1 interface but no further. From a PC, I can ping the Eth0 interface, then the E1 interface, then no further. So the routing is stopping at the E1 interface on each router.....
08-31-2004 12:27 AM
Your ip addressing is not proper. From your config, I think that the E1 controllers on port 5/0 are connected together. They should be on the same ip address subnet, but they seem not to be. Also, for your routing config, use a destination address like 192.168.32.0 rather than a network like 192.168.32.0.
08-31-2004 09:44 AM
You are correct!!! That fixed the problem. I addr'd the 34.1 interface to 32.1 and did static routes to the far side Ethernet ports and all is well!
Thanks so much!!!
...Joe
08-31-2004 02:17 AM
Im suprised your serial interfaces can ping each other as they are in different IP subnets. Unless that is, there is another route for these interfaces to reach each other via another connection.
Regardless, the serial interface config needs correcting. Both serial interfaces on the active FR link should to be in the same subnet.
08-31-2004 09:46 AM
You are correct!!! That fixed the problem. I addr'd the 34.1 interface to 32.1 and did static routes to the far side Ethernet ports and all is well!
I'm not sure why I could ping each interface. Maybe because I did a 0.0.0.0 0.0.0.0 192.168.32.0 route on each box?
Thanks so much!!!
...Joe
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide