08-30-2004 11:41 AM - edited 03-02-2019 06:07 PM
Hello,
I'm trying to route Frame Relay in a test lab and have not been successful yet. I've got two 7206 routers, with IOS 12.0, and E1 serial cards. I've got the E1's cross connected with an RJ45 cable... link lights are good. I've setup each E1 as a frame relay with dlci 16.... sh frame-relay pvc looks good. I've alos got a PC on each router hanging off the Eth0 port.... My goal is to have each PC able to ping the other through the routers. So far on each side, the PC can ping it's Eth interface and the Serial5/0:0 interface, but no further....
Here are a copy of my configs for each router... Can someone tell me where I'm going wrong?
Thanks,
...Joe
sh run
frame-relay switching
!
!
!
!
controller E1 5/0
channel-group 0 timeslots 1-31
!
controller E1 5/1
channel-group 0 timeslots 1-31
!
!
process-max-time 200
gateway
!
!
interface Ethernet1/0
ip address 192.168.33.1 255.255.255.0
no ip directed-broadcast
no cdp enable
!
interface Ethernet1/1
ip address 156.23.150.2 255.255.255.0
no ip directed-broadcast
no cdp enable
!
!
interface Serial5/0:0
description ppp channel 5
ip address 192.168.34.1 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay IETF
ip mroute-cache
no fair-queue
frame-relay interface-dlci 16
frame-relay lmi-type ansi
frame-relay intf-type dce
!
interface Serial5/1:0
ip address 192.168.32.3 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
fair-queue 64 16 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.34.0
no ip http server
--More-- !
no cdp run
!
Gateway of last resort is 192.168.34.0 to network 0.0.0.0
156.23.0.0/24 is subnetted, 1 subnets
C 156.23.150.0 is directly connected, Ethernet1/1
C 192.168.34.0/24 is directly connected, Serial5/0:0
S* 0.0.0.0/0 [1/0] via 192.168.34.0
This is the second routers config:
c2c_rtr_west#sh config
Using 2121 out of 129016 bytes
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2c_rtr_west
!
frame-relay switching
!
!
!
!
controller E1 5/0
channel-group 0 timeslots 1-31
!
controller E1 5/1
!
!
process-max-time 200
gateway
!
!
!
interface Ethernet2/0
ip address 156.23.151.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no cdp enable
bridge-group 1
!
interface Ethernet2/1
ip address 156.23.152.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no cdp enable
interface Serial5/0:0
description ppp channel 5
ip address 192.168.32.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay IETF
ip mroute-cache
fair-queue 64 16 0
cdp enable
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
ip classless
--More-- ip route 0.0.0.0 0.0.0.0 192.168.32.0
no ip http server
08-30-2004 11:51 AM
Hello,
you only need to enable frame-relay switching on one of the routers. I would take it out of the config of the second router. In addition, you need to add the ´clock rate´ command to the interface configuration of your first router:
interface Serial5/0:0
description ppp channel 5
ip address 192.168.34.1 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay IETF
ip mroute-cache
no fair-queue
--> clock rate 64000
frame-relay interface-dlci 16
frame-relay lmi-type ansi
frame-relay intf-type dce
Can you try and see if that helps ?
Regards,
Georg
08-30-2004 11:55 AM
Hi Georg,
I'll go over and try the clock rate and remove the frame-relay switching off the second router and report back.
Thanks!!!
...Joe
08-30-2004 12:33 PM
Hi Georg,
Nope, the clock rate and removal of the second frame-relay switching did not help...
Should i have both router interfaces set to dlci 16? Or should they be different?
Do I need to run rip? Or maybe specify a neighbor?
I'm really lost as to why this doesn't work....
Is there some show commands that would be helpful in finding out where I've gone wrong?
Thanks,
...Joe
08-31-2004 05:12 PM
From the config of the first router:
interface Serial5/0:0
description ppp channel 5
ip address 192.168.34.1 255.255.255.0
From the config of the second router:
interface Serial5/0:0
description ppp channel 5
ip address 192.168.32.2 255.255.255.0
If this is in fact your back to back connection then put them into the same network and subnet.
HTH
Rick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide